package libp11-kit-gnome-keyring 3.20.1-1ubuntu1 failed to install/upgrade: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which has multiple installed instances

Bug #1768541 reported by Fondfire on 2018-05-02
212
This bug affects 59 people
Affects Status Importance Assigned to Milestone
gnome-keyring (Ubuntu)
Undecided
Iain Lane
Bionic
Undecided
Iain Lane

Bug Description

installation of this package failed, upgrading from 17.10.

ProblemType: Package
DistroRelease: Ubuntu 18.04
Package: libp11-kit-gnome-keyring 3.20.1-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
Uname: Linux 4.15.0-20-generic x86_64
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Wed May 2 01:39:47 2018
Dependencies:
 gcc-8-base 8-20180414-1ubuntu2
 libc6 2.27-3ubuntu1
 libgcc1 1:8-20180414-1ubuntu2
DuplicateSignature:
 package:libp11-kit-gnome-keyring:3.20.1-1ubuntu1
 Unpacking gnome-keyring (3.28.0.2-1ubuntu1) over (3.20.1-1ubuntu1) ...
 dpkg: error processing archive /tmp/apt-dpkg-install-PlRQuy/0830-libp11-kit-gnome-keyring_3.28.0.2-1ubuntu1_all.deb (--unpack):
  libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which has multiple installed instances
ErrorMessage: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which has multiple installed instances
Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal, 3.6.5-3
PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal, 2.7.15~rc1-1
RelatedPackageVersions:
 dpkg 1.19.0.5ubuntu2
 apt 1.6.1
SourcePackage: gnome-keyring
Title: package libp11-kit-gnome-keyring 3.20.1-1ubuntu1 failed to install/upgrade: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which has multiple installed instances
UpgradeStatus: Upgraded to bionic on 2018-05-02 (0 days ago)

Fondfire (fondfire) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-keyring (Ubuntu):
status: New → Confirmed
Shomz (shomz) wrote :

I've removed the problematic library and was able to finish the installation/upgrade with no issues.

# apt remove libp11-kit-gnome-keyring

The keyring seems fine as well. Still not sure if this is the way to go.

Changed in gnome-keyring (Ubuntu):
assignee: nobody → Iain Lane (laney)
antonio balentinu (balentinu) wrote :

As Shomz I removed the problematic library and I have not had any problems for now. We will see with the subsequent updates how everything will work.

Iain Lane (laney) wrote :

Anyone affected - were you using any PPAs?

David Kastrup (dak) wrote :

Pretty sure at least I did at several points in the past. Not sure they were active at the time of the report, though.

Iain Lane (laney) wrote :

I'm thinking that Multi-Arch: foreign on the transitional package libp11-kit-gnome-keyring might help.

If someone wants to verify that, please do, otherwise I'll try tomorrow.

Adam Conrad (adconrad) wrote :

From IRC:

11:15 < infinity> Laney: You can't move from MA:same to arch:all.
11:15 < infinity> Laney: You need to use an MA:same transitional as well.
11:17 < infinity> Laney: arch:all by definition can only have one version/copy installed, so your
                  transitional upgrades on the primary arch, and ends up conflicting out any other
                  arch versions of the old package.
11:18 < infinity> Laney: Ran into this same issue with e2fslibs when Ted tried to do what you did.
                  Went very poorly until I fixed it. :P

Adam Conrad (adconrad) wrote :

See e2fsprogs for the fix there, which almost certainly is needed here too:

http://launchpadlibrarian.net/357614118/e2fsprogs_1.43.9-1_1.43.9-1ubuntu1.diff.gz

Iain Lane (laney) on 2018-05-09
Changed in gnome-keyring (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → Iain Lane (laney)
Changed in gnome-keyring (Ubuntu):
status: Confirmed → Fix Committed
Iain Lane (laney) wrote :

Uploaded to bionic queue, sru description to follow once I've worked out a reproer

Hello Fondfire, or anyone else affected,

Accepted gnome-keyring into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-keyring/3.28.0.2-1ubuntu1.18.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-keyring (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 3.28.0.2-1ubuntu2

---------------
gnome-keyring (3.28.0.2-1ubuntu2) cosmic; urgency=medium

  * debian/control{,.in}: Drop old transitional package
    libp11-kit-gnome-keyring; it's not needed past an LTS. (LP: #1768541)

 -- Iain Lane <email address hidden> Wed, 09 May 2018 20:05:34 +0100

Changed in gnome-keyring (Ubuntu):
status: Fix Committed → Fix Released
Iain Lane (laney) wrote :

I can't construct a situation that makes this happen :(

Tried installing ubuntu-desktop and wine1.6 (depends on libp11-kit-gnome-keyring:i386) in xenial and dist-upgrading / do-release-upgrade -d and it doesn't happen...

Since this is accepted, can we just watch for the absence of new bug reports with the -proposed version?

I did the -proposed version if seems to me all is good (but I'm new to this - so take it with a grain of salt).

Same for me, it all appears to be ok. Sudo apt-get update/upgrade now also
seems to work without error messages

Op vr 11 mei 2018 09:11 schreef Scott Johnson <email address hidden>:

> I did the -proposed version if seems to me all is good (but I'm new to
> this - so take it with a grain of salt).
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1768541
>
> Title:
> package libp11-kit-gnome-keyring 3.20.1-1ubuntu1 failed to
> install/upgrade: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1
> (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring
> which has multiple installed instances
>
> Status in gnome-keyring package in Ubuntu:
> Fix Released
> Status in gnome-keyring source package in Bionic:
> Fix Committed
>
> Bug description:
> installation of this package failed, upgrading from 17.10.
>
> ProblemType: Package
> DistroRelease: Ubuntu 18.04
> Package: libp11-kit-gnome-keyring 3.20.1-1ubuntu1
> ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
> Uname: Linux 4.15.0-20-generic x86_64
> ApportVersion: 2.20.9-0ubuntu7
> Architecture: amd64
> Date: Wed May 2 01:39:47 2018
> Dependencies:
> gcc-8-base 8-20180414-1ubuntu2
> libc6 2.27-3ubuntu1
> libgcc1 1:8-20180414-1ubuntu2
> DuplicateSignature:
> package:libp11-kit-gnome-keyring:3.20.1-1ubuntu1
> Unpacking gnome-keyring (3.28.0.2-1ubuntu1) over (3.20.1-1ubuntu1) ...
> dpkg: error processing archive
> /tmp/apt-dpkg-install-PlRQuy/0830-libp11-kit-gnome-keyring_3.28.0.2-1ubuntu1_all.deb
> (--unpack):
> libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not
> co-installable with libp11-kit-gnome-keyring which has multiple installed
> instances
> ErrorMessage: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1
> (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which
> has multiple installed instances
> Python3Details: /usr/bin/python3.6, Python 3.6.5, python3-minimal,
> 3.6.5-3
> PythonDetails: /usr/bin/python2.7, Python 2.7.15rc1, python-minimal,
> 2.7.15~rc1-1
> RelatedPackageVersions:
> dpkg 1.19.0.5ubuntu2
> apt 1.6.1
> SourcePackage: gnome-keyring
> Title: package libp11-kit-gnome-keyring 3.20.1-1ubuntu1 failed to
> install/upgrade: libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1
> (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which
> has multiple installed instances
> UpgradeStatus: Upgraded to bionic on 2018-05-02 (0 days ago)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/1768541/+subscriptions
>

Michał Faflik (faflu) wrote :

Installed libp11-kit-gnome-keyring:amd64 (3.28.0.2-1ubuntu1.18.04.1) without any problems

Francesco De Caro (tecnomad) wrote :

With proposed the issue is solved.

Before:

dpkg: error processing archive /var/cache/apt/archives/libp11-kit-gnome-keyring_3.28.0.2-1ubuntu1_all.deb (--unpack):
 libp11-kit-gnome-keyring:all 3.28.0.2-1ubuntu1 (Multi-Arch: no) is not co-installable with libp11-kit-gnome-keyring which has multiple installed instances
Errors were encountered while processing:
 /var/cache/apt/archives/libp11-kit-gnome-keyring_3.28.0.2-1ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

After:

Get:1 http://archive.ubuntu.com/ubuntu bionic-proposed/universe amd64 libp11-kit-gnome-keyring amd64 3.28.0.2-1ubuntu1.18.04.1 [3.228 B]
Fetched 3.228 B in 0s (23,8 kB/s)
(Reading database ... 548794 files and directories currently installed.)
Preparing to unpack .../libp11-kit-gnome-keyring_3.28.0.2-1ubuntu1.18.04.1_amd64.deb ...
Unpacking libp11-kit-gnome-keyring:amd64 (3.28.0.2-1ubuntu1.18.04.1) over (3.20.1-1ubuntu1) ...
Setting up libp11-kit-gnome-keyring:amd64 (3.28.0.2-1ubuntu1.18.04.1) ...

tags: added: verification-done-bionic
removed: verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 3.28.0.2-1ubuntu1.18.04.1

---------------
gnome-keyring (3.28.0.2-1ubuntu1.18.04.1) bionic; urgency=medium

  * debian/control{,.in}: Make the transitional packages be Arch any and MA
    same, so upgrades work properly. (LP: #1768541)
  * Update Vcs-* for bionic.

 -- Iain Lane <email address hidden> Wed, 09 May 2018 20:19:29 +0100

Changed in gnome-keyring (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-keyring has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers