GNOME rarely starts from GDM in Hardy

Bug #175682 reported by Alexander Jones on 2007-12-11
16
Affects Status Importance Assigned to Milestone
GNOME Keyring
Fix Released
Medium
gnome-keyring (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gdm

About 90% of the time when logging in from GDM, gnome-session hangs.

I don't get any GNOME programs running, just a cursor and a blank, light brown background.

If I choose "Failsafe GNOME", the same happens, though for a few days this seemed to work.

I have cleaned my session, and I have even tried this with newly created users, and the same thing happens.

The only way I can get it to work is by using a "Failsafe Terminal" session and launching gnome-session from that.

Most of the time, this method works, but on rare occasions this method hangs in the same way, too. I can simply just kill it and try again in the same terminal and it will work.

I have a stack trace from what happens when it hangs:

Thread 1 (Thread 0xb6f166b0 (LWP 9474)):
#0 0xffffe410 in __kernel_vsyscall ()
#1 0xb7747973 in __read_nocancel () from /lib/tls/i686/cmov/libpthread.so.0
#2 0xb77ff3f9 in read_all (fd=16, buf=0x80ca5b8 "", len=4)
    at gnome-keyring.c:320
#3 0xb7800b15 in run_sync_operation (buffer=0xbff37194,
    receive_buffer=0xbff37180) at gnome-keyring.c:652
#4 0xb7801d9c in gnome_keyring_daemon_set_display_sync (
    display=0x80ca508 ":0.0") at gnome-keyring.c:1832
#5 0x0805d764 in ?? ()
#6 0x080ca508 in ?? ()
#7 0x00000006 in ?? ()
#8 0x00000000 in ?? ()
#0 0xffffe410 in __kernel_vsyscall ()

ProblemType: Bug
Architecture: i386
Date: Tue Dec 11 19:10:10 2007
DistroRelease: Ubuntu 8.04
NonfreeKernelModules: vmnet vmblock vmmon fglrx
Package: gdm 2.20.0-0ubuntu6
PackageArchitecture: i386
SourcePackage: gdm
Uname: Linux flash 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

Alexander Jones (alex-weej) wrote :
Richard Samson (richard) wrote :

I get the same issue. Have you desktop effects enabled ?

With autologin enabled in Gdm Gnome session loads fine.

Alexander Jones (alex-weej) wrote :

No, I'm using metacity. I'm not sure gnome-session even gets as far as starting a WM. At least with my dud session, I could ssh in and run programs and evidently, neither settings-daemon nor metacity were running.

Sebastien Bacher (seb128) wrote :

Could you attach the list of programs running? The backtrace seems to indicate a gnome-keyring issue rather than a gdm one. Does using startx to start xorg make it work correctly?

Sebastien Bacher (seb128) wrote :

There is http://bugzilla.gnome.org/show_bug.cgi?id=502603 upstream with a debug backtrace

Changed in gdm:
assignee: nobody → desktop-bugs
importance: Undecided → High
milestone: none → ubuntu-8.04
status: New → Triaged
prasopsuk (prasopsuks) wrote :

I get the same issue. i had desktop effects enabled.
no desktop after login.

Changed in gnome-keyring:
status: Unknown → New
Changed in gnome-keyring:
status: New → Confirmed
Changed in gnome-keyring:
status: Confirmed → Incomplete
Changed in gnome-keyring:
status: Incomplete → Confirmed
Jakob Malm (malmjakob) wrote :

I have the same problem. After logging in with GDM, if I kill the gnome-keyring-daemon process from a virtual console, Gnome starts up fine.

Changed in gnome-keyring:
status: Confirmed → Incomplete
Changed in gnome-keyring:
status: Incomplete → Confirmed
jluix (jljurado-ono) wrote :

I have the same problem. I'm almost decided to formatting the disk and go back to ubuntu 7.10.

I've disabled all effects, but it doesn't change anything

I upgraded from 7.10

jluix (jljurado-ono) wrote :

P.D.: I've been reading http://bugzilla.gnome.org/show_bug.cgi?id=502603 thread and I have to add that is not only a problem of x86_64, because my system is x86_32.

reynaldo (rverdejo) wrote :

Backtrace of the hanging gnome-keyring-daemon process.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 2.21.4-0ubuntu2

---------------
gnome-keyring (2.21.4-0ubuntu2) hardy; urgency=low

  * debian/patches/80_from_upstream_fix_login_hang.patch:
    - patch from upstream, fix login hanging sometimes due to gnome-keyring
      (LP: #175682)

 -- Sebastien Bacher <email address hidden> Fri, 11 Jan 2008 17:11:32 +0100

Changed in gnome-keyring:
status: Triaged → Fix Released
Sebastien Bacher (seb128) wrote :

The upload should fix the issue, would be nice if the people who run into the bug could comment after upgrade to say how it works

Ilkka Tuohela (hile) wrote :

Sorry but 2.21.4-0ubuntu2 did not make any difference at least to me.

BTW, the process running is started as

gnome-keyring -d --login

I could not find where it is started like this, could this be some old setup interfering?
The dbus method has different parameters.

eyko (eykosioux) wrote :

Still doesn't work. Updated yesterday and saw it was a patch for this particular bug. Until today, it had been working fine, I haven't updated anything since then nor changed any settings, but today after a restart, logon hanged again. I had to kill the process to get it going again.

I'd rather have gnome-keyring not startup automatically and put the password later on once in the desktop, is there a way to do it this way meanwhile?

reynaldo (rverdejo) wrote :

Sadly, as reported by eyko and llkka, this fix doesn't seem to make any difference. Here is
a new debug backtrace of the hang. I don't have a real time way to reproduce the bug anymore
because I don't have the offending laptop with me, I had to phone the owner to get this for us so
sorry for the delayed answer, hope it helps.

reynaldo (rverdejo) wrote :

Guess the status change is appropiated.

Changed in gnome-keyring:
status: Fix Released → In Progress
reynaldo (rverdejo) wrote :

There seems to be a fix here http://bugzilla.gnome.org/show_bug.cgi?id=502603#c27

Can anyone try it out?

reynaldo (rverdejo) wrote :

anyone/someone

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 2.21.5-0ubuntu2

---------------
gnome-keyring (2.21.5-0ubuntu2) hardy; urgency=low

  * debian/patches/90_from_upstream_fix_loging_hang.patch:
    - new patch from upstream to fix login hang issue (LP: #175682)

 -- Sebastien Bacher <email address hidden> Thu, 17 Jan 2008 14:21:36 +0100

Changed in gnome-keyring:
status: In Progress → Fix Released
Changed in gnome-keyring:
status: Confirmed → Fix Released

I have a problem familiar with bug #136529, where my Gnome-Desktop doesn't start from GDM. Is this fix also available for Gutsy Gibbon?

I have Ubuntu Gutsy Gibbon x86 installed. The radeon-driver for my graphics card (ATI Radeon X800) and the 3d desktop running. Before the bug appeared I had an update (quite big - approximately 30 MB of download-size). Unfortunately I didn't restart after that and I continued to install new software from the repositories (Tex Live, Lyx, the latex-plugin for gedit). On the next day as I entered username, password and finally return into the GDM login window, Gnome didn't start at all. Instead the following message in .xsession-errors comes up:

(process:5691): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.

(process:5695): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
/etc/gdm/Xsession: Beginning session setup...
/etc/profile: 17: id: not found
/etc/gdm/Xsession: 178: grep: not found
/etc/gdm/Xsession: 191: ls: not found
/etc/gdm/Xsession: Executing /usr/bin/gnome-session failed, will try to run x-terminal-emulator
exec: 204: x-terminal-emulator: not found

I tried the offered solutions from #136529 the best I could. But it didn't work (altering privileges to /tmp, remove gdm from boot, creating an alternate user, deleting .gnome2-directory from my home-folder, starting X from terminal). I suceeded in starting Gnome from recovery-mode with root-privileges via startx. But not with my ordinary user account.

I am very grateful for your help in advance.

Kind regards
Frank

Alexander Jones (alex-weej) wrote :

Frank, not the same bug -- this bug is fixed.

Alex Jones schrieb:
> Frank, not the same bug -- this bug is fixed.
>
>
Hi Alex,

thanks for your fast reply. Maybe a missunderstanding. I know that this
bug is fixed. But when I read the comment made by the Launchpad Janitor
I recognized that the patch is made for Hardy, not for Gutsy.

Is a patch automatically made available for all Ubuntu-Versions?

Sorry for causing inconvenience :)

Kind regards
Frank

Alexander Jones (alex-weej) wrote :

This bug never affected Gutsy. Your bug is an entirely different problem -- please open a new report with the same information you have posted here.

Thanks

reynaldo (rverdejo) wrote :

Confirmed as fixed by who I was helping to. Thanks all and sorry for the delay, it was hard to get a confirmation from him.
--
Bests

Changed in gnome-keyring:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.