Can't log out from Plasma session with SDDM

Bug #1407152 reported by Oded Arbel on 2015-01-02
168
This bug affects 32 people
Affects Status Importance Assigned to Milestone
gnome-keyring (Ubuntu)
Critical
Unassigned
Declined for Vivid by Dmitry Shachnev

Bug Description

With up to date vivid, when I choose "Log out" from the KDE menu, the log out process hangs and does not bring back the log in screen.

I am left with either a black screen (where the cursor can still move), or if some non-KDE programs were running when I issued the log out command, they may still be running.

Looking at the process list, I can see that sddm-helper has a couple of zombie childs. If I do `sudo killall sddm-helper`, the log in process completes and I can log in again.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: sddm 0.11.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.16.0-28.38-generic 3.16.7-ckt1
Uname: Linux 3.16.0-28-generic x86_64
ApportVersion: 2.15.1-0ubuntu1
Architecture: amd64
CurrentDesktop: KDE
Date: Fri Jan 2 21:57:24 2015
InstallationDate: Installed on 2015-01-01 (1 days ago)
InstallationMedia: Kubuntu 15.04 "Vivid Vervet" - Alpha amd64 (20141230)
SourcePackage: sddm
UpgradeStatus: No upgrade log present (probably fresh install)

Oded Arbel (oded-geek) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Changed in sddm (Ubuntu):
importance: Undecided → Critical
Adam Lyall (magicmyth) on 2015-02-28
tags: added: kubuntu
Philippe (hellodongfang) wrote :

Any plan to fix this bug?

Please:
- Report this bug to <https://github.com/sddm/sddm/issues>.
- Paste the new report URL here.
- Set this bug status back to "confirmed".

Thank you.

Changed in sddm (Ubuntu):
status: Confirmed → Incomplete
tags: added: asked-to-upstream
Jonathan Riddell (jr) on 2015-03-11
Changed in sddm (Ubuntu):
milestone: none → ubuntu-15.04
Jonathan Riddell (jr) wrote :

I was unable to log out today but after running apt full-upgrade and getting the latest sddm and reboot I was able to log out successfully

warning bug 1431332 maybe stop sddm starting at all :(

ockels (ockels) wrote :

@Jonathan Riddell (jr): Bug confirmed here too, sddm was at least starting before today's apt full-upgrade ... :( Now SDDM won't even start. I might add that switching to other users (which are manually added from the terminal, because the usermanagement is missing in systemsetting) didn't work either. It gave the same symptons as the black logging out bug.

Sherif (ali-sherif10) wrote :

I've this bug too. The screen wasn't completely black. I could see the logging out window. To complete logging out, you must press CTRL+ALT+backspace.

Adam Lyall (magicmyth) wrote :

@ockels (ockels): Ubuntu's latest updates have switched the init system from Upstart to Systemd but it does not seem to enable the sddm service on start. The solution is to enter the following command:

sudo systemctl enable sddm.service -f
sudo reboot

Thanks for the solution go to Ricard (jeanmi-ricard) on bug 1431332.

Unfortunmatley the bug still persists even after the update of sddm and systemd. The workaround is still the same. Kill sddm-helper and the log in screen loads.

Adam Lyall (magicmyth) wrote :

I've opened an upstream bug report at:
https://github.com/sddm/sddm/issues/385

Changed in sddm (Ubuntu):
status: Incomplete → Confirmed

@ Adam Lyall

Thank you.

Changed in sddm (Ubuntu):
status: Confirmed → Triaged
no longer affects: sddm
Jonathan Riddell (jr) wrote :

Is the logout issue still a problem? on a fresh install from today's live CD I can successfully log out of my session from Plasma 5 and it will restart sddm asking for a new login

I just dist-upgraded and tried it and still get the black screen with mouse cursor. I don't think it's sddm as much as kde exiting cleanly. I checked with ps and there are a lot of tasks related to my desktop still running.

Jamie S. (jamiesexton35) wrote :

Still an issue with a fresh install too. To break it all that I did was install which booted and worked fine, install the nvidia drivers, rin apt-get update and dist-upgrade. Rebooted and after the login screen it's blank except the mouse. I can open a terminal though and launch apps from there.

Philippe (hellodongfang) wrote :

Same problem to me.

Looks like that Kde 5 still has a lot of bugs.

Luke Johnstone (john-wella) wrote :

I am fully up to date and still experiencing this issue.

As for the comment above, yes it has a few bugs, but it's pretty damn good for what I believe is almost a complete re-write! The KDE team has done a fantastic job! Keep it up :)

Jonathan Riddell (jr) on 2015-03-26
summary: - Can't log out from KDE 5
+ Can't log out from Plasma session with SDDM
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1407152

tags: added: iso-testing
Paul Worrall (nicknak) wrote :

This bug was fixed for me following a recent dist-upgrade

Adam Lyall (magicmyth) wrote :

Fixed here as well with the latest updates.

Marcin Sągol (soee) wrote :

I can also confirm that after latest updates, i can logout and login again.

Lee Donaghy (deadite66) wrote :

Still can't log out here, as i type this everything on the desktop is black apart from pidgin, thunderbird, firefox, conky and trayer are still on screen.

Luke Johnstone (john-wella) wrote :

Working for me this morning. Thanks guys

affects: sddm (Ubuntu) → gnome-keyring (Ubuntu)
Changed in gnome-keyring (Ubuntu):
status: Triaged → Fix Released
Lee Donaghy (deadite66) wrote :

Ignore my previous comment, reinstalled on a spare drive and logoff, shutdown and reboot works.
something must have gotten broken in all these weeks up updates.

Patrick T. (p1703) wrote :

Don't know, if this is the same bug. I'm using the final version of Kubuntu 15.04 (all published updates installed) - it's impossible to shutdown the pc properly. I get a black screen but it isn't switched off. So I have to switch it off manually and I'm scared about data on my possibly still mounted drives... Ctrl+Alt+F1 doesn't work. I think, keyboard doesn't accept anything at all (e.g. caps lock).

Hypernating is quite unstable - maybe it's related to this, maybe not, maybe this could be a hint for a systemd issue. I tried to hibernate 3 times:
1st time: didn't switch off at all - only the screen flickered and was locked afterwards
2nd time: switched off, but then switched on instantly
3rd time: switched off, but when I returned 1hr later, the computer was running, but it didn't respond.

I've had none of these problems in Kubuntu 14.10 or 14.04...

EdouardC (edouard-canot) wrote :

I'm using Ubuntu 15.04 and Unity, after an upgrade from 14.10 (64bit machine). My graphics card is Intel+AMD-Radeon and I'm using the last driver beta from AMD.

For me too, logout hangs (from Unity or even from FlashBack Metacity) : the screen becomes black and the air-fan blows...
Nevertheless, Suspend and Shutdown work well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers