p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory

Bug #1094319 reported by dobey on 2012-12-28
76
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-keyring (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Impact]
On a 64-bit system, this message can cause severe problems when running some 32-bit applications, such as wine. For example, attempting to run winecfg results in an infinite loop of these messages being printed to the console.

The p11-kit module needs to be moved to a separate multi-arch capable package, so that both arch versions may be installed.

[Test Case]
Install package(s) verify wine can run under amd64

[Regression Potentional]
Minimal, several rdepends build testing have been completed successfully and nothing in the keyring code is attempting to dlopen any hardcoded library paths.

[Additional]
ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-keyring 3.6.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-7.15-generic 3.7.0
Uname: Linux 3.7.0-7-generic x86_64
ApportVersion: 2.7-0ubuntu2
Architecture: amd64
Date: Fri Dec 28 12:39:36 2012
InstallationDate: Installed on 2012-10-21 (67 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: gnome-keyring
UpgradeStatus: Upgraded to raring on 2012-12-24 (3 days ago)

dobey (dobey) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 3.6.2-0ubuntu2

---------------
gnome-keyring (3.6.2-0ubuntu2) raring; urgency=low

  * debian/control:
    - Move the PKCS#11 module into a separate package. (LP: #1094319)
    - Convert to use multi-arch. (LP: #859600)
  * debian/gnome-keyring.install, debian/libp11-kit-gnome-keyring.*:
    - The pkcs11 module needs to be a separate package.
  * debian/libpam-gnome-keyring.install, debian/rules:
    - Use the multi-arch directory for the PAM module.
 -- Rodney Dawes <email address hidden> Mon, 07 Jan 2013 15:03:31 -0500

Changed in gnome-keyring (Ubuntu):
status: New → Fix Released
Adam Stokes (adam-stokes) wrote :

Rodney,

Are the debdiffs from bug 859600 also applicable here for Precise and Quantal? Bug 859600 is blocked on this one being SRU'd.

Thanks!
Adam

dobey (dobey) wrote :

The debdiffs for Quantal and Precise in bug #859600 should also fix this bug.

Adam Stokes (adam-stokes) wrote :
Adam Stokes (adam-stokes) wrote :

Thanks Rodney, gonna get these sponsored and in shape for SRU.

description: updated
Changed in gnome-keyring (Ubuntu Precise):
status: New → In Progress
Changed in gnome-keyring (Ubuntu Quantal):
status: New → In Progress

Hello Rodney, or anyone else affected,

Accepted gnome-keyring into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-keyring/3.2.2-2ubuntu4.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-keyring (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Peter Meiser (meiser79) wrote :

The Replaces line seems wrong. It's "Replaces: gnome-keyring (<< 3.6.2-0ubuntu2~)" in the precise package.

Trying to install the libp11-kit-gnome-keyring, I get the following output:

whoopie@laptop:~$ LANG=C sudo apt-get install libp11-kit-gnome-keyring
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  gir1.2-ubuntuoneui-3.0* gnome-keyring* libsyncdaemon-1.0-1* libubuntuoneui-3.0-1* oneconf* python-ubuntu-sso-client*
  python-ubuntuone-control-panel* rhythmbox-ubuntuone* seahorse* software-center* ubuntu-desktop* ubuntu-sso-client* ubuntu-sso-client-gtk*
  ubuntu-sso-client-qt* ubuntuone-client* ubuntuone-client-gnome* ubuntuone-control-panel* ubuntuone-control-panel-qt* unity-scope-musicstores*
The following NEW packages will be installed:
  libp11-kit-gnome-keyring
0 upgraded, 1 newly installed, 19 to remove and 0 not upgraded.
Need to get 47,1 kB of archives.
After this operation, 19,6 MB disk space will be freed.

Adam Conrad (adconrad) wrote :

Removed from precise-proposed due to the above regression. Please fix and reupload with a bumped version number.

tags: added: verification-failed
removed: verification-needed
Adam Conrad (adconrad) on 2013-06-05
Changed in gnome-keyring (Ubuntu Precise):
status: Fix Committed → In Progress
Jaime Rave (jaimerave) wrote :

I'm getting this error in Sausy too.

dobey (dobey) wrote :

@Jaime, do you have the :i386 version of the package installed? You'll need to install it as well as the 64-bit version, on 64-bit systems, when using wine:i386, to get rid of the error message.

Scott Long (enigmapond) wrote :

I'm getting this bug in Precise 32bit and no wine installed. It's not affecting the system in anyway that I can tell but it does show. Is there anyway to get rid of the error message? Thanks!

ajack38 (ajack-94) wrote :

This bug also affects me, I'm using raring 64-bit.

Sir Malheur (sirmalheur) wrote :

Hello, had the same error message when i was using wine
the solution for me was "sudo apt-get install libp11-kit-gnome-keyring:i386"

could some1 also post it here if you have an account: http://askubuntu.com/questions/127848/wine-cant-find-gnome-keyring-pkcs11-so

source: http://www.playonlinux.com/en/issue-2565.html

Sir Malheur (sirmalheur) wrote :

Ad comment #15:
I´m using wine 1.6 and ubuntu 13.04 (upgraded from 12.04, but i had the same error there)

Sir Malheur (sirmalheur) on 2013-08-15
Changed in gnome-keyring (Ubuntu Precise):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Stéphane Graber (stgraber) wrote :

Hello Rodney, or anyone else affected,

Accepted gnome-keyring into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-keyring/3.6.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-keyring (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: removed: verification-failed
tags: added: verification-needed
Graham Inggs (ginggs) wrote :

I ran 'wine notepad' and saw the following:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory

I installed gnome-keyring and libp11-kit-gnome-keyring:i386 from quantal-proposed.
I ran 'wine notepad' again and did not see the p11-kit warning.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 3.6.1-0ubuntu1.1

---------------
gnome-keyring (3.6.1-0ubuntu1.1) quantal; urgency=low

  * Backport the following changes from gnome-keyring in Raring:
    - Move the PKCS#11 module into a separate package. (LP: #1094319)
    - Convert gnome-keyring to multi-arch. (LP: #859600)
 -- Graham Inggs <email address hidden> Sat, 06 Jul 2013 11:07:07 +0200

Changed in gnome-keyring (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-keyring has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Peter Waller (peter.waller) wrote :

Any chance of an update for precise?

Graham Inggs (ginggs) wrote :

@peter.waller: see mterry's comment 80 in LP: #859600

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers