Wishlist: add patch from Gnome #338088 to allow password changing

Bug #54792 reported by Whoopie on 2006-08-01
30
Affects Status Importance Assigned to Milestone
GNOME Keyring
Expired
Wishlist
gnome-keyring-manager (Debian)
Fix Released
Undecided
Unassigned
gnome-keyring-manager (Ubuntu)
Wishlist
Ubuntu Desktop Bugs

Bug Description

Hi,

gnome-keyring already supports changing passwords. It would be great if you could change the passwords with gnome-keyring-manager.

There's a patch for it at http://bugzilla.gnome.org/show_bug.cgi?id=338088

Best regards,
Whoopie

Changed in gnome-keyring-manager:
importance: Untriaged → Wishlist
Changed in gnome-keyring:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Thanks for your bug. The patch is not trivial, that would be nice if upstream comment on it before we use it for the Ubuntu package

Changed in gnome-keyring-manager:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Paul Sladen (sladen) wrote :

This is probably too intrusive to add at this point. Upstream have since done a re-diff against their head and made one small update, even if it's not been applied or apparently had anything done with it.

Integrating 'libpam-keyring' into 'gdm' and 'gnome-screensaver' '/etc/pam.d' config files would avoid the need to do this. The other alternative is a command line utility just to change/reset the password.

Whoopie (whoopie79) wrote :

You can change the password with the testing version of the pam-keyring-tool (http://www.hekanetworks.com/opensource/pam_keyring/testing/pam_keyring-0.0.8.tar.gz) as libgnome-keyring0 has already support for changing the keyring password.

Whoopie (whoopie79) wrote :

Attached a patch patch for pam-keyring-tool to change password.

This would be Paul's mentioned alternative for a command line utility to change the password.

Changed in gnome-keyring-manager:
status: Unknown → Confirmed
Changed in gnome-keyring:
status: Unconfirmed → Confirmed
Whoopie (whoopie79) wrote :

Seahorse is now able to change the gnome-keyring password.

But how should the user know that?

Whoopie (whoopie79) wrote :

Closing this report because seahorse is doing the job now.

Changed in gnome-keyring-manager:
status: Confirmed → Invalid
Changed in gnome-keyring:
status: Confirmed → Invalid
Artur Rona (ari-tczew) wrote :

fixed-upstream

Changed in gnome-keyring-manager (Debian):
importance: Unknown → Undecided
status: Confirmed → New
status: New → Fix Released
Changed in gnome-keyring:
importance: Unknown → Wishlist
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.