Don't offer Facebook online account integration

Bug #1797736 reported by Jeremy Bicha on 2018-10-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Low
Jeremy Bicha

Bug Description

Impact
======
Ubuntu does not install any apps by default that would use Facebook account in GOA.

The supported apps are GNOME Photos and GNOME Maps.

Therefore, we shouldn't offer Facebook in the Online Accounts page of the Welcome to Ubuntu wizard.

The Online Accounts page isn't used in Ubuntu 18.04 LTS but it is used in Ubuntu 18.10

Test Case
=========
Install Ubuntu. After restarting your computer, the Welcome to Ubuntu wizard should launch. On the Online Accounts page, there should be Ubuntu Single Sign-On, Google, Nextcloud, and Microsoft. Facebook should not be present.

Or you can use a shortcut to avoid needing to re-install Ubuntu. Just remove the empty ~/.config/gnome-initial-setup-done file to restart the wizard.

Regression Potential
====================
None.

Users can still sign in to Facebook from the Online Accounts page in the Settings app.

GNOME doesn't show all the account types by default in gnome-initial-setup.

This will only affect the Ubuntu sessions. Any one who logs in for the first time in the vanilla GNOME sessions will still have this option and will generally get the upstream GNOME experience rather than the Welcome to Ubuntu experience.

Other Info
==========
The Welcome to Ubuntu wizard generally would only show up on first login (because the user should complete the wizard or close the wizard).

Many Ubuntu desktop installs only have one user.

Therefore, this won't be very beneficial as an SRU; it should be fixed before release.

This issue was split off from LP: #1762192

Jeremy Bicha (jbicha) on 2018-10-14
description: updated
Jeremy Bicha (jbicha) on 2018-10-14
description: updated
Changed in gnome-initial-setup (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Jeremy Bicha (jbicha)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.30.0-1ubuntu2

---------------
gnome-initial-setup (3.30.0-1ubuntu2) cosmic; urgency=medium

  * Add Don-t-show-Facebook-in-Ubuntu.patch:
    - Don't offer Facebook login in Welcome to Ubuntu wizard since
      none of Ubuntu's default apps will use it. (LP: #1797736)

 -- Jeremy Bicha <email address hidden> Sat, 13 Oct 2018 22:28:02 -0400

Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers