Link to Ubuntu Report legal notice points at the wrong page

Bug #1789925 reported by Will Cooke on 2018-08-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

* Impact

The legal notice URL is not pointing to the right page of the website

* Test case

- rm ~/.config/gnome-initial-setup-done
- gnome-initial-setup
- click on the 'legal notice' URL from the livepatch page

-> it should open https://www.ubuntu.com/legal/terms-and-policies/systems-information-notice

* Regression potential

It's just an URL change so just check that this reference is working

Related branches

Will Cooke (willcooke) on 2018-08-30
summary: - Link to Livepatch legal notice points at the wrong page
+ Link to Ubuntu Report legal notice points at the wrong page
Changed in gnome-initial-setup (Ubuntu):
importance: Undecided → High
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.29.92-1ubuntu2

---------------
gnome-initial-setup (3.29.92-1ubuntu2) cosmic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - update the livepatch page legal notice url (lp: #1789925)

 -- Sebastien Bacher <email address hidden> Mon, 03 Sep 2018 16:30:19 +0200

Changed in gnome-initial-setup (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-09-03
Changed in gnome-initial-setup (Ubuntu Bionic):
importance: Undecided → High
status: New → Triaged
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Triaged → Fix Committed
description: updated

Hello Will, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-bionic
Will Cooke (willcooke) wrote :

I'm running proposed on Bionic.
I upgraded and get this version:

$ apt-cache policy gnome-initial-setup
gnome-initial-setup:
  Installed: 3.28.0-2ubuntu6.16.04.3
  Candidate: 3.28.0-2ubuntu6.16.04.3
  Version table:
 *** 3.28.0-2ubuntu6.16.04.3 500
        500 http://archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.0-2ubuntu6.16.04.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
     3.28.0-2ubuntu6 500
        500 http://archive.ubuntu.com/ubuntu bionic/main amd64 Packages

This version still points to the wrong notice.

The version mentions 16.04, perhaps that's something to do with it?

tags: added: verification-failed-bionic
removed: verification-needed-bionic
Sebastien Bacher (seb128) wrote :

Unsure about the version, but the diff is
http://launchpadlibrarian.net/393333418/gnome-initial-setup_3.28.0-2ubuntu6.16.04.2_3.28.0-2ubuntu6.16.04.3.diff.gz

what page is being open exactly for you? and on what step of the initial setup did you try?

Will Cooke (willcooke) wrote :

The page being opened is: https://www.ubuntu.com/legal/dataprivacy
From the "Help Improve Ubuntu" page.

I disabled Livepatch, and re-ran g-i-s. The link from the Livepatch page *did* point to the https://www.ubuntu.com/legal/terms-and-policies/systems-information-notice page.

That's incorrect.

Livepatch page should point to: https://www.ubuntu.com/legal/dataprivacy
Ubuntu Report should point to: https://www.ubuntu.com/legal/terms-and-policies/systems-information-notice

Sebastien Bacher (seb128) wrote :

K, so you are right and I didn't understand the request properly. I'm reverting the change in another SRU which includes other fixes from Andrea to livepatch error handling, so marking that one as failed-verification.

The change is not as trivial as changing an URL now though, since the "ubuntu report" page is using the /etc/os-release PRIVACY_POLICY_URL value, so we need to update the code to not try to be as smart and just use a fixed URL.

We need to do/upload the change to disco/cosmic/bionic, I'm going to have a look to that but that's probably for next week

Sebastien Bacher (seb128) wrote :

Suggested change, removing the os-release parsing and pointing to a custom url, we don't want to have a reference ot the legal page but to the one detailling what informations we collect which is specific to this component

Changed in gnome-initial-setup (Ubuntu):
status: Fix Released → In Progress
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → In Progress
Brian Murray (brian-murray) wrote :

I did some digging and this doesn't seem to be fixed in Disco although livepatch support is included, but not enabled, there. Please get these changes into Disco.

Changed in gnome-initial-setup (Ubuntu Bionic):
status: In Progress → Incomplete
Sebastien Bacher (seb128) wrote :

Upload to disco now, new SRU in the cosmic review queue

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Incomplete → In Progress
Sebastien Bacher (seb128) wrote :

Uploaded to bionic as well

Brian Murray (brian-murray) wrote :

Hello Will, or anyone else affected,

Accepted gnome-initial-setup into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.30.0-1ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-initial-setup (Ubuntu Cosmic):
status: New → Fix Committed
tags: added: verification-needed-cosmic
Brian Murray (brian-murray) wrote :

Hello Will, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-initial-setup (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
removed: verification-failed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.30.0-1ubuntu4

---------------
gnome-initial-setup (3.30.0-1ubuntu4) disco; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - update the "legal notice" URL to use the one which is specific about
      ubuntu report (lp: #1789925)

 -- Sebastien Bacher <email address hidden> Wed, 31 Oct 2018 15:41:49 +0100

Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers