Display the ubuntu welcome wizard on Unity sessions

Bug #1781417 reported by Sebastien Bacher on 2018-07-12
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact

Unity users don't get the welcome wizard after upgrading to bionic

* Test case

- install 16.04
- upgrade to 18.04
- select unity in the session selector before first login

-> the wizard should be displayed but without the "what's new in ubuntu" page which describes GNOME

* Regression potential

Check that the wizard still work correctly under GNOME/Ubuntu sessions

Changed in gnome-initial-setup (Ubuntu):
importance: Undecided → Low
status: New → In Progress
description: updated
Sebastien Bacher (seb128) wrote :

change up for review on https://gitlab.gnome.org/Community/Ubuntu/gnome-initial-setup/merge_requests/7 which already got a +1 so I uploaded to cosmic (not updating the vcs because the layout in non standard and undocumented)

Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu13

---------------
gnome-initial-setup (3.28.0-2ubuntu13) cosmic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - typo fix in an error string (lp: #1777468)
  * debian/patches/0001-Display-the-ubuntu-welcome-wizard-in-Unity.patch:
    - Display the ubuntu welcome wizard in Unity, don't display the
      "what's new" page though since Unity didn't change (lp: #1781417)

 -- Sebastien Bacher <email address hidden> Thu, 12 Jul 2018 20:49:37 +0200

Changed in gnome-initial-setup (Ubuntu):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Hello seb! Thanks for the SRU. I was just wondering if it actually makes sense to get this SRUed. I mean, it probably is a bug that the welcome wizard is not displayed, but does it actually cause any inconveniences? What critical bits do the users miss out on when not seeing the welcome screen? Those are regular questions we're asking whenever a low-priority fix is being SRUed, since as always every SRU carries some risk involved (and generates an update to be downloaded by all users) - so I'd just like to be completely sure it's something we'd like to have for good reasons.

Sebastien Bacher (seb128) wrote :

Hey Łukasz. Those users are not being told about livepatch and cool applications available as snap, also they don't have the opportunity to help with metrics collecting. I'm not going to argue on whether those are "low" priority, we do believe they are useful to users though.

Will Cooke (willcooke) wrote :

Just to reiterate what Seb said - I think that its important that we give users the opportunity to send hardware metrics and be given the option to set up Livepatch.

Hello Sebastien, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I have reproduced the problem with gnome-initial-setup 3.28.0-2ubuntu6.16.04.1 in bionic-updates and have verified that the version of gnome-initial-setup 3.28.0-2ubuntu6.16.04.2 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu6.16.04.2

---------------
gnome-initial-setup (3.28.0-2ubuntu6.16.04.2) bionic; urgency=medium

  * debian/patches/0001-Display-the-ubuntu-welcome-wizard-in-Unity.patch:
    - Display the ubuntu welcome wizard in Unity, don't display the
      "what's new" page though since Unity didn't change (lp: #1781417)

 -- Sebastien Bacher <email address hidden> Thu, 12 Jul 2018 19:20:24 +0200

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-initial-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers