Crash when unable to get installed snaps

Bug #1768744 reported by errors.ubuntu.com bug bridge on 2018-05-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Status tracked in Cosmic
Bionic
Medium
Robert Ancell
Cosmic
Medium
Robert Ancell

Bug Description

[Impact]
gnome-initial-setup can crash when unable to get installed snaps:
https://errors.ubuntu.com/problem/f803e4a7c33f3626287e14841d092505a21e69ad

[Test Case]
1. Disable / remove snapd
2. Run gnome-initial-setup:
$ /usr/lib/gnome-initial-setup/gnome-initial-setup --existing-user

Expected result:
gnome-initial-setup continues to work.

Observed result:
gnome-initial-setup crashes

[Regression Potential]
Low, we now just handle a NULL pointer on this error case.

Robert Ancell (robert-ancell) wrote :

Crash occurs when fail to get installed snaps - a NULL pointer is then accessed later.

Changed in gnome-initial-setup (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-initial-setup (Ubuntu Cosmic):
status: Triaged → Fix Committed
assignee: nobody → Robert Ancell (robert-ancell)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu10

---------------
gnome-initial-setup (3.28.0-2ubuntu10) cosmic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Fix alignment of changes page labels
    - Fix crash if fail to get installed snaps (LP: #1768744)

 -- Robert Ancell <email address hidden> Fri, 11 May 2018 12:27:58 +1200

Changed in gnome-initial-setup (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Iain Lane (laney) on 2018-05-24
Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-initial-setup (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Triaged → Fix Committed

Hello errors.ubuntu.com, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic

Can you please add a test case to verify this SRU and an explanation of the crash? Comment #1 is not enough. Thanks.

description: updated
summary: - /usr/lib/gnome-initial-setup/gnome-initial-
- setup:11:contains_snap:gis_apps_page_init:g_type_create_instance:g_object_new_internal:g_object_new_valist
+ Crash when unable to get installed snaps
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I cannot reproduce the problem with gnome-initial-setup 3.28.0-2ubuntu6.1 in bionic-updates but I have verified that the version of gnome-initial-setup 3.28.0-2ubuntu6.16.04.1 in -proposed doesn't introduce any regression and doesn't crash when snapd is not installed or is removed.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Brian Murray (brian-murray) wrote :

The new version of the package does not appear in the error bucket so that's good too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu6.16.04.1

---------------
gnome-initial-setup (3.28.0-2ubuntu6.16.04.1) bionic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Add legal notice for livepatch page (LP: #1773140)
    - Typo fix in the "help improve ubuntu" page (lp: #1768549)
    - Fix crash if fail to get installed snaps (LP: #1768744)
    - Fix alignment of featured snaps (LP: #1769810)
    - Update background images to be more transparent (LP: #1769811)
    - Make changes page translatable (LP: #1766277)
    - Correctly update the "What's new" graphic (LP: #1768557)
    - Fix crash handling errors in livepatch page (LP: #1768743)
    - Remove some dead code
  * debian/patches/0001-Ensure-stamp-file-if-the-user-quit-the-wizard.patch:
    - Split out of 0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Robert Ancell <email address hidden> Thu, 31 May 2018 17:00:47 +1200

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-initial-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers