Update what's new graphic for Welcome to Ubuntu wizard

Bug #1768557 reported by Jeremy Bicha on 2018-05-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Low
Unassigned
Bionic
Low
Robert Ancell

Bug Description

Impact
======
Ubuntu 18.04 LTS (desktop) features a new Welcome to Ubuntu wizard which shows on the first login after installing or upgrading.

This updates the graphic shown on the What's new in Ubuntu screen

"Clock and calendar" has been renamed to "Calendar and notifications"
"Launcher" has been renamed to "Dock"

Test Case
=========
1. Install the bionic daily build from http://cdimage.ubuntu.com/bionic/daily-live/pending/ (This is needed because that image will include the updated gnome-initial-setup package and represents a preview of 18.04.1. Otherwise, the problem is that the first login after a new install will not have SRUs applied yet and gnome-initial-setup is already running before update-manager will prompt to install updates.)
2. Restart and log in to Ubuntu
3. Verify that the label changes have been made on the first page of the Welcome to Ubuntu wizard

Regression Potential
====================
None; this is just a substitution of a .png.

Other Info
==========
See also
https://github.com/CanonicalLtd/desktop-design/issues/101

The graphic is just a .png and is not translatable yet. See LP: #1766277

You can restart the wizard after completing it by removing
~/.config/gnome-initial-setup-done

Jeremy Bicha (jbicha) on 2018-05-02
Changed in gnome-initial-setup (Ubuntu Bionic):
importance: Undecided → Low
status: New → Triaged

Hello Jeremy, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jeremy Bicha (jbicha) on 2018-05-04
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu7

---------------
gnome-initial-setup (3.28.0-2ubuntu7) cosmic; urgency=medium

  [ Robert Ancell ]
  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Fix crash on shutdown in ubuntu-report page (LP: #1767873)

  [ Spencer Bygraves ]
  * Update the "What's new" graphic to mention dock and notifications
    (LP: #1768557)

  [ Andrea Azzarone ]
  * Don't autostart if user quits the wizard before completing it
    (LP: #1768929)

  [ Jeremy Bicha ]
  * Drop debian/ubuntu-changes.png to use the version included in
    0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Jeremy Bicha <email address hidden> Thu, 03 May 2018 14:06:19 -0400

Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Released
Robert Ancell (robert-ancell) wrote :

The bionic version still has the old terms. Also confirmed by looking at the source. However, since this just means no change from the previous version the SRU should continue and this will be properly fixed in bug 1766277.

tags: added: bionicverification-failed-bionic
removed: bionic verification-needed verification-needed-bionic
tags: added: bionic verification-failed-bionic
removed: bionicverification-failed-bionic
Jeremy Bicha (jbicha) on 2018-05-11
Changed in gnome-initial-setup (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu6.1

---------------
gnome-initial-setup (3.28.0-2ubuntu6.1) bionic; urgency=medium

  [ Robert Ancell ]
  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Fix crash on shutdown in ubuntu-report page (LP: #1767873)

  [ Spencer Bygraves ]
  * Update the "What's new" graphic to mention dock and notifications
    (LP: #1768557)

  [ Andrea Azzarone ]
  * Don't autostart if user quits the wizard before completing it
    (LP: #1768929)

  [ Jeremy Bicha ]
  * Drop debian/ubuntu-changes.png to use the version included in
    0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Jeremy Bicha <email address hidden> Thu, 03 May 2018 14:06:19 -0400

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-initial-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Jeremy Bicha (jbicha) on 2018-05-17
tags: removed: verification-failed-bionic
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Released → Triaged
Iain Lane (laney) on 2018-05-24
Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Sebastien Bacher (seb128) wrote :

The issue is fixed in the cosmic version

Changed in gnome-initial-setup (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Triaged → Fix Committed
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released
assignee: Robert Ancell (robert-ancell) → nobody
assignee: nobody → Robert Ancell (robert-ancell)
status: Fix Released → Fix Committed

Hello Jeremy, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I have reproduced the problem with gnome-initial-setup 3.28.0-2ubuntu6.1 in bionic-updates and have verified that the version of gnome-initial-setup 3.28.0-2ubuntu6.16.04.1 in -proposed fixes the issue.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu6.16.04.1

---------------
gnome-initial-setup (3.28.0-2ubuntu6.16.04.1) bionic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Add legal notice for livepatch page (LP: #1773140)
    - Typo fix in the "help improve ubuntu" page (lp: #1768549)
    - Fix crash if fail to get installed snaps (LP: #1768744)
    - Fix alignment of featured snaps (LP: #1769810)
    - Update background images to be more transparent (LP: #1769811)
    - Make changes page translatable (LP: #1766277)
    - Correctly update the "What's new" graphic (LP: #1768557)
    - Fix crash handling errors in livepatch page (LP: #1768743)
    - Remove some dead code
  * debian/patches/0001-Ensure-stamp-file-if-the-user-quit-the-wizard.patch:
    - Split out of 0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Robert Ancell <email address hidden> Thu, 31 May 2018 17:00:47 +1200

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers