Ubuntu changes graphic is not translatable

Bug #1766277 reported by Jean-Baptiste Lallement on 2018-04-23
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Status tracked in Cosmic
Bionic
Medium
Robert Ancell
Cosmic
Medium
Robert Ancell

Bug Description

[Impact]
The graphic showing the changes in Ubuntu is a png located in the debian/ directory and is not translatable.

[Test Case]
* install the language pack candidate version from https://launchpad.net/~ubuntu-langpack/+archive/ubuntu/ppa
* Open GNOME Initial Setup in a non-english language

Expected result:
Changes page shows translated descriptions

Observed result:
Changes page shows descriptions in english only.

[Regression Potential]
Code added to position labels - some risk of introducing bugs.

Jean-Baptiste Lallement (jibel) wrote :
description: updated
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1766277

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-initial-setup (Ubuntu):
status: New → Confirmed
Changed in gnome-initial-setup (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in gnome-initial-setup (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-initial-setup (Ubuntu):
status: Triaged → In Progress
Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Committed
Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu8

---------------
gnome-initial-setup (3.28.0-2ubuntu8) cosmic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Remove some dead code
    - Fix alignment of featured snaps (LP: #1769810)
    - Update background images to be more transparent (LP: #1769811)
    - Make changes page translatable (LP: #1766277)
    - Fix crash handling errors in livepatch page (LP: #1768743)
  * debian/patches/0001-Ensure-stamp-file-if-the-user-quit-the-wizard.patch:
    - Split out of 0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Robert Ancell <email address hidden> Wed, 09 May 2018 16:08:27 +1200

Changed in gnome-initial-setup (Ubuntu Cosmic):
status: Fix Committed → Fix Released
Iain Lane (laney) on 2018-05-24
Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: nobody → Robert Ancell (robert-ancell)
Changed in gnome-initial-setup (Ubuntu Bionic):
status: Triaged → Fix Committed
description: updated

Hello Jean-Baptiste, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-bionic
Jean-Baptiste Lallement (jibel) wrote :

I think the test case is incorrect because the strings were not available for translation and hence not translate.

When testing the version in proposed the strings are still in English. Can you please update the test case to something that can be verified ?

Robert Ancell (robert-ancell) wrote :

@seb128 - were these translations part of the ones you uploaded? Is there any method of testing this easily?

Sebastien Bacher (seb128) wrote :

I've updated the instructions, the strings are included in the current langpacks builds which can be downloaded from this ppa https://launchpad.net/~ubuntu-langpack/+archive/ubuntu/ppa

Note that some translations might still be incomplete, e.g the french one includes the string for "Calendar and notifications" but not for "Window switcher"

description: updated
Jean-Baptiste Lallement (jibel) wrote :

SRU verification for Bionic:
I have reproduced the problem with gnome-initial-setup 3.28.0-2ubuntu6.1 in bionic-updates and have verified that the version of gnome-initial-setup 3.28.0-2ubuntu6.16.04.1 in -proposed fixes the issue and that the welcome page is translated in French.

Marking as verification-done

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.28.0-2ubuntu6.16.04.1

---------------
gnome-initial-setup (3.28.0-2ubuntu6.16.04.1) bionic; urgency=medium

  * debian/patches/0001-Add-Ubuntu-mode-with-special-pages.patch:
    - Add legal notice for livepatch page (LP: #1773140)
    - Typo fix in the "help improve ubuntu" page (lp: #1768549)
    - Fix crash if fail to get installed snaps (LP: #1768744)
    - Fix alignment of featured snaps (LP: #1769810)
    - Update background images to be more transparent (LP: #1769811)
    - Make changes page translatable (LP: #1766277)
    - Correctly update the "What's new" graphic (LP: #1768557)
    - Fix crash handling errors in livepatch page (LP: #1768743)
    - Remove some dead code
  * debian/patches/0001-Ensure-stamp-file-if-the-user-quit-the-wizard.patch:
    - Split out of 0001-Add-Ubuntu-mode-with-special-pages.patch

 -- Robert Ancell <email address hidden> Thu, 31 May 2018 17:00:47 +1200

Changed in gnome-initial-setup (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-initial-setup has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers