gnome-initial-setup says that Livepatch is "all set" even if enabling is still in progress.

Bug #1764723 reported by Andrea Azzarone on 2018-04-17
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-initial-setup (Ubuntu)
Medium
Andrea Azzarone
Bionic
Medium
Andrea Azzarone

Bug Description

* Impact

- Livepatch can fail to install and the user will never be notified about the error.

* Test case
- Install ubuntu 18.04
- Wait for the wizard to be displayed
- Activate livepatch in the livepatch page
- Disconnect the system from the internet

-> After a while an error message dialog should be displayed

* Regression potential
Gnome-initial-setup fails to properly close (make sure that after a while the process is no longer running).

* Original bug

In Livepatch page we show the message "You're all set: Livepatch is now on" even if this is not true. Enabling livepatch requires several time-steps (e.g. installing the snap, getting the token, etc) that can fail at any time. We should update the message and show a notification in case of failure.

Related branches

Andrea Azzarone (azzar1) on 2018-04-17
Changed in gnome-initial-setup (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
status: New → In Progress
Will Cooke (willcooke) wrote :

Let's use:

"You're all set: Livepatch is now being enabled"

Andrea Azzarone (azzar1) on 2018-06-26
tags: added: rls-bb-incoming
Iain Lane (laney) on 2018-07-03
Changed in gnome-initial-setup (Ubuntu Bionic):
assignee: nobody → Andrea Azzarone (azzar1)
tags: removed: rls-bb-incoming
Changed in gnome-initial-setup (Ubuntu Bionic):
status: New → In Progress
importance: Undecided → Medium
Sebastien Bacher (seb128) wrote :

Thanks Andy, could you make the bug MIR compliant as well (impact/test case/regression potential)?

We also need to land the change in cosmic first since it seems it has not been uploaded yet, I'm going to have a look to that since Robert is away this week.

Andrea Azzarone (azzar1) on 2018-07-20
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-initial-setup - 3.29.1-1ubuntu1

---------------
gnome-initial-setup (3.29.1-1ubuntu1) cosmic; urgency=medium

  * Merge from Debian experimental (lp: #1784617). Remaining changes:
    + debian/control.in:
      - Build-Depends on libsnapd-glib-dev, libsoup2.4-dev, libsysmetrics-dev
      - Enable langpack usage
    + Ubuntu-specific patches:
      - 0001-Don-t-run-welcome-tour-at-end.patch
      - 0001-Make-summary-page-explicitly-request-navigation-butt.patch
      - 0001-Ensure-stamp-file-if-the-user-quit-the-wizard.patch
      - 0001-Add-Ubuntu-mode-with-special-pages.patch
      - 0001-Display-the-ubuntu-welcome-wizard-in-Unity.patch
      - 0006-goa-Add-Ubuntu-Single-Sign-On-to-the-list.patch
  * d/p/0001-Add-Ubuntu-mode-with-special-pages.patch:
      - Support Meson build system
      - Show an dialog in case of error when enabling Livepatch (lp: #1764723)
      - Enable online accounts page (lp: #1762192)
  * d/p/0001-Display-the-ubuntu-welcome-wizard-in-Unity.patch:
      - Enable online accounts page (lp: #1762192)
  * d/p/0006-goa-Add-Ubuntu-Single-Sign-On-to-the-list.patch:
      - Show "Ubuntu Single Sign-on" first in the list in the online accounts
        page.
  * d/p/0007-goa-adjust-description-to-not-mention-email-or-conta.patch:
      - Adjust online account description to not mention email or contacts.

 -- Andrea Azzarone <email address hidden> Tue, 14 Aug 2018 16:12:10 +0200

Changed in gnome-initial-setup (Ubuntu):
status: In Progress → Fix Released

Hello Andrea, or anyone else affected,

Accepted gnome-initial-setup into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-initial-setup/3.28.0-2ubuntu6.16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-initial-setup (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers