[apport] gnome-sudoku crashed with AttributeError in auto_fill_current_entry()

Bug #81303 reported by Susana Pereira on 2007-01-24
12
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
Critical
gnome-games (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-games

I clicked in a lot of icons very fast. I don't know the sequence that caused this.

ProblemType: Crash
Date: Wed Jan 24 16:12:58 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/games/gnome-sudoku
InterpreterPath: /usr/bin/python2.5
Package: gnome-games 1:2.17.90.1-0ubuntu1
ProcCmdline: python /usr/games/gnome-sudoku
ProcCwd: /home/susana
ProcEnviron:
 LANGUAGE=pt:pt_BR:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=pt_PT.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/games/gnome-sudoku']
SourcePackage: gnome-games
Uname: Linux laplace 2.6.20-5-generic #2 SMP Sat Jan 6 14:50:47 UTC 2007 i686 GNU/Linux

Sebastien Bacher (seb128) wrote :

Thank you for your bug. I've forwarded it upstream: http://bugzilla.gnome.org/show_bug.cgi?id=400279

Changed in gnome-games:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in gnome-games:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

fixed upstream

Changed in gnome-games:
status: Confirmed → Fix Committed
Changed in gnome-games:
status: Unconfirmed → Fix Released
Daniel Holbach (dholbach) wrote :

 gnome-games (1:2.17.91-0ubuntu1) feisty; urgency=low
 .
   * New upstream release:
     - General:
       - bugbuddy integration is better for python-based games;
         gnome-python-desktop >= 2.17.3 required
       - Unit testing framework added
       - Gnome-doc-utils support increased for a few games
     - GTali: Fix the category for flush, so that only valid flushes may be
       entered there
     - Gnome Sodoku: Prevent exception from occuring when clicking on the
       autofill button, when nothing is selected (LP: #81303)
     - Gnobots2: Cheating was possible while the preferences dialog is open.
     - GGZ:
       - lots of fixed to gnome-games network play
       - HIG compliant connection box
     - glchess: Fix startup crasher if cannot contact bugbuddy due to rogue
       'none' command (LP: #82409)
   * debian/control.in:
     - updated Depends and Build-Depends according to configure.in
   * debian/patches/01_lpi.patch, debian/patches/99_autoconf.patch:
     - updated.

Changed in gnome-games:
status: Fix Committed → Fix Released
Changed in gnome-games:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.