Ubuntu

Swell Foop game does not work

Reported by Matt Meinwald on 2010-08-28
86
This bug affects 16 people
Affects Status Importance Assigned to Milestone
GNOME Games
Invalid
High
gnome-games (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-games

When I launch Swell Foop, it appears to work fine, but when I attempt to click on a group of blocks, nothing happens. If I select Game->New, it does not create a new board, and the main part of the window does not repaint. The program as a whole does not freeze, as I am still able to access the menus.

This issue also occurs for me in Nibbles.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: swell-foop 1:2.31.90-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-19.26-generic 2.6.35.3
Uname: Linux 2.6.35-19-generic i686
Architecture: i386
Date: Sat Aug 28 16:52:37 2010
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-games

Matt Meinwald (meinwald) wrote :
Matt Meinwald (meinwald) on 2010-08-28
description: updated
Pedro Villavicencio (pedro) wrote :

Thanks for the report, could you run the game from the command line and see if you get any errors there? thanks in advance.

Changed in gnome-games (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

actually i can reproduce this, clicking on the board doesn't do anything.

Changed in gnome-games (Ubuntu):
status: Incomplete → Confirmed
Pedro Villavicencio (pedro) wrote :

There's an upstream report here https://bugzilla.gnome.org/show_bug.cgi?id=624493; saying that this is affecting the nouveau driver from nvidia but i'm using an intel card thus the intel driver and having the same issue, already commented on the upstream report, thanks in advance.

Changed in gnome-games (Ubuntu):
status: Confirmed → Triaged
Matt Meinwald (meinwald) wrote :

I was using an Intel card as well. I will see what other information I can get when I have a chance. If I recall, I did not see any terminal output when running the program from the command line.

Changed in gnome-games:
status: Unknown → Confirmed

Same problem here, running an eeePC 1005 (Intel). This program was really buggy in 10.04, crashing frequently. I'm hoping we get a functional version for 10.10 since its predecessor (same-gnome) was one of my go-to games when I wanted to waste 5 minutes or less!

Here's the output when running from terminal:

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 1 must not be null for function: Conf.get_string

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 1 must not be null for function: Conf.get_integer

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 1 must not be null for function: Conf.get_integer

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 1 must not be null for function: Conf.get_boolean

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 2 must not be null for function: Scores.new

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 3 must not be null for function: Scores.new

** (seed:3819): WARNING **: ArgumentError - probably due to incorrect gir file (which may be fixed upstream) argument 5 must not be null for function: Scores.new

Changed in gnome-games:
importance: Unknown → High
vovkkk (vovkkk) wrote :

I have these (when moving cursor)

** (seed:4053): WARNING **: Exception in closure (0x86a48f8) for signal handler (handler light_left). Line 43 in /usr/share/gnome-games/swell-foop/Board.js: TypeError Result of expression 'GLib.main_context_pending' [undefined] is not a function.

** (seed:4053): WARNING **: Exception in closure (0x86d4a70) for signal handler (handler light_entered). Line 43 in /usr/share/gnome-games/swell-foop/Board.js: TypeError Result of expression 'GLib.main_context_pending' [undefined] is not a function.

** (seed:4053): WARNING **: Exception in closure (0x86d4ac0) for signal handler (handler light_left). Line 43 in /usr/share/gnome-games/swell-foop/Board.js: TypeError Result of expression 'GLib.main_context_pending' [undefined] is not a function.

** (seed:4053): WARNING **: Exception in closure (0x86a5b40) for signal handler (handler light_entered). Line 43 in /usr/share/gnome-games/swell-foop/Board.js: TypeError Result of expression 'GLib.main_context_pending' [undefined] is not a function.

and when clicking

** (seed:4053): WARNING **: Exception in closure (0x8672af0) for signal handler (handler [anonymous]). Line 43 in /usr/share/gnome-games/swell-foop/Board.js: TypeError Result of expression 'GLib.main_context_pending' [undefined] is not a function.

nikitakit (nikitakit) wrote :

I can confirm this bug for nibbles, swell foop, and lights off. (It's also a duplicate of https://bugs.launchpad.net/ubuntu/+source/gnome-games/+bug/572577)

My log outputs are nearly identical to what other people listed. I also have an Intel video card.

Mark Weaver (mark-weaver) wrote :

I have the same problem with swell foop. My error messages are similar to those already reported. I would like to add that if I maximize another program, and then maximize swell foop, the swell foop window is then blank. Also, if I change preferences and then close the preferences window, the space occupied by the preferences window is blank. This is on a Lenovo T43 with an Intel 915 graphics chip.

Jonathan Siebott (jonsiebott) wrote :

#11 fixes the bug. I have made the changes and am providing the entire gnome game files for SwellFoop and Lightsoff. Simply remove the old directory and replace with the ones I provide...

 /usr/share/gnome-games/swell-foop
/user/share/gnome-games/lightsoff

 You'll need to run Nautilus as root to do this. To run as root, enter the following command in terminal...

gksudo "nautilus --browser %U"

Great! That fixed it for me. I trust we'll see this working out of the box in 11.04.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:2.32.1-0ubuntu4

---------------
gnome-games (1:2.32.1-0ubuntu4) natty; urgency=low

  [ Ken VanDine ]
  * debian/gnome-games-common.install.in
    - Fix multiarch related FTBFS
  * debian/rules
    - Fix multiarch related FTBFS

  [ Robert Ancell ]
  * debian/control:
    - Add gir1.2-gnomegamessupport-1.0 package
  * debian/gir1.2-gnomegamessupport-1.0.install.in:
    - New package for GIR files
  * debian/rules:
    - Fix use of DEB_DH_FIXPERMS_ARGS_ALL
    - Use DEB_DH_GIREPOSITORY_ARGS_ALL to find gir file
  * debian/patches/00git_private_typelib.patch:
    - Install GI files into a private location
  * debian/patches/03_swell_foop.patch:
    - Fix Swell Foop (LP: #626016)
  * debian/patches/04_lightsoff.patch:
    - Fix Lights Off (LP: #633292)
 -- Robert Ancell <email address hidden> Thu, 31 Mar 2011 10:21:55 +1100

Changed in gnome-games (Ubuntu):
status: Triaged → Fix Released

Arghh... I upgraded my netbook to 11.04 beta1 over the weekend and both programs simply segfault... I guess I'll check to see if there's a report open yet for 11.04.

Changed in gnome-games:
status: Confirmed → Invalid
David Robert Crawford (drceef) wrote :

....G'day, Just a quickie to say how grateful I am for everyones work on such a minor glitch.

For what it's worth... I too suffered from 'Lights Off' not even switching on...! I tried successfully editing the 'board.js' file, but then installed Sean Fitzpatricks patch.

I have an AMD 5770 video card.

The patch wasn't mine! I think it came from upstream and was posted here by Jonathan. Although, this may all be moot, since in 11.10 testing it looks like both swell-foop and lightsoff have been pulled from the gnome-games package - in fact they're gone from the repositories altogether. So perhaps these two ended up being more trouble than they're worth.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.