Package glchess fails to install and ask removal of gnome-games

Bug #234865 reported by TAC one on 2008-05-25
56
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
Critical
gnome-games (Ubuntu)
Medium
Ubuntu Desktop Bugs
Hardy
Low
Unassigned
Intrepid
Medium
Ubuntu Desktop Bugs
python-support (Debian)
Fix Released
Unknown
python-support (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Similar to another bug reported.
I also fail to understand why apt wants to remove gnome-games.

tacone@tacone-desktop:~$ sudo apt-get install glchess
[sudo] password for tacone:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  gnuchess
Suggested packages:
  xboard eboard
Recommended packages:
  python-opengl libgtkglext1 python-gtkglext1 gnuchess-book
The following packages will be REMOVED:
  gnome-games
The following NEW packages will be installed:
  glchess gnuchess
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.
Need to get 287kB of archives.
After this operation, 598kB disk space will be freed.
Do you want to continue [Y/n]?
Get:1 http://archive.ubuntu.com hardy/universe gnuchess 5.07-4 [90.9kB]
Get:2 http://archive.ubuntu.com hardy/universe glchess 1.0+debian-1 [196kB]
Fetched 287kB in 0s (430kB/s)
(Reading database ... 248576 files and directories currently installed.)
Removing gnome-games ...
Selecting previously deselected package gnuchess.
(Reading database ... 248517 files and directories currently installed.)
Unpacking gnuchess (from .../gnuchess_5.07-4_i386.deb) ...
Selecting previously deselected package glchess.
Unpacking glchess (from .../glchess_1.0+debian-1_all.deb) ...
Setting up gnuchess (5.07-4) ...

Setting up glchess (1.0+debian-1) ...
/usr/sbin/update-python-modules:125: DeprecationWarning: raising a string exception is deprecated
  raise "Trying to overwrite %s which is already provided by %s"%(os.path.join(dir,file),otherdir)
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 339, in <module>
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 160, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 125, in install_modules_func
    raise "Trying to overwrite %s which is already provided by %s"%(os.path.join(dir,file),otherdir)
Trying to overwrite glchess/__init__.py which is already provided by /usr/share/python-support/gnome-games-data
dpkg: error processing glchess (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 glchess
E: Sub-process /usr/bin/dpkg returned an error code (1)

TAC one (tacone) wrote :

after removal of the partial installed glchess, i apt-getted gnome-games.
Now, trying to launch gnuchess leds to a crash.

Distribution: Ubuntu 8.04 (hardy)
Gnome Release: 2.22.1 2008-05-07 (Ubuntu)
BugBuddy Version: 2.22.0

System: Linux 2.6.24-17-generic #1 SMP Thu May 1 14:31:33 UTC 2008 i686
X Vendor: The X.Org Foundation
X Vendor Release: 10400090
Selinux: No
Accessibility: Disabled
GTK+ Theme: OSX-theme
Icon Theme: Human

Memory status: size: 0 vsize: 0 resident: 0 share: 0 rss: 0 rss_rlim: 0
CPU usage: start_time: 0 rtime: 0 utime: 0 stime: 0 cutime:0 cstime: 0 timeout: 0 it_real_value: 0 frequency: 0

----------- .xsession-errors (194654 sec old) ---------------------
[4836f401][chat]: Mase: win
[4836f403][chat]: *** [SeOg] Tee joined the blue team
[4836f403][chat]: Baddi: 2.!!!
[4836f404][client]: input was late with -12 ms
[4836f406][client]: input was late with -3 ms
[4836f409][chat]: -=|TSE|=- dane : 1!!!!!!!!!
[4836f409][chat]: Mase: wund !!!!
[4836f40b][client]: input was late with -3 ms
[4836f40d][client]: input was late with -4 ms
[4836f40f][chat]: *** KOPOBA has left the game
[4836f413][client]: input was late with -92 ms
[4836f414][client]: input was late with -4 ms
[4836f417][client]: input was late with -2 ms
...Too much output, ignoring rest...
--------------------------------------------------
Traceback (most recent call last):
  File "/usr/games/glchess", line 61, in <module>
    start_game()
  File "/var/lib/python-support/python2.5/glchess/glchess.py", line 20, in start_game
    import main
ImportError: No module named main

accleo (accleo) wrote :

Same (exactly the same!) problem here!

I have gnome-games installed and I can play chess.
When I open Synaptic, glChess doesn't appear to be installed, though.
When I try to install it, it makes me uninstall gnome-games... (why??).
After agreeing to its purpose, the glChess package fails to get installed giving the same error as in the first post.
After reinstalling gnome-games, it fails like in the second post...

Hope anyone can help... ;)

TAC one (tacone) wrote :

sudo apt-get remove --purge gnome-games gnome-games-data
sudo apt-get install gnome-games gnome-games-data

This apparently fixed it. I don't know if it got fixed because of the
reinstallation of gnome-games-data, because of --purge option or just
because it was the second removal :-

Pedro Villavicencio (pedro) wrote :

not an upstream task.

Changed in gnome-games:
status: New → Invalid
Justin Dugger (jldugger) wrote :

It might not be an upstream task, but this is also the MOST duplicated bug in GNOME games upstream =(

Changed in gnome-games:
status: Invalid → Unknown
Changed in gnome-games:
status: Unknown → Confirmed
Justin Dugger (jldugger) wrote :

This bug turns out to be derived in part from an error in python-support, now fixed in Debian:

 python-support (0.8.2) unstable; urgency=low
 .
   * Fix typo in 0.8.1 changelog entry.
   * update-python-modules:
     + Call dpkg-trigger explicitly when we need it. This should prevent
       the trigger from being run *before* the actual installation.
       Closes: #486516.

Changed in python-support:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

confirming, gnome-games-data should conflict on glchess

Changed in gnome-games:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Fix Committed
Changed in gnome-games:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

change uploaded as an hardy update, it seems to create quite some upstream duplicates and the change is trivial

Changed in gnome-games:
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

the change is similar to the one used in debian and list gnome-soduko which can be broken in the same way

Martin Pitt (pitti) wrote :

Accepted gnome-games into hardy-proposed, please test.

Changed in gnome-games:
status: Confirmed → Fix Committed
Tormod Volden (tormodvolden) wrote :

I upgraded to gnome-games-data_1:2.22.2.1-0ubuntu2_all.deb (from hardy-proposed). Then I installed glchess successfully, but it removed gnome-games and gnome-games-data. So the "fails to install" part seems fixed, but the "ask removal of gnome-games" issue is still there.

Martin Pitt (pitti) wrote :

I think the reason is that the conflicts:/replaces: are missing the "1:" epoch.

Changed in gnome-games:
status: Fix Committed → In Progress
Sebastien Bacher (seb128) wrote :

hum, I'm not sure to understand what you mean there, glchess is not using an epoch number and the conflicts is required and not a bug

Martin Pitt (pitti) wrote :

Intrepid has a newer python-support version.

Changed in python-support:
status: New → Fix Released
status: New → Invalid
Sebastien Bacher (seb128) wrote :

the conflicts is not a bug, glchess and gnome-games have similar files so they can't be installed together but that's not required since gnome-games has glchess

the bug was that gnome-games-data and glchess were not conflicting which was leading to a broken installation, that has been fixed now by using a correct conflicts there

Martin Pitt (pitti) on 2008-07-13
Changed in gnome-games:
status: In Progress → Fix Committed
Tormod Volden (tormodvolden) wrote :

I installed gnome-games, and this removed glchess (the package). So the conflicts seem to work fine.

And yes, I still have glchess (now from gnome-games). Why is there a duplicate package for it?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:2.23.4-0ubuntu2

---------------
gnome-games (1:2.23.4-0ubuntu2) intrepid; urgency=low

  * debian/control.in:
    - use gnome-games-data conflicts on glchess and gnome-sudoko,
      fix installation issues leading to non working gnome games (lp: #234865)

 -- Sebastien Bacher <email address hidden> Mon, 14 Jul 2008 15:39:39 +0100

Changed in gnome-games:
status: Fix Committed → Fix Released
Steve Beattie (sbeattie) wrote :

The upload for this got superseded by a later upload and so did not get marked as fixed released for Hardy by launchpad.

Changed in gnome-games:
status: Fix Committed → Fix Released
Changed in gnome-games:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.