gnect crashed playing sound

Bug #146411 reported by Florian Staudacher on 2007-09-28
56
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
High
gnome-games (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-games

during the update with adept_updater the crash report-tool came up and asked wether to report this...

ProblemType: Crash
Architecture: i386
Date: Mon Sep 24 13:30:58 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/games/gnect
NonfreeKernelModules: nvidia
Package: gnome-games 1:2.20.0.1-0ubuntu2
PackageArchitecture: i386
ProcCmdline: /usr/games/gnect
ProcCwd: /home/florian
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-games
Stacktrace:
 #0 0x08062d7f in ?? ()
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
Title: gnect crashed with SIGSEGV
Uname: Linux flo-notebook 2.6.22-12-generic #1 SMP Sun Sep 23 18:11:30 GMT 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

StacktraceTop:games_sound_thread_run (data=0x80a5900 "slide", user_data=0x0) at games-sound.c:63
g_thread_pool_thread_proxy (data=0x8319480) at /build/buildd/glib2.0-2.14.1/glib/gthreadpool.c:265
g_thread_create_proxy (data=0x8433368) at /build/buildd/glib2.0-2.14.1/glib/gthread.c:635
start_thread () from /lib/tls/i686/cmov/libpthread.so.0
clone () from /lib/tls/i686/cmov/libc.so.6

Changed in gnome-games:
importance: Undecided → Medium

Thanks for your report. it was caused by the gnect game may you run it from the console and see if it works fine? possible the crash is some old issue, thanks.

Changed in gnome-games:
assignee: nobody → desktop-bugs
status: New → Incomplete

Now it seems to work fine.
Thanks for your attention!

Pedro Villavicencio (pedro) wrote :

Thanks for your update.

Changed in gnome-games:
status: Incomplete → Fix Released
Oddround (oddround) wrote :

Game ended and I won. No movement of coins to show, just hang and crash.

Merike Sell (merikes) wrote :

I'm confused. I'm using Kubuntu 7.10 and got gnome-games from Ubuntu's repository using Adept and yet it crashes even though it says "fix released"? Is it because I don't have the latest version? I'm not that familiar with versions so I'm unsure of how to check that.

Changed in gnome-games:
status: Fix Released → New
Pedro Villavicencio (pedro) wrote :

Is this still an issue?

Changed in gnome-games:
status: New → Incomplete
Merike Sell (merikes) wrote :

It crashes in Kubuntu with version 1:2.20.1-0ubuntu1.

A user of another distro also hit this with gnometris. We debugged the problem, here is the result.

static void games_sound_init (void)

{

  GError *err = NULL;

  g_assert (g_thread_supported ());

  pipeline = gst_element_factory_make ("playbin", "playbin");

  threads = g_thread_pool_new ((GFunc) games_sound_thread_run, NULL, 10, FALSE, &err);

  sound_init = TRUE;

}

The code doesn't check the return value of gst_element_factory_make(), and that's the real bug. It returns NULL if there are no sound output plugins installed.

I.e., in order for sound in GNOME games to be functional, the users must install at least base and good plugins, and also ogg and vorbis plugins.

Note: I am not a user of Ubuntu, and will not help with this bug further.

Merike Sell (merikes) wrote :

Since I couldn't understand which plugins were meant by ogg and vorbis plugins I installed only gstreamer base and good and it really resulted in game being playable. I have one pixel white stripe though on playing area and it still prints:
(gnect:20817): GStreamer-CRITICAL **: gst_event_new_new_segment_full: assertion `start <= stop' failed
to command-line.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Thanks in advance.

Vincent (vinnl) wrote :

I haven't, but I haven't used gnome-games since.

Merike Sell (merikes) wrote :

Without gstreamer base plugins (perhaps it should be a dependency?) with KDE desktop installed:

(gnect:26213): GStreamer-CRITICAL **: gst_element_get_bus: assertion `GST_IS_ELEMENT (element)' failed
(gnect:26213): GLib-GObject-CRITICAL **: g_object_set: assertion `G_IS_OBJECT (object)' failed
(gnect:26213): GStreamer-CRITICAL **: gst_element_set_state: assertion `GST_IS_ELEMENT (element)' failed
(gnect:26213): GStreamer-CRITICAL **: gst_bus_timed_pop: assertion `GST_IS_BUS (bus)' failed
Segmentation fault

With base plugins (gstreamer0.10-plugins-base liboil0.3) added:

Error playing sound: Both autoaudiosink and alsasink elements are missing.

With gstreamer0.10-alsa installed as well: error gone and no crash.

Pedro Villavicencio (pedro) wrote :

could somebody able to reproduce this with jaunty forward the bug upstream to bugzilla.gnome.org? thanks in advance.

Sebastien Bacher (seb128) wrote :

is that still an issue in jaunty?

Robert Ancell (robert-ancell) wrote :

Raised upstream

Changed in gnome-games:
status: Unknown → Confirmed
Robert Ancell (robert-ancell) wrote :

Fixed upstream

summary: - gnect crashed with SIGSEGV
+ gnect crashed playing sound
Changed in gnome-games (Ubuntu):
status: Incomplete → Triaged
Changed in gnome-games:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the bug should be fixed in karmic now

Changed in gnome-games (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-games:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.