Ubuntu

Gnometris controls very unresponsive when keys are held down

Reported by Scott Ritchie on 2007-09-10
96
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Games
Fix Released
Critical
gnome-games (Ubuntu)
Medium
Ubuntu Desktop Bugs
Declined for Hardy by Sebastien Bacher

Bug Description

Binary package hint: gnome-games

Play gnometris, and get to around level 3 or 4. This bug is easier to see at higher levels.

Use the move keys by holding them down. The resulting behavior is very frustrating - the block will move in spurts, and continue to move after you let go of the key. Worse still, it becomes impossible to move the block all the way to the side before it declines several rows, making it literally impossible to place a block in the upper right corners of the board as the level increases.

Regardless, even basic play becomes frustrating like this at a fairly early level. It is very aggravating letting go of the keyboard and watching your piece keep flying across the screen beyond your control.

William Grant (wgrant) wrote :

Are you using compiz? I recall seeing this, and I think I was running compiz. Can't reproduce it without compiz here.

Changed in gnome-games:
status: New → Incomplete
Alexander Jones (alex-weej) wrote :

Added upstream bug reference.

I think we should port Gnometris to OpenGL.

Scott Ritchie (scottritchie) wrote :

This is without compiz or beryl being used.

I have nvidia display drivers and a Geforce 6800.

Scott Ritchie (scottritchie) wrote :

The problem is more obvious with heavy disk access and at higher game levels.

Changed in gnome-games:
status: Unknown → Invalid
AndreasRøsdal (andreasr) wrote :

"heavy disk access"?? Gnometris should never access the harddisk while playing.

Scott Ritchie (scottritchie) wrote :

The bug is a LOT easier to reproduce now that Gnometris levels have been fixed. Start a new game somewhere between level 6 and 9. Try to move the block from one side of the screen to the other - it is the exact opposite of smooth, especially when changing directions. You'll likely notice up to an entire second of lag here.

Peterix (peterix) wrote :

This (or something very similar) happens when there are many blocks on the screen - the more blocks, the slower it is. I can hear the CPU/GPU fans spinning like crazy.
Running Gutsy with compiz and proprietary drivers (ATI X800).

Sebastien Bacher (seb128) wrote :

looks like upstream closed the bug

Changed in gnome-games:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Scott Ritchie (scottritchie) wrote :

Honestly, I think it's quite erroneous to close this bug upstream. The game is rendered nigh unplayable.

Changed in gnome-games:
status: Invalid → New
Changed in gnome-games:
status: Incomplete → Triaged

I hope this is the same bug, otherwise I'll open a new one:

In Gutsy, (with Compiz and XGL, ATI Card), I notices that this slow response ist so slow, that it even affects the following blocks: E.g., I have a block in the right position and speed up falling by pressing arrow down. Then sometimes even the following few blocks come falling down uncontrollable. Same with right or left. After some time, the keys hitted in the meanwhile are executed, i.e., when a block moved left and I wanted to get it right, the following blocks all move left, until suddenly one moves right.

This makes the game really unusable. What a shame, regarding the beatiful new theme...

sc3252 (sc3252-gmail) wrote :

I thought I would add to this. After just installing ubuntu gutsy I decided to try out some of the defualt games. The first game happened to be gnometris. both with and without compiz the lag was visible, but with compiz it was more visible at the lower levels. While playing at high levels such as 7 or 8 you don't even need to press a button if you have more then 7 rows filled with blocks, since it is absolutely unplayable. I would see lag up to 7 seconds if I had more then half the screen filled with blocks, so it is very noticeable.

I really dont understand how this game was even allowed into ubuntu.

Thought I would include my system specs

amd64 3000+'
nvidia 7600gt
1.5GB ram
gutsy 32bit

François Marier (fmarier) wrote :

Have you tried changing the theme? I was having performance problems with Gnometris (Gutsy version) on a slower machine and changed the block style to "plain". It's much more playable now.

In fact, it may be a good idea to make this the default.

Francois Marier wrote:
> Have you tried changing the theme? I was having performance problems
> with Gnometris (Gutsy version) on a slower machine and changed the block
> style to "plain". It's much more playable now.
>
> In fact, it may be a good idea to make this the default.
>

That works great.
Thanks!!

costales (costales) wrote :

Same error in Ubuntu 7.10.
Solve this feature is important for this game's usability.
Regards.

mcourneyea (courneyea) wrote :

I still see the bug and its very annoying.
it seems to me as if the queue holding directional instructions for each piece doesn't empty once the piece gets to the bottom but adds its instructions to the new piece making it uncontrollable until the queue is cleared. for some reason this doesn't happen with only a few pieces on the screen but becomes very noticeable with a lot of pieces on the screen - I could be wrong but that's my take on it from a programmer point of view....

TennesseeJed (bkeane) wrote :

Confirmed. Game becomes unplayable (as described above) when Level >= 5. If I choose "Plain" Block Style under the Theme preferences, the game returns to its normal, playable, self (thanks, François).

I'm running 7.10, desktop effects enabled. I've got a Radeon 9200se and I'm using the 'ati' driver.

Ivan Jekic (the-edge) wrote :

Totally agree. I'm using 7,10 ubuntu with compiz on default settings. All tango themes are useless! Game is seriously slow.
Never thought that a tetris game would be impossible to play on 2,5ghz & 2gb ram machine! ;-)

Changed in gnome-games:
importance: Low → Medium
win22 (win22) wrote :

after 6 level it's unresponsible and the screen dimmed.
my ubuntu 7.10 ram 2 GB pentium-m 1200GHz, video cad intel 855 64mb videoram

Karl Ostmo (kostmo) wrote :

Just curious what the status of the fix is. Like everyone else, for me the controls become sluggish after mere minutes of play. Changing to the "plain" theme resolves this problem. So, will "Plain" be made the default theme, or has some code been fixed such that the "Tango Shaded" theme doesn't cause a slowdown? "Tango Flat" also results in a major slowdown when a lot of blocks are on the screen.

Specs: 1.6GHz P4, 768 MB RAM, ATI Mobility Radeon 7500 graphics card.

Jonas Jørgensen (jonasj) wrote :

Seriously, all this needs is a change of the default theme to 'Plain'. Can't we have that done for hardy? (Shipping reasonable defaults that Just Work and all that...)

I disagree.
This problem needs to be FIXED, it's a disgrace for gnome games team. I
mean, come on, two gigs of RAM, 2.7ghz processor and I simply can't play
Tetris(!) with fancy tiles. It does not make any sense, the game is
probably badly coded/optimized.

On Sat, 2008-02-02 at 07:26 +0000, Jonas Jørgensen wrote:
> Seriously, all this needs is a change of the default theme to 'Plain'.
> Can't we have that done for hardy? (Shipping reasonable defaults that
> Just Work and all that...)
>

Changed in gnome-games:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

This is fixed upstream now, thanks a lot for reporting.

Changed in gnome-games:
status: Triaged → Fix Committed
Jonas Jørgensen (jonasj) wrote :

A developer added a comment to the upstream bug, saying that the patch wasn't effective. Setting status back to new until someone finds out whether this is fixed or not...

Changed in gnome-games:
status: Fix Committed → New

i still have the problem with hardy alpha 6 live cd with the default theme. if it cant be fixed, please change the default to plain before hardy is released, which works, even if it is less than perfect

Tom Arnold (g0tt) wrote :

I have a monster machine and i cannot play TETRIS?? Come on. Either remove this game or fix it. Those are the options.

Tom Arnold schreef:
> I have a monster machine and i cannot play TETRIS?? Come on. Either
> remove this game or fix it. Those are the options.
>
>
no way,

start up tetris, goto settings / theme and select "plain"
now you can play again tetris like before.

my language settings are dutch, so "settings and theme" can be have a
different name

enjoy your game

johan (bukie) wrote :

Tom Arnold schreef:
> I have a monster machine and i cannot play TETRIS?? Come on. Either
> remove this game or fix it. Those are the options.
>
>

Changed in gnome-games:
status: New → Confirmed
kiersie (ckiers) wrote :

Ummmh i using 8.04 beta but it apears again, after i choose change the theme it go's rapide as an tgv. i push down onche and i am on the bottem of the game, dont close it in ubuntu 8.04 until its fixed!!!

revkarl (revkarl) wrote :

This really is embarrassing. When we tout how superior Linux is at allocating resources and my gaming machine can't handle Tetris, it threatens the credibility of the whole system. The game really needs to be nixed or fixed.

I can also confirm this bug on my Dell Optiplex GX270 desktop running intel gfx. Seems like after I hold down the "down" arrow key is when the controls start going haywire. Massive lag and unresponsiveness. I can hear the fans speeding up in my system indicating the cpu is under heavy load. Same problem with/without Compiz. When Compiz is enabled, the screen will fade black and white while the game is playing. Hardy install fully updated as of 4-5-08 8:15pm

Changed in gnome-games:
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games - 1:2.22.1.1-0ubuntu1

---------------
gnome-games (1:2.22.1.1-0ubuntu1) hardy; urgency=low

  * New upstream version:
    Sudoku:
    - Don't crash when clearing a tracker
    - Handle when no more puzzles of a certain difficulty exists
    - Don't always show the same puzzle until it has been completed or saved
    - Fix crash on cancel in new game dialog
  * Sync on Debian
  * debian/control.in:
    - Build-Depends on liblaunchpad-integration-dev (>= 0.1.17)
    - don't Depends on chess packages we use the gnome-games version
    - gnome-cards-data replaces gnome-games-data (<< 1:2.20.1-1)
    - gnome-games-data replaces gnome-cards-data (<< 1:2.20.1-1)
    - updated ggz requirements
    - updated maintainer information
    - updated python requirement
  * debian/patches/01_lpi.patch:
    - launchpad integration changes
  * debian/patches/80_change_tetris_theme.patch:
    - use the plain theme to workaround cairo speed issues (lp: #138586)
  * debian/patches/99_reautoconf.patch:
    - update and list in the series
  * debian/pyversions:
    - require python 2.5
  * debian/rules:
    - add gnuchess to the build

 -- Sebastien Bacher <email address hidden> Wed, 09 Apr 2008 00:56:31 +0200

Changed in gnome-games:
status: Triaged → Fix Released

This bug is not fixed even with the new updates. The bug still occurs when using the "Tango Flat" and "Tango Shaded" block themes. Hardy fully updated Gnometris v2.22.1.1

Just noticed this:

 " * debian/patches/80_change_tetris_theme.patch:
    - use the plain theme to workaround cairo speed issues (lp: #138586) "

Telling users to switch themes isn't much of a fix. It would be best to just remove the Tango block themes and save the users/devs headaches.

Sebastien Bacher (seb128) wrote :

The change is not telling users what to do, it's changing the default theme as a workaround. The tango theme is slower because it hits slow code in the xorg stack on some cards but is likely working correctly for some other people so there is no really reason to don't make it available

Philip Macpherson (philipmac1) wrote :

I can confirm that this is still a problem in Ibex beta (plus the recent gnome game updates) when theme is switched to tango ones.

Ivansmail (ivansmail) wrote :

I find that the controls stop working all together and the game seems to be grey instead of in colour.

Silvio Sisto (sistoviejo) wrote :

I can confirm this bug on Ubuntu Jaunty Jackalope.
Apparently the game starts becoming more and more unresponsive with time.
Also the game can become responsive again when you fill a line.
So if you keep stacking blocks but don't fill any lines it will become less and less responsive after a while.

Silvio Sisto (sistoviejo) wrote :

To notice the unresponsiveness pile up some lines of blocks and keep using the arrow-down key to lower blocks faster.
You will notice after a while that it will become a lot less responsive.

Silvio Sisto (sistoviejo) wrote :

Gnometris allows you to change block themes. This issue appears when I use the tango "Tango Shaded" theme. It doesn't happen when I use the "Plain" theme. I have a fast cpu so it's not a cpu usage issue. Also using top I was able to see that cpu usage stays low even when gnometris becomes unresponsive. It doesn't use more cpu and stays at around 1% all the time.

Scott Ritchie (scottritchie) wrote :

The issue is that Gnometris is being very stupid about rendering - every frame it's rendering every single svg brick separately. This is why it gets slower with more bricks on the screen even when they're the same color. If it did some sort of caching this likely wouldn't be an issue.

ricardisimo (ricardisimo) wrote :

Still a problem here in September 2009. The theme appears to be the culprit in my case. I changed it to "Plain" and it behaves itself well certainly through the first dozen or so "levels". Thanks for everything you people do.

Hell Pé (hellpe) wrote :

That's still a problem to me, too. I'm using Xubuntu 9.04 on an Acer Aspire One, and Gnometris quickly becomes virtually unplayable, even with the "plain" theme selected.

jal (kilian-hekhuis) wrote :

Just played gnometris for the first time, and indeed with the Tango Shaded theme a lag is detectable at the lower levels, but from level 10 and up the game becomes unplayable, despite it taking "only" a little over 50% processor power (a rediculous amount for such a game, but at least it shows that it's not maxing out on my CPU - note that I have a single core Celeron 2.66GHz, so no hyperthreading issue). Even clicking the window's close button lags, and I get a "force application quit" pop-up. When selecting the Plain theme, the game is playable and the CPU stays around 12%. So it seems the game has some serious graphics issues.

jal, which version of GNOME/Gnometris are you using?

With 2.28, the graphics engine seems to have bin ported to OpenGL. The lagging graphics issue of previous versions seems to have gone with that version. But I noticed that the new OpenGL animation leads to a lag of some milliseconds that make it hard to get through the upper levels. I think this is not a bug, but by design. Still it might be nice to have an option to disable the animation to get more precise control.

Hell Pé (hellpe) wrote :

I've been upgrading to Karmic recently, and the new Gnometris seems to keep a good response time at the higher levels, even with Tango Shaded theme. It looks like that I'm not affected anymore by this bug.

Changed in gnome-games:
importance: Unknown → Critical
Tomas Pospisek (tpo-deb) wrote :

There was a playable tetris game for the TI calculator like 20 years ago.

But still someone has managed to have Gnome ship a version of that game since 2007 that isn't even playable on 2011's supercomputers.

The culmination of social hacking!

Even Excel Tetris on an Arduino beats the crap out of this implementation performance wise. Hilarious!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.