gnome-games-app has broken AppStream metadata

Bug #1787780 reported by Jeremy Bicha on 2018-08-19
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-games-app (Ubuntu)
Medium
Unassigned
Bionic
Medium
Jeremy Bicha

Bug Description

Impact
------
The metadata license field in gnome-games-app's Appstream metadata is not recognized as valid by appstream-generator. Because of this, the metadata is not used and the entry in the GNOME/Ubuntu Software app is a minimal entry generated from its .desktop. That introduces a major problem where the libretro addons do not show up in the GNOME Software app on the GNOME Games page. This makes it much more difficult for people to install the libretro addons needed to play many games.

http://appstream.ubuntu.com/bionic/universe/issues/gnome-games-app.html

Test Case
---------
1. Please wait up to a day after the update is built and published for the metadata to be published to the Ubuntu Software app.
2. Make sure that Ubuntu Software is not running. You can do this by logging out and logging back in or by running a command like
pkill gnome-software
3. Open Ubuntu Software.
4. Search for GNOME Games. Click the GNOME Games result.
It should show a screenshot and 3 (or maybe more) addons.

Regression Potential
--------------------
This is a very minimal fix cherry-picked from upstream's gnome-3-28 branch.

Jeremy Bicha (jbicha) on 2018-08-19
description: updated
Changed in gnome-games-app (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games-app - 3.28.0-2

---------------
gnome-games-app (3.28.0-2) unstable; urgency=medium

  * Set Architecture to linux-any since libmanette and retro-gtk are
    Linux-only
  * Update debian/gbp.conf
  * Cherry-pick appdata-Fix-metainfo-license.patch:
    Fix metadata license in Appstream metadata (LP: #1787780)

 -- Jeremy Bicha <email address hidden> Sat, 18 Aug 2018 22:04:14 -0400

Changed in gnome-games-app (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2018-09-04
Changed in gnome-games-app (Ubuntu Bionic):
status: Triaged → In Progress
assignee: nobody → Jeremy Bicha (jbicha)

Hello Jeremy, or anyone else affected,

Accepted gnome-games-app into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-games-app/3.28.0-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-games-app (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Bartosz Kosiorek (gang65) wrote :

After upgrade package from proposed, the plugin list are appearing.
Verification done.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-games-app has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-games-app - 3.28.0-1ubuntu1

---------------
gnome-games-app (3.28.0-1ubuntu1) bionic; urgency=medium

  * Cherry-pick appdata-Fix-metainfo-license.patch:
    Fix metadata license in Appstream metadata so that GNOME Games and
    its addons shows correctly in the Ubuntu Software app (LP: #1787780)

 -- Jeremy Bicha <email address hidden> Mon, 03 Sep 2018 21:05:03 -0400

Changed in gnome-games-app (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers