Activity log for bug #1607937

Date Who What changed Old value New value Message
2016-07-29 20:21:00 Rinzwind bug added bug
2016-07-29 20:26:29 Launchpad Janitor gnome-font-viewer (Ubuntu): status New Confirmed
2016-07-29 20:29:14 Gunnar Hjalmarsson bug added subscriber Gunnar Hjalmarsson
2016-07-29 22:36:49 Gunnar Hjalmarsson bug task added language-selector (Ubuntu)
2016-07-29 22:37:03 Gunnar Hjalmarsson nominated for series Ubuntu Xenial
2016-07-29 22:37:03 Gunnar Hjalmarsson bug task added language-selector (Ubuntu Xenial)
2016-07-29 22:37:03 Gunnar Hjalmarsson bug task added gnome-font-viewer (Ubuntu Xenial)
2016-07-29 22:37:16 Gunnar Hjalmarsson bug task deleted language-selector (Ubuntu)
2016-07-29 22:37:23 Gunnar Hjalmarsson bug task deleted language-selector (Ubuntu Xenial)
2016-07-29 22:37:46 Gunnar Hjalmarsson gnome-font-viewer (Ubuntu): status Confirmed Fix Released
2016-07-29 22:38:05 Gunnar Hjalmarsson gnome-font-viewer (Ubuntu Xenial): importance Undecided High
2016-07-29 22:38:05 Gunnar Hjalmarsson gnome-font-viewer (Ubuntu Xenial): status New In Progress
2016-07-29 22:38:05 Gunnar Hjalmarsson gnome-font-viewer (Ubuntu Xenial): assignee Gunnar Hjalmarsson (gunnarhj)
2016-07-29 22:38:57 Gunnar Hjalmarsson description Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ... Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options. [Impact] While gnome-font-viewer can be started from command line, it fails to start via the .desktop file. As can be seen in comment #3, it seems to be related to DBus somehow. The problem is not present in version 3.20.2-1 in yakkety, and since there is no obvious single commit in the upstream source which could be patched, the proposal is to backport the yakkety version as an SRU. It's built in this PPA: https://launchpad.net/~gunnarhj/+archive/ubuntu/font-viewer and there are no runtime dependency blockers. [Test Case] Try to start gnome-font-viewer from the Dash and find that the launch fails. After having installed the proposed upload, starting the application from the Dash works fine. [Regression Potential] gnome-font-viewer is an independent tool, which doesn't affect other parts of the system. Hence the regression risk should be low. [Original description] Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ...    Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service    Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options.
2016-07-29 22:40:41 Gunnar Hjalmarsson bug added subscriber Ubuntu Sponsors Team
2016-07-29 22:42:58 Gunnar Hjalmarsson tags xenial
2016-07-30 01:39:14 Jeremy Bicha bug watch added https://bugzilla.gnome.org/show_bug.cgi?id=765518
2016-07-30 01:39:14 Jeremy Bicha bug task added gnome-font-viewer
2016-07-30 01:52:06 Jeremy Bicha bug added subscriber Jeremy Bicha
2016-07-30 02:20:59 Bug Watch Updater gnome-font-viewer: status Unknown Fix Released
2016-07-30 02:20:59 Bug Watch Updater gnome-font-viewer: importance Unknown Medium
2016-07-30 02:51:09 Gunnar Hjalmarsson description [Impact] While gnome-font-viewer can be started from command line, it fails to start via the .desktop file. As can be seen in comment #3, it seems to be related to DBus somehow. The problem is not present in version 3.20.2-1 in yakkety, and since there is no obvious single commit in the upstream source which could be patched, the proposal is to backport the yakkety version as an SRU. It's built in this PPA: https://launchpad.net/~gunnarhj/+archive/ubuntu/font-viewer and there are no runtime dependency blockers. [Test Case] Try to start gnome-font-viewer from the Dash and find that the launch fails. After having installed the proposed upload, starting the application from the Dash works fine. [Regression Potential] gnome-font-viewer is an independent tool, which doesn't affect other parts of the system. Hence the regression risk should be low. [Original description] Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ...    Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service    Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options. [Impact] While gnome-font-viewer can be started from command line, it fails to start via the .desktop file. As can be seen in comment #3, it seems to be related to DBus somehow. The problem is not present in version 3.20.2-1 in yakkety. Probably it was fixed via this commit: https://git.gnome.org/browse/gnome-font-viewer/commit/?id=acf919c The NEWS in 3.20.0 and 3.20.2 can be found here: https://git.gnome.org/browse/gnome-font-viewer/tree/NEWS Considering that other upstream changes seem to consist of a few minor bug fixes and translation updates, 3.20.2-1 might be considered a suitable microrelease to be backported. Consequently the proposal is to backport the yakkety version as an SRU. It's built in this PPA: https://launchpad.net/~gunnarhj/+archive/ubuntu/font-viewer and there are no runtime dependency blockers. [Test Case] Try to start gnome-font-viewer from the Dash and find that the launch fails. After having installed the proposed upload, starting the application from the Dash works fine. [Regression Potential] gnome-font-viewer is an independent tool, which doesn't affect other parts of the system. Hence the regression risk should be low. [Original description] Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ... Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options.
2016-07-30 22:38:06 Mathew Hodson gnome-font-viewer (Ubuntu): importance Undecided Medium
2016-08-08 12:10:14 Richard bug added subscriber Richard
2016-08-10 08:29:37 Sebastien Bacher removed subscriber Ubuntu Sponsors Team
2016-08-10 16:54:24 Gunnar Hjalmarsson attachment added gnome-font-viewer_GApplication.patch https://bugs.launchpad.net/ubuntu/+source/gnome-font-viewer/+bug/1607937/+attachment/4718486/+files/gnome-font-viewer_GApplication.patch
2016-08-10 16:55:36 Gunnar Hjalmarsson description [Impact] While gnome-font-viewer can be started from command line, it fails to start via the .desktop file. As can be seen in comment #3, it seems to be related to DBus somehow. The problem is not present in version 3.20.2-1 in yakkety. Probably it was fixed via this commit: https://git.gnome.org/browse/gnome-font-viewer/commit/?id=acf919c The NEWS in 3.20.0 and 3.20.2 can be found here: https://git.gnome.org/browse/gnome-font-viewer/tree/NEWS Considering that other upstream changes seem to consist of a few minor bug fixes and translation updates, 3.20.2-1 might be considered a suitable microrelease to be backported. Consequently the proposal is to backport the yakkety version as an SRU. It's built in this PPA: https://launchpad.net/~gunnarhj/+archive/ubuntu/font-viewer and there are no runtime dependency blockers. [Test Case] Try to start gnome-font-viewer from the Dash and find that the launch fails. After having installed the proposed upload, starting the application from the Dash works fine. [Regression Potential] gnome-font-viewer is an independent tool, which doesn't affect other parts of the system. Hence the regression risk should be low. [Original description] Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ... Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options. [Impact] While gnome-font-viewer can be started from command line, it fails to start via the .desktop file. The issue was fixed upstream via this commit: https://git.gnome.org/browse/gnome-font-viewer/commit/?id=acf919c The attached patch cherry picks that commit. [Test Case] Try to start gnome-font-viewer from the Dash and find that the launch fails. After having installed the proposed upload, starting the application from the Dash works fine. [Regression Potential] gnome-font-viewer is an independent tool, which doesn't affect other parts of the system. Hence the regression risk should be low. [Original description] Ubuntu 16.04.1 Fully updated. $ gnome-font-viewer --version GNOME Font Viewer 3.16.2 - starting from command-line: no problems. - starting from dash: application is shown in launcher but kills itself. - /var/log/syslog shows ... Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Unknown option --gapplication-service Jul 29 22:18:08 schijfwereld org.gnome.font-viewer[3361]: Run '/usr/bin/gnome-font-viewer --help' to see a full list of available command line options.
2016-08-10 16:57:54 Gunnar Hjalmarsson bug added subscriber Ubuntu Sponsors Team
2016-08-10 19:04:33 Mathew Hodson summary font viewer starred from dash: Unknown option --gapplication-service Font Viewer fails to start from dash: Unknown option --gapplication-service
2016-08-10 19:12:38 Mathew Hodson tags xenial patch xenial
2016-08-12 05:38:36 Jeremy Bicha removed subscriber Ubuntu Sponsors Team
2016-08-12 05:38:41 Jeremy Bicha gnome-font-viewer (Ubuntu Xenial): assignee Gunnar Hjalmarsson (gunnarhj)
2016-08-14 09:00:40 Eldar Khayrullin bug added subscriber Eldar Khayrullin
2016-08-22 10:33:47 Martin Pitt gnome-font-viewer (Ubuntu Xenial): status In Progress Fix Committed
2016-08-22 10:33:49 Martin Pitt bug added subscriber Ubuntu Stable Release Updates Team
2016-08-22 10:33:50 Martin Pitt bug added subscriber SRU Verification
2016-08-22 10:33:53 Martin Pitt tags patch xenial patch verification-needed xenial
2016-08-22 14:21:53 Gunnar Hjalmarsson tags patch verification-needed xenial patch verification-done xenial
2016-08-31 15:08:11 Chris J Arges removed subscriber Ubuntu Stable Release Updates Team
2016-08-31 15:18:14 Launchpad Janitor gnome-font-viewer (Ubuntu Xenial): status Fix Committed Fix Released