gnome-font-viewer freezes up itself or the X session

Bug #1375819 reported by Reinis Zumbergs on 2014-09-30
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-font-viewer (Fedora)
Won't Fix
High
gnome-font-viewer (Ubuntu)
Critical
Unassigned
Nominated for Utopic by Alberto Salvia Novella

Bug Description

When I open gnome-font-viewer by clicking on font file (tried on TTF and PFB) it sometimes locks up. Then nothing can be done within the window, but the rest of X session works. However sometimes the whole X session freezes, only mouse cursor moves. It can be worked around by switching to tty1 and killall'ing gnome-font-viewer.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: gnome-font-viewer 3.12.0-1
ProcVersionSignature: Ubuntu 3.16.0-18.25-generic 3.16.3
Uname: Linux 3.16.0-18-generic x86_64
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Sep 30 16:46:07 2014
InstallationDate: Installed on 2013-07-21 (436 days ago)
InstallationMedia: Xubuntu 13.04 "Raring Ringtail" - Release amd64 (20130423.1)
SourcePackage: gnome-font-viewer
UpgradeStatus: Upgraded to utopic on 2014-09-25 (4 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-font-viewer (Ubuntu):
status: New → Confirmed
Changed in gnome-font-viewer (Ubuntu):
importance: Undecided → Critical
description: updated
Changed in gnome-font-viewer (Ubuntu):
status: Confirmed → Triaged
Kirue (kirue) wrote :

I had the same problem when installing fonts from .ttf files. Either the system froze completely and I had to reboot manually or just the font viewer window froze, in that case I could right click it in the dock and close it.
However, I found that a bit of patience with the program helps to prevent the freezing. When I wait about 10 seconds after I opened the font in the viewer and before I click install and do the same after it said "installed" and before I close the font viewer, no crash occured.

Nate Olander (aeves-nate) wrote :

I have this same issue. I launched gnome-font-viewer from the terminal and got this output:

$ gnome-font-viewer Desktop/FantasqueSansMono-RegItalic.otf

(gnome-font-viewer:30277): Gdk-ERROR **: The program 'gnome-font-viewer' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadShmSeg (invalid shared segment parameter)'.
  (Details: serial 1517 error_code 128 request_code 130 (MIT-SHM) minor_code 5)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the GDK_SYNCHRONIZE environment
   variable to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
Trace/breakpoint trap (core dumped)

Changed in gnome-font-viewer (Fedora):
importance: Unknown → High
status: Unknown → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.