1804.1 - sticky-keys not working in gnome-session-flashback

Bug #1790744 reported by davidr on 2018-09-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-flashback (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]

I installed 18.04.1 on my pc. I was previously running 16.04 series. When using GNOME Flashback sticky-keys settings do not work.

[Test Case]

1. While in GNOME Flashback, go to System Settings > Universal Access > Typing Assist and set Sticky Keys ON.

2. Open any document or a new text file and try to use combinations like
Ctrl+C, Ctrl+V by pressing the keys separately.

3. “Beep when a modifier key is pressed” should behave accordingly, and produce a sound when sound is enabled.

4. Activate the “Enable by Keyboard” setting. After that, holding down Shift key for 8 seconds should activate Slow Keys feature, and there should be a notification bubble about it. Pressing the Shift key 5 times in a row should activate Sticky Keys feature, and there should be a notification bubble about it. Pressing any two keys simultaneously should disable this feature, again with a notification.

[Regression Potential]

The changes are adding new code, so the potential for regressions are bugs and crashes in that code. However, that code is activated only if the user enables some accessibility features in settings. Also, this code is shipped in GNOME Flashback 3.30 in Ubuntu 18.10, and no crashes have been reported to Launchpad or errors.ubuntu.com.

[Other Info]

Description: Ubuntu 18.04.1 LTS
Release: 18.04

gnome-flashback:
  Installed: 3.18.2-1ubuntu1

The changes are backports of the following two upstream commits:

https://gitlab.gnome.org/GNOME/gnome-flashback/commit/15a4900dfb17860b (sticky keys plugin)
https://gitlab.gnome.org/GNOME/gnome-flashback/commit/453781f5ccdc6895 (notifications fix needed by sticky keys plugin)

These commits are applied upstream in version 3.30.0.

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1790744/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Paul White (paulw2u) on 2018-09-05
affects: ubuntu → gnome-flashback (Ubuntu)
davidr (davaweb) wrote :

https://bugs.launchpad.net/ubuntu/+bug/1790744/+editstatus

gives me "This page does not exist" so I can not add the package name "to the text box".

The package name in synaptic is as above, gnome-session-flashback

but I note from Paul White he refers to gnome-flashback (thank you).

Does anybody know how to add the package for me please?

Dmitry Shachnev (mitya57) wrote :

The package is already added, see Paul’s change above.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-flashback - 3.30.0-1ubuntu1

---------------
gnome-flashback (3.30.0-1ubuntu1) cosmic; urgency=medium

  * Merge with Debian unstable, remaining changes:
    - debian/rules:
      + Add an epoch number to gnome-session-flashback package.
    - debian/gnome-flashback-common.gsettings-override:
      + Disable some not needed gnome-flashback components.
      + Add the default settings for GNOME Flashback sessions.
    - debian/gnome-session-flashback.target:
      + The target file for systemd, based on ubuntu-session.target.
      + Install this file into /usr/lib/systemd/user/ directory.
    - debian/control.in:
      + Bump gnome-session-bin dependency to 3.18.1.2-1ubuntu5, to be able
        to use run-systemd-session.
      + Add dependencies on dbus-user-session, indicator-common, nautilus
        and systemd.
      + Use Ubuntu VCS fields.
    - debian/patches/run-systemd-session.diff:
      + Use run-systemd-session script for running the session.
    - debian/patches/support-indicator-keyboard.diff:
      + Support “org.gnome.desktop.input-sources current” key, to make
        indicator-keyboard working.
    - debian/patches/revert-nautilus-remove.diff:
      + Revert removing nautilus-classic from required components. Ubuntu
        18.10 ships Nautilus 3.26, which still has desktop icons support.
  * The new release brings the following features:
    - Accessibility keyboard plugin, supporting sticky keys (LP: #1790744).
    - Per-window input sources support (LP: #1769838).
  * Drop assign-groups-in-order.diff, applied in the new release.
  * Drop trackpoint-settings.diff, applied in the new release.
  * Refresh debian/patches/support-indicator-keyboard.diff.
  * Add epoch to the required metacity version (1:3.30.1).
  * Remove button-layout override which is now present upstream.

 -- Dmitry Shachnev <email address hidden> Mon, 10 Sep 2018 10:47:44 +0300

Changed in gnome-flashback (Ubuntu):
status: New → Fix Released
davidr (davaweb) wrote :

Thank you Dmitry.

My version is 3.28

Is there a way I can get it updated to 3.30?

David

davidr (davaweb) wrote :

Hi Albetrts

I can't see from your link what I am supposed to do.

Apologies for the inconvenience.

David

You need to update bug report description to match SRU Bug template.

For example you can look at this bug:
https://bugs.launchpad.net/ubuntu/+source/gnome-flashback/+bug/1769838

Or this one:
https://bugs.launchpad.net/ubuntu/+source/gnome-flashback/+bug/1790336

You did not need to open new bug, you can edit original bug. :) I copied new bug description to this one and closed as invalid.

description: updated
description: updated
tags: removed: bot-comment
davidr (davaweb) wrote :

Thank you Alberts.

Apologies - I could not see how to edit :(

David

No problem, but unfortunately this will take some time - there is already submitted fix for other bug. In other words we now need to wait until that fix is accepted and moved into -updates and only then it will be possible to process this bug.

davidr (davaweb) wrote :

Understood - thanks.

I'll have to stay with 1604.4 until it comes through as I can only use one hand. I don't suppose these fixes are ever available for public testing are they ? Just thinking ...

description: updated

Hello davidr, or anyone else affected,

Accepted gnome-flashback into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-flashback/3.28.0-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-flashback (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
davidr (davaweb) wrote :

Thanks Brian,

Will do when it is up - I'm getting File not Found with the link on launchpad at the moment.

Many thanks,

David

davidr (davaweb) wrote :

Hi Brian,

I'm still not able to download gnome-flashback/3.28.0-1ubuntu1.3 from https://launchpad.net/ubuntu/+source/gnome-flashback/3.28.0-1ubuntu1.3

All I get is File Not Found.

Am I too impatient?

regards,
David

What are you trying to do?

You should enable proposed and then using apt upgrade to new version. Proposed might have other packages - you can install / upgrade all or only gnome-flashback.

davidr (davaweb) wrote :

Hi Alberts,

As per Brian's post #14 trying to dowload the packages from launchpad.

I have Proposed enabled and at the time of wring my previous post the update had not come through.

However, it now has and sticky-keys is working now in gnome-flashback.

Many thanks to all who worked on this.
Regards,
David

davidr (davaweb) wrote :

Fix works:
18.04.1 flashback

Sticky keys and keyboard accessibility panel indicator work.

Changed in gnome-flashback (Ubuntu Bionic):
status: Fix Committed → Opinion

Post output from:
apt-cache policy gnome-flashback

Changed in gnome-flashback (Ubuntu Bionic):
status: Opinion → Fix Committed

@davidr, can you post output from apt-cache command above? We need to know that you have correct version installed...

davidr (davaweb) wrote :

As requested, but please note it is working perfectly since I update:

$ apt-cache policy gnome-flashback
gnome-flashback:
  Installed: 3.28.0-1ubuntu1.3
  Candidate: 3.28.0-1ubuntu1.3
  Version table:
 *** 3.28.0-1ubuntu1.3 100
        100 /var/lib/dpkg/status
     3.28.0-1ubuntu1.2 500
        500 http://archive.ubuntu.com/ubuntu bionic-updates/universe amd64 Packages
     3.28.0-1ubuntu1 500
        500 http://archive.ubuntu.com/ubuntu bionic/universe amd64 Packages

Thanks!

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic

The verification of the Stable Release Update for gnome-flashback has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-flashback - 3.28.0-1ubuntu1.3

---------------
gnome-flashback (3.28.0-1ubuntu1.3) bionic; urgency=medium

  * Backport Accessibility Keyboard plugin from upstream, adding support
    for sticky keys and other accessibility features (a11y-keyboard.diff;
    LP: #1790744).
  * This also needs a small fix in Notifications module to correctly close
    bubbles on API call (notifications-close-bubble.diff).

 -- Dmitry Shachnev <email address hidden> Thu, 11 Oct 2018 18:25:50 +0300

Changed in gnome-flashback (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers