gnome-flashback crashes with XError in flashback_monitor_manager_apply_configuration

Bug #1619895 reported by errors.ubuntu.com bug bridge on 2016-09-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-flashback (Ubuntu)
Undecided
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-flashback. This problem was most recently seen with version 3.18.2-1ubuntu1, the problem page at https://errors.ubuntu.com/problem/af811351a031062e6c411ef016093e9a3a9950f2 contains more details.

This is the most "popular" crash in gnome-flashback on errors.ubuntu.com, with 593 occurancies. It affects 15.10 and 16.04, however I do not know whether it affects 16.10 or not.

Dmitry Shachnev (mitya57) wrote :

A stacktrace, from errors.ubuntu.com.

summary: - /usr/bin/gnome-
- flashback:5:XRRSetCrtcConfig:flashback_monitor_manager_apply_configuration:apply_configuration:flashback_monitor_config_make_default:flashback_monitor_manager_on_hotplug
+ gnome-flashback crashes with XError in
+ flashback_monitor_manager_apply_configuration
description: updated

It might be good to know if this crash happens because unity-settings-daemon tries to do same thing? Probably with GNOME-Flashback:Unity display-config should have been disabled...

Dmitry Shachnev (mitya57) wrote :

Right, if unity-settings-daemon does the same, then it's a good idea to disable display-config handling for 16.10.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-flashback - 3.20.2-1ubuntu2

---------------
gnome-flashback (3.20.2-1ubuntu2) yakkety; urgency=medium

  * Disable shell component (workaround for LP: #1619895).

 -- Dmitry Shachnev <email address hidden> Sun, 04 Sep 2016 19:26:33 +0300

Changed in gnome-flashback (Ubuntu):
status: New → Fix Released
Dmitry Shachnev (mitya57) wrote :

There are 11 entries of this issue errors.ubuntu.com with version 3.20.2-1ubuntu2. So the workaround did not help.

Changed in gnome-flashback (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments