[fix] Gnome 3 compatibility

Bug #752578 reported by Elad Alfassa
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-exe-thumbnailer (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-exe-thumbnailer

Gnome has switched to using gsettings instead of gconf in gnome 3, so for gnome-exe-thumbnailer to work on gnome 3, a gsettings schema has to be provided.

Revision history for this message
Elad Alfassa (elad661) wrote :

Apparently thumnbailer configuration is not in gsettings as well, but in external thumnbailer configuration file.
Install the attached file as /usr/share/thumbnailers/gnome-exe-thumbnailer.thumbnailer

See also https://bugzilla.redhat.com/show_bug.cgi?id=636819#c29

summary: - Provide a gsettings schema
+ [fix] Gnome 3 compatibility
Revision history for this message
Elad Alfassa (elad661) wrote :

Oh, this file requires the thumbnailer to handle gvfs URIs instead of absolute pathnames...

Revision history for this message
Elad Alfassa (elad661) wrote :

Change the %u in the file to %s to fix this.

Revision history for this message
Elad Alfassa (elad661) wrote :

oh oops, I mean %i

Revision history for this message
Jack Leigh (leighman) wrote :

Not working in Precise.
Is this the cause?
Any news on the package?

Revision history for this message
Jan Nekvasil (jan-nekvasil) wrote :

Scott Ritchie, the Ubuntu's wine maintainer, got a new version of gnome-exe-thumbnailer which includes fix for this bug already, but he is busy just now getting wine1.4 all working nicely with Precise. Please, be patient, I believe that this fix makes it into Precise on time.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-exe-thumbnailer - 0.9-0ubuntu1

---------------
gnome-exe-thumbnailer (0.9-0ubuntu1) precise; urgency=low

  * New version (thanks Jan Nekvasil)
    - added support for GNOME 3 (LP: #752578, #879267)
    - read current icon theme from dconf first
    - added thumbnail templates for the Faience icon theme
    - cleaner templates for the Faenza icon themes
    - DISPLAY=NONE for getting rid of the occasional "Wine is updating" window
      when extracting ProductVersion with MS Windows Script Host
    - delete old thumbnails created by g-e-t on it's first run after the icon
      theme change
  * debian/copyright: convert to dep5 format
 -- Scott Ritchie <email address hidden> Sun, 11 Mar 2012 05:18:23 -0700

Changed in gnome-exe-thumbnailer (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.