gnome-dvb-daemon does not find channels in Estonia and Lithuania

Bug #674993 reported by Erki Hallingu on 2010-11-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME DVB Daemon
Undecided
Unassigned
Baltix
Undecided
Unassigned
gnome-dvb-daemon (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-dvb-daemon

gnome-dvb-daemon does not find channels in Estonia.

Otherwize when using
scan ee-All > dvb_channels.conf
and imorting dvb_channels.conf file, I'm able to watch tv channels perfectly with Totem.

Kaffeine works by itself and finds channels automatically.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-dvb-daemon 0.1.21-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-23.37-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
Architecture: amd64
Date: Sat Nov 13 22:13:17 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANG=et_EE.utf8
 SHELL=/bin/bash
SourcePackage: gnome-dvb-daemon

Erki Hallingu (erkiha) wrote :
Mantas Kriaučiūnas (mantas) wrote :

I can confirm this bug in Lithuania (country code: lt) too :(
Erki Hallingu, could you tell me how to import dvb_channels.conf file into gnome-dvb-daemon?

Btw, maybe this bug is fixed in latest gnome-dvb-daemon release?

Version 0.2.1 - 2011-05-23
=============
 DVB-T brute-force scan works correctly, again.
- Fixed binding gettext domain
- gnomedvb: Set window position of preferences window
- gnomedvb: Launch gnome-dvb-setup when pressing on preferences button
- Manager: disconnect from destroyed signal before destroying Scanners in shutdown
- Adjusted DVB-T brute-force scan to new signature of AddScanningData method

Latest release can be downloaded from http://download.gnome.org/sources/gnome-dvb-daemon/0.2/

Please update Ubuntu packages to gnome-dvb-daemon 0.2.1

summary: - gnome-dvb-daemon does not find channels in Estonia
+ gnome-dvb-daemon does not find channels in Estonia and Lithuania
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-dvb-daemon (Ubuntu):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I still can't choose Lithuania country in gnome-dvb-setup from gnome-dvb-daemon package in newest Ubuntu 11.10 (Oneiric).
There is /usr/share/dvb/dvb-t/lt-All for whole Lithuanian country since Ubuntu 10.10 (Maverick), but gnome-dvb-setup 0.1.23 and older doesn't see it :(

Fortunately I found a workaround - I simply copy standard channels.conf file with channels info to ~/.config/gnome-dvb-daemon/channels_DVB-T.conf and killall gnome-dvb-daemon process.
Just tested this in Ubuntu 11.04 with gnome-dvb-daemon packages from gnome-dvb-daemon PPA - https://launchpad.net/~gnome-dvb-daemon/+archive

Mantas Kriaučiūnas (mantas) wrote :

Latest version of gnome-dvb-daemon (0.2.4) still doesn't offer Lithuania, Latvia and Estonia countries in gnome-dvb-setup tool from gnome-dvb-daemon 0.2.4-0~oneiric3 package (from https://launchpad.net/~gnome-dvb-daemon/+archive )
There is /usr/share/dvb/dvb-t/lt-All for whole Lithuanian country since 2010, but gnome-dvb-setup 0.2.4 (and all older versions) doesn't see it :(
Maybe I should report a bug in GNOME Bugzilla?

Sebastian Pölsterl (sebp) wrote :

Thanks for reporting this bug.

I just added additional countries: http://git.gnome.org/browse/gnome-dvb-daemon/commit/?id=d0035029f3fba00d9480c55b78be33e71dc7e0c1

I did not add Estonia because I couldn't find any initial tuning data at linuxtv.org for it.

I will release a new version that includes this fix shortly.

Changed in gnome-dvb-daemon (Ubuntu):
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed
Changed in gnome-dvb-daemon:
status: New → Fix Committed
Mantas Kriaučiūnas (mantas) wrote :

Sebastian Pölsterl (sebp) wrote on 2011-10-10:
> I just added additional countries: http://git.gnome.org/browse/gnome-dvb-daemon/commit/?id=d0035029f3fba00d9480c55b78be33e71dc7e0c1

I'm attaching a patch file from your commit - it applies cleanly even on gnome-dvb-daemon 0.1.23 (works on Ubuntu 11.04/Gnome 2.32)!

Sebastian, could you build gnome-dvb-daemon packages for Ubuntu 11.04 (Natty) with this patch applied in PPA? Lots of people like old GNOME 2.32 and Ubuntu 11.04 is the latest version with old GNOME.

The attachment "patch, adding additional countries (Lithuania, Latvia, etc) for gnome-dvb-daemon 0.1.2x and 0.2" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Sebastian Pölsterl (sebp) wrote :

I uploaded a new package for natty, it might need some time to build, though. Could you please test if the updated package solves your issue.

Changed in gnome-dvb-daemon:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers