Scanning for channels produces a faulty list and prevents DVB playback

Bug #548738 reported by bojo42 on 2010-03-26
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME DVB Daemon
High
Unassigned
gnome-dvb-daemon (Ubuntu)
Low
Unassigned
totem (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-dvb-daemon

In the course of debugging Bug #361322 we had to recognize that gnome-dvb-setup can produce a channels list that contains the wrong tunning parameters. This is a showstopper as users will just perceive that Totem's DVB playback and recording via gnome-dvb-daemon will not work.

For user reading this bug: you can work around this bug by placing a working channels.conf to ~/.config/gnome-dvb-daemon/channels_DVB-T.conf

Related branches

bojo42 (bojo42) wrote :

so far i can confirm that at least DVB-T is affected.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in totem (Ubuntu):
importance: Undecided → Low
bojo42 (bojo42) wrote :

Okay i opened an upstream report at Bug #548776 , but didn't manage it to add it via "Also affects project". BTW Sebastian Pölsterl (who is the upstream author) is already aware of the issue.

Sebastian Pölsterl (sebp) wrote :

Could someone please check if the attached patch improves the situation?

Changed in gnome-dvb-daemon:
importance: Undecided → High
Frédéric Crozat (fcrozat) wrote :

this patch doesn't build with g-d-d 0.1.16 + vala 0.8.0.

Sebastian Pölsterl (sebp) wrote :

I'm aware of the issues with vala 0.8.0. I'm currently working on it, give me 30 minutes ;)

Sebastian Pölsterl (sebp) wrote :

Should be fixed in bzr now.

Frédéric Crozat (fcrozat) wrote :

ok, it works fine (it only found a subset of available channels but it might be caused by fr-Paris file being incorrect, I didn't test a full scan yet) but I found another bug in the process #558583 :)

Sebastian Pölsterl (sebp) wrote :

Are the errors/warnings you mentioned in bug #540937 gone as well?

Frédéric Crozat (fcrozat) wrote :

no, they are still there (log attached).

Sebastian Pölsterl (sebp) wrote :

Ok, the frequency that's causing problems has been retrieved during the scan (not in initial tuning data). If I understand it correctly, it isn't fatal, the broadcaster just put a wrong frequency in there.

Changed in gnome-dvb-daemon:
status: New → Fix Committed
tags: added: patch
Changed in gnome-dvb-daemon:
status: Fix Committed → Fix Released
Nigel Babu (nigelbabu) wrote :

This patch has been accepted upstream and the new version is in debian, should be synced for maverick.

tags: added: patch-accepted-upstream
removed: patch
Sebastien Bacher (seb128) wrote :

the new version has been synced

Changed in gnome-dvb-daemon (Ubuntu):
importance: Undecided → Low
Changed in totem (Ubuntu):
status: New → Invalid
Changed in gnome-dvb-daemon (Ubuntu):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the new version has been synced to maverick now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions