gnome-dvb-daemon crashed with SIGSEGV in dvb_scanner_Destroy()

Bug #528849 reported by Michael Lamothe on 2010-02-27
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME DVB Daemon
Undecided
Unassigned
gnome-dvb-daemon (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-dvb-daemon

Had started gnome-dvb-daemon on the command line and left it running, then started gnome-dvb-setup, finished scanning, pressed the "Next" button and this happened.

ProblemType: Crash
Architecture: amd64
Date: Sat Feb 27 15:54:48 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gnome-dvb-daemon
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
NonfreeKernelModules: nvidia
Package: gnome-dvb-daemon 0.1.13-1ubuntu1
ProcCmdline: gnome-dvb-daemon
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_AU.utf8
ProcVersionSignature: Ubuntu 2.6.32-14.20-generic
SegvAnalysis:
 Segfault happened at: 0x486dac <dvb_scanner_Destroy+92>: mov 0x40(%rax),%rdi
 PC (0x00486dac) ok
 source "0x40(%rax)" (0xaaaaaaaaaaaaaaea) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-dvb-daemon
StacktraceTop:
 dvb_scanner_Destroy ()
 ?? ()
 dvb_id_bus_terrestrial_scanner_dbus_message ()
 dvb_terrestrial_scanner_dbus_message ()
 ?? () from /lib/libdbus-1.so.3
Title: gnome-dvb-daemon crashed with SIGSEGV in dvb_scanner_Destroy()
Uname: Linux 2.6.32-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

visibility: private → public

StacktraceTop:
 dvb_scanner_Destroy (self=0x15693d0,
 _dbus_dvb_id_bus_terrestrial_scanner_Destroy (
 dvb_id_bus_terrestrial_scanner_dbus_message (
 dvb_terrestrial_scanner_dbus_message (
 _dbus_object_tree_dispatch_and_unlock (

Sebastian Pölsterl (sebp) wrote :

Could you please check if the bug still appears with the latest version.

StacktraceTop:
 dvb_scanner_Destroy (self=0x15693d0,
 _dbus_dvb_id_bus_terrestrial_scanner_Destroy (
 dvb_id_bus_terrestrial_scanner_dbus_message (
 dvb_terrestrial_scanner_dbus_message (
 _dbus_object_tree_dispatch_and_unlock (

StacktraceTop:
 dvb_scanner_Destroy (self=0x15693d0,
 _dbus_dvb_id_bus_terrestrial_scanner_Destroy (
 dvb_id_bus_terrestrial_scanner_dbus_message (
 dvb_terrestrial_scanner_dbus_message (
 _dbus_object_tree_dispatch_and_unlock (

Martin Pitt (pitti) on 2010-03-02
tags: removed: need-amd64-retrace

I tried 0.1.15 and the same crash did not happen. However, gnome-dvb-daemon crashed so gnome-dvb-setup could not exit and I got this error every time I tried to close the window or click the "Close" button, "org.freedesktop.DBus.Error.ServiceUnknown: The name :1.142 was not provided by any .service files". Had to kill gnome-dvb-setup and restart gnome-dvb-daemon but this time it looked like it had channels.

For some reason apport did not fire. The totem plugin does not seem to work when manually installed, I think that this is because it does to /usr/local, maybe. Any ideas?

Changed in gnome-dvb-daemon:
status: New → Invalid
Changed in gnome-dvb-daemon (Ubuntu):
status: New → Confirmed
Sebastian Pölsterl (sebp) wrote :

The error you described is expected when the daemon crashes. It would be great if you could provide a stacktrace of the daemon's crash.

Regarding the Totem plugin, looks like you have to use --prefix=/usr when running configure

Sebastian Pölsterl (sebp) wrote :

Sorry, but I failed to reproduce the crash with neither 0.1.15 from the tarball nor the bzr version.

Sebastian Pölsterl (sebp) wrote :

I have an idea what might be the cause of the crash, could someone please try if the attached patch fixes the crash?

Changed in gnome-dvb-daemon:
status: Invalid → Incomplete

Yes, the patch fixes the issue for me at least.

tags: added: patch
Changed in gnome-dvb-daemon:
status: Incomplete → Fix Committed
Changed in gnome-dvb-daemon:
status: Fix Committed → Fix Released
Changed in gnome-dvb-daemon (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Committed
Emmet Hikory (persia) on 2010-05-04
tags: added: patch-accepted-upstream
JC Hulce (soaringsky) wrote :

This bug has been marked as Fix Committed for over a year. If the fix has made it into Ubuntu, please mark this bug as Fix Released. If the fix has been released upstream, but not Ubuntu, create a new bug asking for the new version and tag it with upgrade-software-version. If this bug has not been fixed anywhere, change the status back to Confirmed.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.