gnome-dvb-setup crashes on selecting a country

Bug #518327 reported by odi on 2010-02-07
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME DVB Daemon
Undecided
Unassigned
gnome-dvb-daemon (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-dvb-client

Upon selecting a country in the 'Country and Provider selection' window of gnome-dvb-setup 0.1.13 in lucid lynx a crash occurs.
Console output:

Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/gnomedvb/ui/wizard/pages/InitialTuningDataPage.py", line 284, in on_country_changed
    country, city = f.split('-', 1)
ValueError: need more than 1 value to unpack

The country is selected in the field but the 'Providers' field and the 'Forward' button is not actived and it is not possible to continue and do a channel scan

ProblemType: Crash
Architecture: amd64
Date: Sun Feb 7 10:45:02 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/gnome-dvb-setup
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: gnome-dvb-client 0.1.13-1ubuntu1
ProcAttrCurrent: unconfined (enforce)
ProcCmdline: python /usr/bin/gnome-dvb-setup --transient-for=20971837
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
PythonArgs: ['/usr/bin/gnome-dvb-setup', '--transient-for=20971837']
SourcePackage: gnome-dvb-daemon
Title: gnome-dvb-setup crashed with ValueError in on_country_changed()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/pymodules/python2.6/gnomedvb/ui/wizard/pages/InitialTuningDataPage.py", line 284, in on_country_changed
     country, city = f.split('-', 1)
 ValueError: need more than 1 value to unpack
Uname: Linux 2.6.32-12-generic x86_64
UserGroups:

Related branches

odi (odaker) wrote :
tags: removed: need-duplicate-check
visibility: private → public
Sebastian Pölsterl (sebp) wrote :

Which country did you select, or does it happen no matter which country?

odi (odaker) wrote :

no, it doesn't matter which country.
in fact, i figured out what caused the crash recently, just had forgotten that I filed this bug (sorry about that).
The problem is that it tries to parse the files that contain the frequencies to scan. The are located in /usr/share/dvb/dvb-c/ (for dvb-c) if I remember correctly.
What I had done was create a file in there that contained the frequencies for my provider (since none of the provided files were right for me) and named it something like 'myfreqs' which didn't follow the correct naming scheme. That is what caused the crash.
gnome-dvb-daemon expects ALL the files in that folder to follow the COUNTRY-CITY naming scheme.
When I selected the country it tried to find all the files that start with that country code ... and crashed.
What it actually should do is check the filename first instead of just trying to parse it an crash.

Sebastian Pölsterl (sebp) wrote :

You're absolutely right, it's fixed now.

Changed in gnome-dvb-daemon:
status: New → Fix Committed
Changed in gnome-dvb-daemon (Ubuntu):
importance: Undecided → Low
Changed in gnome-dvb-daemon:
status: Fix Committed → In Progress
status: In Progress → Fix Released
dino99 (9d9) wrote :

This version is outdated and no more supported

Changed in gnome-dvb-daemon (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers