Ubuntu

Positioning of gnome-do window is sometimes erratic

Reported by Mika Fischer on 2008-03-20
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Do
Low
Unassigned
gnome-do (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-do

I'm using version 0.4.0.1-0ubuntu1 on Ubuntu hardy.

Sometimes the gnome-do window will pop up in unexpected places instead of in the center of the screen. Even more annoyingly the drop-down list will always pop up in the "right" location in the center of the screen. Sometimes this can even lead to the situation that the main gnome-do window becomes obscured by the drop-down box.

Screenshots attached

Tags: ui Edit Tag help

Related branches

Mika Fischer (zoop) wrote :
Richard Harding (rharding) wrote :

I also get a jumping Do window whenever I tab to the second pane. It happens as soon as I tab over, the window jumps up. Then if I exit and launch it again, it's back to the normal spot.

Video here:
http://uploads.mitechie.com/packages/moving_do.ogg

Changed in do:
importance: Undecided → Low
status: New → Confirmed

Jumping Jehosaphat! Must be the new multiple-monitor code.

Changed in gnome-do:
importance: Undecided → Low
status: New → Confirmed
status: Confirmed → Triaged
Jason Smith (jassmith) wrote :

There is new code in bzr that might help with this situation (or at the very least will make it easier to debug). In the file PositionWindow.cs (Do.Addins/src/Do.UI/PositionWindow.cs) around line 72 there are 3 commented out writelines. If you would go ahead and uncomment those before you compile that would enable debuging output that is very useful to figure out what is going wrong here.

Mika Fischer (zoop) wrote :

I cannot even reproduce the issue with the version in bzr :)

Jason Smith (jassmith) wrote :

Marking as fixed in response to comments

Changed in do:
status: Confirmed → Fix Committed
CannyDuck (cannyduck) wrote :

Can please somebody fix this in the hardy release?

Richard Harding (rharding) wrote :

I talked with our packager for Hardy and this won't make it into the Hardy packages. Hardy releases in two days.

If this is too bad I'd suggest using the PPA packages instead, but be warned that those are not going to be the long term stable packages like the ones shipped with Hardy.

  • unnamed Edit (62 bytes, text/html; charset=ISO-8859-1)

PPA packages will not be less stable than Hardy packages.

Richard Harding (rharding) wrote :

Understood Dave, I was thinking more along the lines of things that would break backward compatibility. The types of change will be greater than one would expect for a package in a LTS Ubuntu release. I don't mean to discourage users from using the PPAs, but beware if there are changes that cause the user to make changes/adjustments on their end.

Bart Rose (jbrose3) wrote :

I'd been having the same issue with the package in Hardy's repository and upgraded to 0.4.2.0 from the PPA as suggested above. Unfortunately, it didn't resolve the problem. Any ideas?

Bart Rose (jbrose3) wrote :

Recently switched from fglrx to radeon driver for my ati card and the problem disappeared...

Ross Burton (ross) wrote :

I'm running do from bzr (last merge 2008-06-04) and see this frequently.

Benedikt (bernsmann) wrote :

I "sometimes" see it happen under Metacity (compositing enabled). Didn't occur with Compiz so far. Wish I knew how to reliably reproduce the problem and be of more help.

Jorge O. Castro (jorge) wrote :

Does anyone see this bug in .5?

Jason Smith (jassmith) wrote :

This is fixed in 0.5. The PPA has the fix.

Changed in gnome-do:
status: Triaged → Fix Committed
Jason Smith (jassmith) wrote :

Latest do in PPA has this fixed just fine =)

Changed in do:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do - 0.6.0.0-0ubuntu1

---------------
gnome-do (0.6.0.0-0ubuntu1) intrepid; urgency=low

  * New upstream version, packaging based on the soon-to-be uploaded Debian
    package in pkg-cli-apps svn. FFe is LP: #267020
  * New upstream version fixes erratic positioning bug (LP: #204372)
  * debian/control
    + Update build-depends for new version
    + Update standards version to 3.8.0, adding README.Source
  * debian/gnome-do-autostart.desktop
  * debian/gnome-do.install
    + Delete our desktop file, install upstream's translated desktop file
      to /etc/xdg/autostart instead.
  * debian/gnome-do.preinst
    + Remove old autostart file on upgrade (if unmodified). Otherwise
      GNOME Do will appear twice in the autostart list.
  * debian/gnome-do.1
    + Manpage updated for new version
  * debian/rules:
    + Fix get-orig-source target to run properly from any directory; now should
    be policy compliant.
  * debian/copyright:
    + Refresh for new upstream version
    + Update to more recent CopyrightFormat proposal

 -- Christopher James Halse Rogers <email address hidden> Sun, 14 Sep 2008 10:09:40 +1000

Changed in gnome-do:
status: Fix Committed → Fix Released
aloctavodia (aloctavodia) wrote :

this erratic behaviour starts today after upgrading from kamic to lucid alpha 3.

aloctavodia (aloctavodia) wrote :

I never before have experienced this problem (not in karmic or jaunty) I am using GNOME Do 0.8.3.1

thanks in advance

aloctavodia (aloctavodia) wrote :

As I say before this same problem start with alpha3 now in the second beta and is still there.

thank you!

Changed in gnome-do (Ubuntu):
status: Fix Released → New
Changed in do:
status: Fix Released → New
aloctavodia (aloctavodia) wrote :

The problem is related to metacity, the behavior just as expected with compiz

Davide Lasagna (lasagnadavide) wrote :

Found a solution:

1) open gconf-editor
2) uncheck /apps/metacity/general/disable_workarounds

Now it worrk as expected.

aloctavodia (aloctavodia) wrote :

Thanks Davide, your workarounds solves the positioning problem, but know the screen flick everytime DO is surmounted :-(

Bismark (bismark-foofus) wrote :

Running Lucid x64 and Gnome-Do 0.8.3.1+dfsg-1ubuntu1 with dual monitors in a stacked configuration. On the top monitor Gnome-Do appears right in the center of the screen when called, however on the bottom monitor (laptop screen) it is almost all the way down at the bottom of the screen. This means that when I call it on the bottom monitor, lists of results is displayed off screen.

I have the same issue as Bismark on my Lenovo T61 running Linux Mint 11 and Do 0.8.4. Due to the window position of Do, it is nearly unusable on my laptop screen.

Chris Halse Rogers (raof) wrote :

 status incomplete

If you're on Natty or Oneiric would you be able to try a build from the
do-testers PPA¹? I've pushed a change to the window summoning code
which might well fix this.

¹: https://launchpad.net/~do-testers/+archive/ppa

Changed in do:
status: New → Incomplete
Thomas Hotz (thotz) on 2012-11-23
Changed in gnome-do (Ubuntu):
status: New → Confirmed
Thomas Hotz (thotz) on 2013-05-02
Changed in do:
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers