Gnome Do application's site information goes to an advertisment site

Bug #1442873 reported by heartsmagic on 2015-04-11
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-do (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Trusty
Medium
Unassigned
Utopic
Medium
Unassigned
gnome-do-plugins (Ubuntu)
Medium
Unassigned
Precise
Medium
Unassigned
Trusty
Medium
Unassigned

Bug Description

[Impact]

Gnome Do's site definiton goes to an advertisement site in Ubuntu Software Center.

[Test Case]

Enable -proposed and update; apt-cache show gnome-do should list the Homepage as do.cooperteam.net, not do.davebsd.com.

[Regression Potential]

Low; Only changes package metadata.

affects: zipper.app (Ubuntu) → software-center (Ubuntu)
Matthew Paul Thomas (mpt) wrote :

Ubuntu Software Center shows the URL provided by the package, as you can see by entering "apt-cache show gnome-do" at a terminal. It's the package that is out of date.

affects: software-center (Ubuntu) → gnome-do (Ubuntu)
Changed in gnome-do (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
tags: added: bitesize
Chris Johnston (cjohnston) wrote :

There's already an upstream bug. Marking this as duplicate and expanding the upstream bug to the package.

Chris Halse Rogers (raof) wrote :

Is actually not a duplicate, Software Centre is picking up a different piece of data.

This is fixed in Vivid; I'll make some SRU uploads to fix it everywhere else.

Changed in gnome-do (Ubuntu):
status: Confirmed → Fix Released
description: updated

Hello heartsmagic, or anyone else affected,

Accepted gnome-do into utopic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.95.1-1ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Utopic):
status: New → Fix Committed
tags: added: verification-needed
Timo Aaltonen (tjaalton) wrote :

Hello heartsmagic, or anyone else affected,

Accepted gnome-do into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.9-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Trusty):
status: New → Fix Committed
heartsmagic (heartsmagic) wrote :

Thank you, after upgrade problem's solved.

Brian Murray (brian-murray) wrote :

Hello heartsmagic, or anyone else affected,

Accepted gnome-do into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do/0.8.5-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do (Ubuntu Precise):
status: New → Fix Committed
Brian Murray (brian-murray) wrote :

@heartsmagic - for which release of Ubuntu is this problem solved?

Changed in gnome-do (Ubuntu Utopic):
status: Fix Committed → Won't Fix
heartsmagic (heartsmagic) wrote :

When I wrote my last comment I was using 14.10 and the problem was fixed on that release.

Mathew Hodson (mathew-hodson) wrote :

I have the trusty-proposed repository enabled, and in Ubuntu Software Centre, the Version for GNOME Do shows gnome-do 0.9-1ubuntu0.1, and the Developer Web Site link goes to http://do.cooperteam.net/

tags: added: verification-done-trusty verification-needed-precise
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do - 0.9-1ubuntu0.1

---------------
gnome-do (0.9-1ubuntu0.1) trusty-proposed; urgency=low

  * debian/control: Update Homepage: to not point at spam URL. (LP: #1442873)
  * debian/patches/03_fix_website_address.patch:
    - Update help links to not point at spam URL. (LP: #1363589)
  * debian/patches/04_fix_mono_3.0_build.patch
    - Fix the build with mono 3.0 (LP: #1277891)
 -- Christopher James Halse Rogers <email address hidden> Tue, 14 Apr 2015 11:16:10 +1000

Changed in gnome-do (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-do has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in gnome-do (Ubuntu Precise):
importance: Undecided → Medium
Changed in gnome-do (Ubuntu Trusty):
importance: Undecided → Medium
Changed in gnome-do (Ubuntu Utopic):
importance: Undecided → Medium
Mathew Hodson (mathew-hodson) wrote :

The package gnome-do-plugins needs the same fix.

no longer affects: gnome-do-plugins (Ubuntu Utopic)
tags: added: packaging
Changed in gnome-do-plugins (Ubuntu):
importance: Undecided → Medium
Changed in gnome-do-plugins (Ubuntu Precise):
importance: Undecided → Medium
Changed in gnome-do-plugins (Ubuntu Trusty):
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-do-plugins (Ubuntu Trusty):
assignee: nobody → Joshua Bayfield (jbayfield)
Michael Terry (mterry) wrote :

I've uploaded Joshua's fix for gnome-do-plugins to trusty. Thanks, Joshua! Now once it lands, it just needs a quick verification.

Changed in gnome-do-plugins (Ubuntu Trusty):
status: Triaged → In Progress
Mathew Hodson (mathew-hodson) wrote :

Bug #1363589 is similar but separate. The changelogs have been mentioning these bugs seprately, and the most recent upload of gnome-do-plugins fixes this bug but not Bug #1363589

Mathew Hodson (mathew-hodson) wrote :

This bug was fixed in the package gnome-do-plugins (0.8.5-4)

gnome-do-plugins (0.8.5-4) unstable; urgency=medium

  * [76f7b70] Drop Flickr plugin as it fails to authenticate.
  * [a8446ca] Drop WindowManager plugin. (Closes: 798874)
  * [cd192c0] Update Homepage field
  * [8aff48b] Mark as Built-Using: banshee
  * [3c36fa0] Bump Standards-Version now that we correctly set Built-Using

 -- Christopher James Halse Rogers <email address hidden> Thu, 12 Nov 2015 10:59:34 +0000

Changed in gnome-do-plugins (Ubuntu):
status: New → Fix Released
Changed in gnome-do-plugins (Ubuntu Trusty):
status: In Progress → Fix Committed
status: Fix Committed → In Progress
Changed in gnome-do-plugins (Ubuntu Trusty):
status: In Progress → Fix Released
Mathew Hodson (mathew-hodson) wrote :

gnome-do-plugins for Trusty is still in the upload queue here: https://launchpad.net/ubuntu/trusty/+queue?queue_state=1

Once it's added to trusty-proposed, there will be a comment like comment #5. Then we can get it moved to -trusty-updates.

Changed in gnome-do-plugins (Ubuntu Trusty):
status: Fix Released → In Progress

The version of gnome-do in the proposed pocket of Precise that was purported to fix this bug report has been removed because the bugs that were to be fixed by the upload were not verified in a timely (105 days) fashion.

tags: removed: verification-needed-precise
Changed in gnome-do (Ubuntu Precise):
status: Fix Committed → Won't Fix

Hello heartsmagic, or anyone else affected,

Accepted gnome-do-plugins into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-do-plugins/0.8.5-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-do-plugins (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Mathew Hodson (mathew-hodson) wrote :

Tested gnome-do-plugins 0.8.5-2ubuntu0.1. The Homepage field has been updated to http://do.cooperteam.net/ so the Developer Web Site link goes to the correct page and doesn't show spam.

tags: added: verification-done
removed: verification-done-trusty verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-do-plugins - 0.8.5-2ubuntu0.1

---------------
gnome-do-plugins (0.8.5-2ubuntu0.1) trusty; urgency=medium

  * Update Homepage: to not point at spam URL. (LP: #1442873)

 -- Joshua Bayfield <email address hidden> Tue, 29 Mar 2016 15:42:13 +0000

Changed in gnome-do-plugins (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in gnome-do-plugins (Ubuntu Trusty):
assignee: Joshua Bayfield (jbayfield) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers