gnome-do gCalculate plugin fails to display "times" symbol

Bug #274252 reported by Pablo Marchant on 2008-09-25
2
Affects Status Importance Assigned to Milestone
Do Plugins
Low
Alex Launi
gnome-do-plugins (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-do-plugins

When using gnome do to make conversions (via gCalculate), it fails to display correctly numbers in scientific notation. For instance, if I put:

1 eV in Joule

It says:

1 electron volt = 1.60217646 × 10-19 joules

Here "&#215" corresponds to the html symbol for times, wich is simply a cross.

Chris Halse Rogers (raof) wrote :

Confirmed. Adding upstream task.

Changed in gnome-do-plugins:
importance: Undecided → Low
status: New → Confirmed
Changed in do-plugins:
importance: Undecided → Low
status: New → Confirmed

Oh. It actually occurs to me that this may be due to over-eager
escaping of response text. Grr.

Alex Launi (alexlauni) on 2009-03-01
Changed in do-plugins:
assignee: nobody → alexlauni
status: Confirmed → Fix Committed
Chris S. (cszikszoy) on 2009-03-14
Changed in do-plugins:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package gnome-do-plugins - 0.8.1.3+dfsg-0ubuntu1

---------------
gnome-do-plugins (0.8.1.3+dfsg-0ubuntu1) jaunty; urgency=low

  [ Daniel T Chen ]
  * New upstream release (LP: #344578)
    + Banshee plugin goes crazy if banshee isn't loaded first
      (LP: #289802)
    + gnome-do gCalculate plugin fails to display "times" symbol
      (LP: #274252)
    + Banshee-1 fails to build in Mono 2.0 (LP: #309188)
    + Pidgin 2.5.4 has incompatible dbus interface. s/uint/int/
      (LP: #314927)
    + Pidgin plugin hangs opening a chat if pidgin is unresponsive
      (LP: #315565)
    + twitter plugin still reports friend updates even when
      deactivated (LP: #317674)
    + Misspelling in microblogging plugin confirmation message
      (LP: #319433)
    + make install uses mdtool, but configure doesn't check for it
      (LP: #322951)
    + Virtualbox Icon in 2.10 are broken because of a new
      specification (LP: #323902)
    + Google Maps Plugin shouldn't always use route (LP: #324271)
    + Fix for Google Maps when using newlines and other special
      characters (LP: #324667)
    + VirtualBox failed to load icon (LP: #325712)
    + 'Read Man Pages' plugin makes Gnome-Do unresponsive
      (LP: #325935)
    + Search returns broken URLs (LP: #327855)
    + Default action for SSH hosts is "open" (LP: #328236)
    + Files and Folders Configuration doesn't use standard buttons
      (LP: #328236)
    + Window manager maximize action should focus if window is not
      currently focused (LP: #258893)
    + Locate plugin has no error message (LP: #262360)
    + Wishlist: Let user specify files and folders to ignore
      (LP: #263177)
    + ts-client plugin doesn't index subdirectories (LP: #322352)
    + Max 3000 items in Files and Folders plugin (LP: #324105)
    + putty cannot find host when running from gnome do
      (LP: #324282)
    + locate plugin with globbing (LP: #334798)
    + Twitter plugin encountered an error in UpdateFriends
      (LP: #317575)
    + gnome-terminal profiles no longer work (LP: #321977)
    + Creating a task using Remember the Milk plugin can fail if
      no task list is specified (LP: #324066)
    + bundled libraries makefile needs destdir (LP: #324704)
    + Typographical error in del.icio.us plugin (LP: #330525)
    + ImageShack fails to upload (LP: #337324)
  * debian/copyright
    + Refresh for new upstream version; new plugins added.
  * debian/patches/00_dfsg_autofoo.dpatch
    + Update for new upstream version
    + Don't build the YouTube plugin due to removal of shipped
      exes and dlls causing FTBFS
  * debian/patches/02_ssh_respect_exec_arg.dpatch
    debian/patches/03_buildsystem_respect_mcs.dpatch
    debian/patches/04_fix_pidgin_dbus_ints.dpatch
    + Drop; fixed upstream

  [ Iain Lane ]
  * debian/rules: Update repackaging to not delete *.dll; upstream now ships
    source copies of google-gdata meaning we can now enable the Google and
    Youtube plugins.
  * debian/patches/00_dfsg_autofoo: Drop, fixed by including and building
    these libs now.
  * debian/copyright: Update with information for google-gdata.
  * debian/patches/04_fix_pidgin_dbus_ints.dpatch: Add le...

Read more...

Changed in gnome-do-plugins:
status: Confirmed → Fix Released
Pablo Marchant (pamarca) wrote :

I still see the same problem with today updates that had version 0.8.1.3+dfsg-0ubuntu1 of gnome-do-plugins.

For instance, using "1 inch in light years" shows an answer with × instead of the cross sign.

This doesn't mean you're actually using the new plugin unfortunately, it's
very possible you're still using an old version. This is a separate bug
we're working on fixing, rm -rf your plugins dir
(~/.local/share/gnome-do/plugins*) and try again.

Pablo Marchant (pamarca) wrote :

Yup, deleting the plugins directory did the trick. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers