Ubuntu

compiz segfaults when mounting/unmounting a loopback device quickly

Reported by Colin King on 2012-03-07
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Unity
Medium
Andrea Azzarone
gnome-disk-utility (Ubuntu)
High
BVBISE_B6

Bug Description

compiz segfaults when quickly mounting/unmonting a loopback filesystem

[ 4855.938753] compiz[6801]: segfault at 18 ip 00007f4360b470d0 sp 00007fff03eed728 error 4 in libgdu.so.0.0.0[7f4360b2f000+37000]

Testcase: See attached bash script.

I hit this problem running a bunch of ecryptfs tests where I create and mount/umount a loopback device multiple times a second.

Can reproduce this every time. Unfortunately compiz tries hard to startup but eventually gets stuck and I end up with a totally unusable desktop.

Colin King (colin-king) wrote :
Colin King (colin-king) on 2012-03-07
description: updated
Colin King (colin-king) on 2012-03-09
Changed in gnome-disk-utility (Ubuntu):
milestone: none → ubuntu-12.04-beta-2
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Changed in gnome-disk-utility (Ubuntu):
milestone: ubuntu-12.04-beta-2 → ubuntu-12.04
tags: added: rls-mgr-p-tracking
Changed in gnome-disk-utility (Ubuntu):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
Colin King (colin-king) wrote :

Any updates on this?

Tim Penhey (thumper) wrote :

I'm guessing this is actually in the unity side of things with the handling of mounted file systems.

I've added the bug tasks.

Changed in unity:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (andyrock)
Andrea Azzarone (andyrock) wrote :

Can you test with unity trunk? Also we need a better stacktrace.

On 13/09/12 10:33, Andrea Azzarone wrote:
> Can you test with unity trunk? Also we need a better stacktrace.

Andy, there was a test shell script in the bug as the first comment I think.

Can you run it against trunk as you probably have this built already.

Tim

Andrea Azzarone (andyrock) wrote :

@Tim, tested. No crash here.

Changed in unity:
status: Triaged → Incomplete
no longer affects: compiz
Changed in gnome-disk-utility (Ubuntu):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → BVBISE_B6 (b6bvbisemp2013)
assignee: BVBISE_B6 (b6bvbisemp2013) → nobody
assignee: nobody → BVBISE_B6 (b6bvbisemp2013)
Colin King (colin-king) wrote :

Can't reproduce this now, so looks like it is fixed. Thanks

Colin King (colin-king) on 2014-04-03
Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Fix Released
Changed in unity:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers