warning given about disk health due to smart not being enabled

Bug #454301 reported by Andrés Felipe Vargas on 2009-10-17
130
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
gnome-disk-utility (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-disk-utility

After upgrade from to karmic, once restart, I got a red message saying my disk is failing and have to be replaced, the exact message was:

DISK IS BEING USED OUTSIDE DESIGN PARAMETERS

after trying to check the smart status of the disk I found that SMART was not enabled, after enabling it the message gone.

attached is all what I wrote on my console while I chat on #ubuntu+1 asking for help

please let me know if there is something else that I can do to help.

thanks

Andrés

ProblemType: Bug
Architecture: amd64
Date: Sat Oct 17 18:00:42 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/palimpsest
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20091017)
Package: gnome-disk-utility 2.28.0+git20091012-0ubuntu1
ProcEnviron:
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gnome-disk-utility
Uname: Linux 2.6.31-14-generic x86_64

Andrés Felipe Vargas (andphe) wrote :
Steven Harper (stevenharperuk) wrote :

I have the same problem, however I am on an EEEpc (701) which has a solid state disk. I am not sure that you can enable smart on these disks.

Sam Swift (samswift) wrote :

I am experiencing the same thing, also on an eeePC 701 running 9.10 RC notebook remix.

Some other threads of observations:

http://groups.google.com/group/UbuntuMini/browse_thread/thread/42451079da60efe9/e23a3e755b885375?show_docid=e23a3e755b885375&pli=1

http://ubuntuforums.org/showthread.php?t=1280693

marker (marker) wrote :

I have the same error message on Ubuntu 9.10 UNR i386 on a stock 4GB SSD. I thought it was ext4 so i reinstalled with ext3 and the message still comes up. When you click on the message it takes you to the "palimsest desk utility".

Gabriel Santacruz (lordahriman) wrote :

i have the problem when i startup my ubuntu!! a warning text

gdu-notificaction-daemon
un disco duro puede estar fallando
uno o mas discos informan de problemas de salud. pulse el icono para obtener mas informacion

in the beginin i think is cd damages!! but then i reinstall using a pendrive!! but the problem still appear!!

i hope find help!!

many people says is hard drives damages!! but my laptop hd is new it is imposible!!

MGdesigner (shoichi-chou) wrote :

I have a Eeepc 701 installed a very clean UNR 9.10 ,too. I also can confirm this situation.

ewaldmire (ewaldmire) wrote :

Same error is happening with 9.10 on a Dell Mini 9 with 4GB SSD.

Penguinnerd (ab-beadle) wrote :

I am getting the same thing on my EeePC 701 4GB with standard desktop Ubuntu 9.10.

Nicholas Allen (nick-allen) wrote :

I also get this on EEE PC 701 4GB after resuming from suspend with 9.10.

leeshipley (leeshipley) wrote :

Yet again eee pc 701 4GB after resuming from suspend with 9.10. Ext4. Stock standard 239 MB after a full reinstall of Ubuntu which wiped out a Jaunty to Koala upgrade that had the same problem. Although it does not appear to be related, I get the message about my battery being broken. The battery is now two years old so it may very well be broken!

The system then suggests a self test.
Attribute 32 returned normalized 32, worst 73, threshold 32 and value n/a. assessment failing
Attribute 50 returned normalized 55, worst 54, threshold 53 and value n/a. assessment good
Attribute 55 returned normalized 0 , worst 2, threshold 55 and value n/a assessment failed in the past
Attribute 73 returned normalized 0 , worst 16,threshold 30 and value n/a assessment failed in the past
Attribute 84 returned normalized 73, worst 32,threshold 78 and value n/a assessment failing

The other attributes were all N/A

frederyk (frederyk) wrote :

For me it is the same problem. Asus EEE 701 after suspend a SMART error is reported.

BandD (swords-into-plowshares) wrote :

Can also confirm this bug on eeepc 701 4GB SSD. Only happens to me after a resume from suspend. If I restart, the message goes away. No noticeable "damage". Files are fine, performance is top notch.

Simon Butcher (sbutcher) wrote :

Workaround: After installing smart-notifier package on my eee 701 i don't get this problem anymore when resuming from suspend.

Simon Butcher (sbutcher) wrote :

Please ignore my previous comment #13 - this does not fix the problem after all.

momcilo (momcilo-majic) wrote :

The bug is still active there on ASUS 701.
Does SMART have any sense on SSD?

Same problem with Asus 701 after fresh install of Karmic.
(This didn't happen with Jaunty.)

Ticking off "Spin down hard disks when possible" someone suggested didn't help. :-(
I settled on ticking "Don't warn me if the disk is failing" on, scary though it sounds.
(Incidentally, I find it annoying that Palimpsest opens window that doesn't
fit in the screen and has to be dragged around to be able to even see everything.
It'd be nice if programs - especially of this kind, that pop up semi-automatically,
would keep their windows small enough to fit even small machines or
size them automatically depending on screen size.)

SwaJime (john-swajime) wrote :

"After upgrade from to karmic, once restart, I got a red message saying my disk is failing and have to be replaced, the exact message was:

DISK IS BEING USED OUTSIDE DESIGN PARAMETERS"

But ... smartdisk IS enabled on this mini-9.

# smartctl -a /dev/sda
smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Device Model: STEC ATA DISK vS020.1.0
Serial Number: STECG51608A12r78IPkm
Firmware Version: AD B602D
User Capacity: 3,791,241,216 bytes
Device is: Not in smartctl database [for details use: -P showall]
ATA Version is: 6
ATA Standard is: ATA/ATAPI-6 T13 1410D revision 3a
Local Time is: Tue Jan 5 15:14:28 2010 EST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled

Error SMART Values Read failed
Smartctl: SMART Read Values failed.

Error SMART Thresholds Read failed
Smartctl: SMART Read Thresholds failed.

=== START OF READ SMART DATA SECTION ===
SMART overall-health self-assessment test result: PASSED

General SMART Values:
Offline data collection status: (0x00) Offline data collection activity
     was never started.
     Auto Offline Data Collection: Disabled.
Total time to complete Offline
data collection: ( 0) seconds.
Offline data collection
capabilities: (0x00) Offline data collection not supported.
SMART capabilities: (0x0000) Automatic saving of SMART data is not implemented.
Error logging capability: (0x00) Error logging NOT supported.
     No General Purpose Logging support.

Warning: device does not support Error Logging
Error SMART Error Log Read failed
Smartctl: SMART Error Log Read Failed
Warning: device does not support Self Test Logging
Error SMART Error Self-Test Log Read failed
Smartctl: SMART Self Test Log Read Failed
Device does not support Selective Self Tests/Logging

Eric D (eric-dunbar) wrote :

I've got an Eee PC 4G (701) (in use since March of 2008 with Xandros) and Ubuntu 9.10 reports this error on the internal solid state drive after being woken up.

I'm guessing the problem is with the fact that SD cards are not designed for high volumes of write operations and the virtual memory/swap partition is subject to high volumes of read-write operations. The SD's SMART circuitry probably detects this and (rightly) says "stop it". The Asus provided version of Xandros does not use a swap disk and it is also optimized to not write to the disk often (unfortunately it doesn't seem to be updated anymore so, for example, FireFox is still sitting back at version 2.x... if it were I'd still be running it).

So... now to find out whether I should actually bother to "fix" the problem and whether I can configure an SD card in the card reader slot to be the swap disk (to be started up after boot). Unfortunately the card reader slot is treated as USB 1.1 if you use it as the boot device (vs. 2.0 later on) so you're getting 12 Mbit/s max read-write operations which are as slow as molasses in January.

Eric D (eric-dunbar) wrote :

Ok, I figured there had to be a simple work-around. There is! Create a swap file and use that instead of a swap partition. This will drastically reduce the number of unnecessary writes that your (irreplaceable) internal SD has to experience (especially if you have 0.5 GB of RAM).

https://help.ubuntu.com/community/SwapFaq

What you need to do is the following:
1. Disable your swap partition or re-install Ubuntu Redux 9.10 without the swap partition.
2. Use a USB memory key or an SDHD/SD card that you leave in the card reader and create on that solid state device the swap-file.

You can also do some other tweaks to reduce the number of writes that take place. See https://help.ubuntu.com/community/EeePC/Using#Reducing%20Drive%20Writes for details.

Caveat re swap-file vs. swap partition:

I'm guessing that this method will force extra steps on you whenever you want to access other SD cards in the card reader.

You will have to turn OFF your computer and remove the card before turning it on (I'm sure there's a way for you to turn off the swap-file interactively but I'll leave that up to the experts to do). You'll obviously be running a system without a swap (virtual memory) at that point so you'll be limited to the 0.5 GB or 1 GB of your Eee PC/netbook but at least you'll be able to access the files on another SD card.

Once you're done, simply turn off the computer and insert your swap SD card.

Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. Can you recreate the issue in Lucid? This should be reproducible from the live CD environment.

Changed in gnome-disk-utility (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Simon Butcher (sbutcher) wrote :

@eric D
i'm not convinced that your workaround will work in all cases, since i didn't use a swap partition with ubuntu 9.10 (since i had 2gb ram) and still received the error when resume from suspend

Simon Butcher (sbutcher) wrote :

this bug still affects my eee 701 using lucid netbook remix when logging into gnome session.

James Hardy (mrweeble) wrote :

Just installed Ubuntu Desktop 10.04 on my Dell Mini 9 (had been using the preinstalled 8.04 previously) with a 4GB SSD and got this error. To minimise disk writes I do not have a swap partition and use ext2 to eliminate journalling (this is how it was before and it worked fine). The details tell me that attribute-32 (No description for attribute 32) has status Failing. Not very useful, it has identical info for 41, 46, 44 (all no description). 68, 109 and 178 say "failed in the past".

References to "spinning down" and "surface" do not inspire me with confidence that this app knows about the existence of SSDs let alone how to deal with them properly.

The UI is also pretty appalling as it is not possible to shrink the window to fit to the desktop, requiring me to use virtual windows and skip between them - the designer needs to remember that not everyone uses huge hi resolution monitors, I don't expect perfect, but scroll bars would be better than this

James Hardy (mrweeble) wrote :

a

Kiri (kiri) wrote :

Problem persists on MM 10.10.
gnome-disk-utility:
  Installed: 2.30.1-2

Nathan Allen (nathanallen) wrote :

Bug confirmed on EeePC 701 running Ubuntu 10.04
Ext3 formatted without swap
I also use tmpfs on certain directories to reduce disk writes

-None- (mike-nycmoma) wrote :

After boot, time to time, i have same message (DISK IS BEING USED OUTSIDE DESIGN PARAMETERS) on my SSD Corsair F40. Disk is new & attached to my box only for testing purposes. Now it have one LVM partition w/o any logical volumes. After one or two hours of uptime warning disappears and disk status is OK.
Also I have another SSD in my box for system partitions: Corsair V64, I'v never seen this warning message for it.

Confirming here on 10.10 amd64 with a OCZ Vertex 120 GB.

Martin Karlsson (foh1981) wrote :

Just installed 10.10 on my new computer with an OCZ Vertex 2 60GB SSD, and I've got the same message. I get this message regardless of SMART is enabled in BIOS or not.

Simon Butcher (sbutcher) wrote :

marking confirmed since several people have confirmed this

Changed in gnome-disk-utility (Ubuntu):
status: Incomplete → Confirmed
joseph alberino (jp-alberino) wrote :

I have found that in trying Xubuntu 10.10 the problem went away, now that i've reloaded ubuntu netbook 10.10 the problem is back. I have no idea why so the choice is stick with the error or change to xubuntu10.10
J

Simon Butcher (sbutcher) wrote :

this bug still exists in natty beta on asus eee 701

Simon Butcher (sbutcher) wrote :

There is now even worse behaviour in natty than before. Upon resuming from suspend (into gnome classic, since unity is not working well on eee) i receive 5 windows which I am required to click.
See attached screenshot

J B (scottie) wrote :

Nice to know that natty also works on eee 701 though. (though without unity)

SSD manufacturer's would probably be happy to help linux developers on this, seeing how it affects many of their users. Having SSDs work with ubuntu would also be a factor for buyers in choosing whether to upgrade a system to SSD.

Is this really damaging the SSDs? Does the message still appear for newer SSDs?

Status on LUCID 10.04, latest updates & kernel for it:
On an EEE 701 i'm using, (512mb Ram), the message still appears after suspend / hibernate. Which I guess is expected since that's when all the data from RAM is stored on the hard disk.

gdu-notification-daemon
A hard disk may be failing. One or more hard disks report health problems. Click the icon to get more information.

When you click on the icon on panel (with orange exclamation point):
4.0 GB hard disk - ATA Siliconmotion SM223AC
in red: "DISK IS BEING USED OUTSIDE DESIGN PARAMETERS"

But usually no message appears (aside from another one that says my battery is defective, which is another story). A testament to how ubuntu / linux uses minimal memory to achieve it's ordinary tasks.

Ubuntu/Linux and SSD drive have been introduced to each other for a while. Now they just have to enjoy playing together.

dcam (david-pastornet) wrote :

This problem also present on upstream debian.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers