gdu-notification-daemon crashed with SIGSEGV in gdu_pool_get_devices()

Bug #418300 reported by jon bystedt on 2009-08-24
This bug affects 163 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Expired
Critical
gnome-disk-utility (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Most likely duplicates: bug 403192

Binary package hint: gnome-disk-utility

Was restarting gnome-do, as it was using too much cpu on startup.

ProblemType: Crash
Architecture: amd64
CrashCounter: 1
Date: Mon Aug 24 13:11:02 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gnome-disk-utility/gdu-notification-daemon
NonfreeKernelModules: nvidia
Package: gnome-disk-utility 0.5-0ubuntu1
ProcCmdline: /usr/lib/gnome-disk-utility/gdu-notification-daemon
ProcEnviron:
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-6.26-generic
SegvAnalysis:
 Segfault happened at: 0x7f8ed1f7766d <gdu_pool_get_devices+13>: mov 0x18(%rdi),%rax
 PC (0x7f8ed1f7766d) ok
 source "0x18(%rdi)" (0x00000018) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-disk-utility
StacktraceTop:
 gdu_pool_get_devices () from /usr/lib/libgdu.so.0
 ?? ()
 ?? ()
 __libc_start_main () from /lib/libc.so.6
 ?? ()
Title: gdu-notification-daemon crashed with SIGSEGV in gdu_pool_get_devices()
Uname: Linux 2.6.31-6-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

jon bystedt (jonbystedt) wrote :
visibility: private → public

StacktraceTop:gdu_pool_get_devices (pool=0x0) at gdu-pool.c:1345
update_all (data=0x251a0c0)
main (argc=1, argv=0x7fffc58640f8)

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
don hardaway (don-hardaway) wrote :

i got this error too after updating and rebooting

kylea (kylea) wrote :

Same with - 2.6.31-7-generic #27-Ubuntu SMP Mon Aug 24 19:18:31 UTC 2009 x86_64 GNU/Linux
------------------
Description: Ubuntu karmic (development branch)
Release: 9.10

IdleOne (idleone) wrote :

Received this error on first boot with live cd. using daily build Aug 27, 2009

bigal (tubebender) wrote :

I got the same error from a cold start
2.27.91 (Ubuntu 2009-08-27) 2.6.31-8-generic (#28-Ubuntu SMP Thu Aug 27 14:43:30 UTC 2009)

userdce (userdce) wrote :

same with 2.6.31-9-generic

Sebastien Bacher (seb128) wrote :

duplicate bug #403192?

Sebastien Bacher ha scritto:
> duplicate bug #403192?
>
>

Yes... but for other architecture

---
avast! Antivirus: In partenza messaggio pulito.
Virus Database (VPS): 090902-0, 02/09/2009
Controllato il: 03/09/2009 11.12.37

James Westby (james-w) wrote :

Could someone still seeing this bug please reboot, confirm you
get the crash and then attach your ~/.xsession-errors file to the bug.

Thanks,

James

forscher (forscher) wrote :
kamahat (kamahat) wrote :
Noel J. Bergman (noeljb) wrote :
Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2009-09-07
description: updated
dtaylor84 (davidt-launchpad) wrote :

This problem appears to be caused by /dev/shm having the wrong permissions (which is also causing me a number of other problems). Running

$ sudo chmod 1777 /dev/shm

and logging out and back in fixes the problem (until the next reboot).

I am not sure why /dev/shm has the wrong permissions - /etc/init.d/mountdevsub.sh calls

domount tmpfs shmfs /dev/shm tmpfs -onosuid,nodev$SHM_OPT

This doesn't specify mode=1777, so I am not sure where this mode should be getting set (although other users confirm they do see the correct 1777 mode).

AGStumps8807 (aglenn88) wrote :
Gareth Jones (gareth) wrote :
Martin Pitt (pitti) wrote :

I believe the vast majority of these instances are fixed by

devicekit-disks (006-0ubuntu4) karmic; urgency=low

  * Add devicekit-disks.postinst: Kill the old devkit-disks-daemon, to ensure
    that the new version will be used at the next occasion. (LP: #403192)

 -- Martin Pitt <email address hidden> Wed, 16 Sep 2009 18:46:10 +0200

dtaylor84, this indeed looks like a different problem, my /dev/shm is correct here. Can you please file this as a bug against sysvinit?

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Fix Released
Cezary Baginski (cezary0) wrote :

I have:
  devicekit-disks 006-0ubuntu4

and the all the patches until *now* and I still have the problem after a restart.

The crash file also contains ' devicekit-disks 006-0ubuntu4', just to be sure. (I was sent to this page by apport).

As a result (I think) I keep on getting respawning nautilus icons in the task bar - unsure if it is related, so I'm not yet putting up my .xsession-errors file.

Daniel Hermansson (daniel.h) wrote :

I still get these crashes and apport sent me right to this report

Changed in gnome-disk-utility (Ubuntu):
status: Fix Released → Confirmed
Alex Mauer (hawke) wrote :

I’m also getting these crashes, with the “fixed” version of devicekit-disks.

Bill Muller (billmullerii-aol) wrote :

Resulted after applying update when system rebooted.

IKT (ikt) wrote :

happened after rebooting for latest round of updates.

James Westby (james-w) wrote :

Hi,

I'm pretty sure I just fixed this with the upload of dbus 1.2.16-0ubuntu8.

If you install the fixed version and get the error after a reboot then please
re-open, but then I'll be *really* stumped.

Thanks,

James

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Fix Released
luanqh (luanqh) on 2009-10-06
Changed in gnome-disk-utility (Ubuntu):
assignee: nobody → luanqh (luanqh)
Gyorgyi Toth (tgyorgyi27) wrote :

I just did the latest update (I think it was only two things), and get this error message now.

Allen Frank (allen-frank) wrote :

Getting this crash regularly on a Dell Mini9 (910) when resuming from suspend - all updates installed as of 10/17/09

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

bug #416519 seems to be the same issue still happening?

REY (reygamboa) on 2010-01-03
Changed in gnome-disk-utility (Ubuntu):
assignee: luanqh (luanqh) → REY (reygamboa)
Paul Sladen (sladen) wrote :

No idea what 'gdu-notification-daemon' was/is, but it crashed all by itself for no obvious reason.

zob (zob) wrote :

Getting this on ubuntu netbook remix 10.04 alpha2 kernel 2.6.32-11.
Both my devicekit-disks and my dbus are more recent than the ones metioned as fixes.

devicekit-disks: 009-1ubuntu3
dbus 1.2.16-2ubuntu2

apport automatically directed me to thus side.

dino99 (9d9) wrote :

like post 29 above says, how can we report new regression on something that already have had this problem and was fixed, but rebirthed now ?

" This problem was already reported in the bug report displayed in the web browser. Please check if you can add any further information that might be helpful for the developers. " (apport dialog box comments)

So, if devs want to know about new bugs, maybe they might unlocked the door.

Changed in gnome-disk-utility (Ubuntu):
status: Fix Released → New
Chris Coulson (chrisccoulson) wrote :

Please don't attach crash files to public bug reports, as they might contain private information that you don't really want other people to see. Crash reports should be submitted in the usual manner via Apport, which will open a private bug report and get handled by the retracer. I've deleted your crash file, as there's no need to submit any more information here.

Changed in gnome-disk-utility (Ubuntu):
assignee: REY (reygamboa) → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
Sebastien Bacher (seb128) wrote :

is somebody still having this issue on lucid?

dino99 (9d9) wrote :

nothing into logs now on my end

Carlo Pires (carlopires) wrote :

Using unity and just login when the bug happened

Bug in natty

Changed in gnome-disk-utility:
importance: Unknown → Critical
status: Unknown → Confirmed
Gopi (gopi-pm) wrote :

I have the same issue in Ubuntu 11.10

tags: added: precise
Changed in gnome-disk-utility:
status: Confirmed → Expired
dino99 (9d9) wrote :

This has been fixed a while back

Changed in gnome-disk-utility (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.