gnome-disks shows three icons in menu of lxpanel

Bug #1666693 reported by Lyn Perrine on 2017-02-21
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Fix Released
High
gnome-disk-utility (Ubuntu)
High
Unassigned

Bug Description

To reproduce install lubuntu 17.04 beta 1 and reboot after the installation then open the menu on lxpanel on the lower left hand corner and mouseover prefrences and see that there are there entries that say disks. Clicking on all three opens the main gnome-disks ui.

Description: Ubuntu Zesty Zapus (development branch)
Release: 17.04
lubuntu-default-settings:
  Installed: 0.48
  Candidate: 0.48
  Version table:
 *** 0.48 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/universe i386 Packages
        100 /var/lib/dpkg/status
gnome-disk-utility:
  Installed: 3.23.4-0ubuntu1
  Candidate: 3.23.4-0ubuntu1
  Version table:
 *** 3.23.4-0ubuntu1 500
        500 http://us.archive.ubuntu.com/ubuntu zesty/main i386 Packages
        100 /var/lib/dpkg/status
I expected one entry in the menu to run this program even if there are multiple .desktop files in /usr/share/applicatoins. I expected this to have one entry in the menu like in 14.04 or 16.04 not one for each desktop file gnome-disks puts in /usr/share/appliactions.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: lubuntu-default-settings 0.48
ProcVersionSignature: Ubuntu 4.10.0-8.10-generic 4.10.0-rc8
Uname: Linux 4.10.0-8-generic i686
ApportVersion: 2.20.4-0ubuntu2
Architecture: i386
CurrentDesktop: LXDE
Date: Tue Feb 21 13:35:17 2017
InstallationDate: Installed on 2017-02-21 (0 days ago)
InstallationMedia: Lubuntu 17.04 "Zesty Zapus" - Alpha i386 (20170221.2)
PackageArchitecture: all
SourcePackage: lubuntu-default-settings
UpgradeStatus: No upgrade log present (probably fresh install)

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1666693

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lubuntu-default-settings (Ubuntu):
status: New → Confirmed
Kev Bowring (flocculant) wrote :

also affecting Xubuntu

Walter Lapchynski (wxl) wrote :

If it's also affecting Xubuntu, assumedly this is not an lxpanel bug. Any ideas? Is it everyone's default-settings?

Sean Davis (bluesabre) wrote :

The package gnome-disk-utility contains three identical launchers. That's where these entries are coming from.

* /usr/share/applications/gnome-disk-image-writer.desktop
* /usr/share/applications/gnome-disk-image-mounter.desktop
* /usr/share/applications/org.gnome.DiskUtility.desktop

Kev Bowring (flocculant) wrote :

@bluesabre - thanks - I did see the 3 .desktop's - but wasn't really awake ;)

affects: lubuntu-default-settings (Ubuntu) → gnome-disk-utility (Ubuntu)
Jeremy Bicha (jbicha) wrote :

Thanks for taking the time to report this bug. I have reported it to GNOME.

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in gnome-disk-utility:
importance: Unknown → High
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.23.4-0ubuntu2

---------------
gnome-disk-utility (3.23.4-0ubuntu2) zesty; urgency=medium

  * Add git_fix-duplicate-launchers.patch:
    - Fix 'Disks' app appearing 3 times (LP: #1666693)

 -- Jeremy Bicha <email address hidden> Fri, 03 Mar 2017 19:24:19 -0500

Changed in gnome-disk-utility (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-disk-utility:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.