Disks shows all mounted snaps

Bug #1637984 reported by Will Cooke on 2016-10-31
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Fix Released
Medium
gnome-disk-utility (Ubuntu)
High
Andrea Azzarone
Xenial
High
Unassigned
Artful
High
Unassigned
Bionic
High
Andrea Azzarone
udisks2 (Ubuntu)
High
Andrea Azzarone
Xenial
High
Unassigned
Artful
High
Unassigned
Bionic
High
Andrea Azzarone

Bug Description

* Impact
In 16.04 and later any installed snaps show as loop devices in Disks.

* Test Case
- install a snap
- open gnome-disks
-> the snap shouldn't be listed on the left pane as a device

* Regression potential
Check that all your existing disks are still listed

Will Cooke (willcooke) wrote :
Jan Claeys (janc) wrote :

It also clutters the output of 'mount', 'df', etc. to the point where the useful stuff scrolls off the screen...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → High
Andrea Azzarone (azzar1) on 2018-02-05
Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Andrea Azzarone (azzar1)
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → Fix Released

The attachment "udisks2.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Andrea Azzarone (azzar1) wrote :

Please find attached the gnome-disk-utility's debdiff for bionic.

Sebastien Bacher (seb128) wrote :

the udisks change looks good but please mention the libmount updated requirement in the changelog with its reason

Sebastien Bacher (seb128) wrote :

can you also update the .symbols to list the new udisks_block_get_userspace_mount_options? ;-)

Andrea Azzarone (azzar1) wrote :

Please find attached the udisks2's debdiff for Bionic.

Andrea Azzarone (azzar1) on 2018-02-06
Changed in udisks2 (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) wrote :

Considering that the above fix will only work for newly installed snaps I'm attaching another debdiff (valid both for bionic and for artful) to workaround this problem.

Andrea Azzarone (azzar1) wrote :

I've prepared also a workaround for xenial considering that xenial ships with an older version of libmount1.

Changed in gnome-disk-utility (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-disk-utility (Ubuntu Artful):
importance: Undecided → High
Changed in udisks2 (Ubuntu Xenial):
importance: Undecided → High
Changed in udisks2 (Ubuntu Artful):
importance: Undecided → High
Changed in udisks2 (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in gnome-disk-utility (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in udisks2 (Ubuntu Artful):
status: New → Won't Fix
Changed in udisks2 (Ubuntu Xenial):
status: New → Won't Fix
description: updated
Changed in gnome-disk-utility (Ubuntu Xenial):
status: New → Fix Committed
Changed in gnome-disk-utility (Ubuntu Artful):
status: New → Fix Committed

Hello Will, or anyone else affected,

Accepted gnome-disk-utility into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-disk-utility/3.26.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed verification-needed-artful
tags: added: verification-needed-xenial
Brian Murray (brian-murray) wrote :

Hello Will, or anyone else affected,

Accepted gnome-disk-utility into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-disk-utility/3.18.3.1-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Will Cooke (willcooke) wrote :

Installed a 16.04 VM, installed some snaps, opened disks, saw that there were lots of snaps listed.
Enabled proposed and upgraded, rebooted, opened disks again and all the snaps were not show. Much better!

tags: added: verification-done-xenial
removed: verification-needed-xenial
Will Cooke (willcooke) wrote :

Ditto Artful.

tags: added: verification-done-artful
removed: verification-needed-artful
Will Cooke (willcooke) on 2018-02-08
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.26.1-0ubuntu2

---------------
gnome-disk-utility (3.26.1-0ubuntu2) bionic; urgency=medium

  * debian/patches/hide-if-xgdu-hide.patch:
    - Hide file systems mounted with x-gdu.hide userspace mount option
  * debian/patches/hide-snaps.patch:
    - Workaround to hide snaps. This is needed because the existing installed
      snaps are not mounted with the x-gdu.hide option. (lp: #1637984)

 -- Andrea Azzarone <email address hidden> Wed, 07 Feb 2018 15:39:32 +0100

Changed in gnome-disk-utility (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.26.1-0ubuntu1.1

---------------
gnome-disk-utility (3.26.1-0ubuntu1.1) artful; urgency=medium

  * debian/patches/hide-snaps.patch:
    - Don't list snaps loop mount as disks/devices since that's confusing
      (lp: #1637984)

 -- Andrea Azzarone <email address hidden> Wed, 07 Feb 2018 15:39:32 +0100

Changed in gnome-disk-utility (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-disk-utility has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.18.3.1-1ubuntu1.1

---------------
gnome-disk-utility (3.18.3.1-1ubuntu1.1) xenial; urgency=medium

  * debian/patches/hide-snaps.patch:
    - Don't list snaps loop mount as disks/devices since that's confusing
      (lp: #1637984)

 -- Andrea Azzarone <email address hidden> Wed, 07 Feb 2018 16:01:32 +0100

Changed in gnome-disk-utility (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in udisks2 (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.