gnome-disk-utilty does not allow swapoff of zram devices

Bug #1458383 reported by Brendan Perrine on 2015-05-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Low
Unassigned

Bug Description

To reproduce boot a lubuntu desktop image like wily image downloaded from zsync http://cdimage.ubuntu.com/lubuntu/daily-live/20150524/wily-desktop-amd64.iso.zsync

Then boot into the live session and select try lubuntu without installing and from the main menu open acessories gnome disks. Click on the /dev/zram devices which are create equal to` nproc ` will show up but if I boot this live session on a mchaine that has swap partitions I get a stop button to perform swapoff of the device.
 swapon --summary outputs.

filename Type Size Used Priority
/dev/sda2 partition 17407996 0 -1
/dev/sdc5 partition 13630460 0 -2
/dev/zram0 partition 2013436 0 5
/dev/zram1 partition 2013436 0 5
/dev/zram2 partition 2013436 0 5
/dev/zram3 partition 2013436 0 5

gnome-disk-utility:
  Installed: 3.16.0-1ubuntu1
  Candidate: 3.16.0-1ubuntu1
  Version table:
 *** 3.16.0-1ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ wily/main amd64 Packages
        100 /var/lib/dpkg/status
Description: Ubuntu Wily Werewolf (development branch)
Release: 15.10

I expected the zram compressed ram device to be able to have the swap turned off in gnome-disks through the GUI. INstead I got options to format and benchamrk the zram device which don't work and nothing to swapoff the device.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: gnome-disk-utility 3.16.0-1ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-18.18-generic 3.19.6
Uname: Linux 3.19.0-18-generic x86_64
ApportVersion: 2.17.3-0ubuntu1
Architecture: amd64
CasperVersion: 1.360
CurrentDesktop: LXDE
Date: Sun May 24 19:56:20 2015
LiveMediaBuild: Lubuntu 15.10 "Wily Werewolf" - Alpha amd64 (20150524)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-disk-utility
UpgradeStatus: No upgrade log present (probably fresh install)

Brendan Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1458383

tags: added: iso-testing
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Low
Phill Whiteside (phillw) wrote :

This is expected behaviour within Lubuntu where the RAM overhead is quite large compared to what lubuntu itself needs to run. Where this not used, the minimal RAM for running a Live instance would be greater than we currently state as required.

Changed in gnome-disk-utility (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers