gnome-disk-utlity and launcher/nautilus lost all raid awareness

Bug #1222776 reported by Rachel Greenham on 2013-09-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Undecided
Unassigned
gnome-themes-standard (Ubuntu)
Undecided
Unassigned

Bug Description

Expected: Raid arrays have appropriate icons in launcher/disk utility etc. Used to be there in Precise
Actual: Icons are missing. Raid array has generic drive icon.

Compare the first screenshot, taken before upgrading from Precise to Quantal, and the second, taken afterwards.

There is a RAID1 array, created using the disk utility, which shows up with an appropriate icon on the launcher and matching emblem in nautilus, as well as showing up properly in gnome-disk-utility itself.

In the second screenshot, the raid array now has a generic drive icon in the launcher, just a folder icon in nautilus, and gnome-disk-utility itself seems to have no understanding at all that it has a raid device on its hands, nor any options any more to create new ones.

It kind of looks like a deliberate decision was made to have no desktop support for raid any more, but I haven't found any discussion of this, so at worst, some kind of explanation?

I don't even really care if gnome-disk-utility can be used to *manage* raid arrays; what launched me on this quest was simply wanting to have the raid *icon* in the launcher for the mounted filesystem. It used to be there in precise; on upgrade, it vanishes.

Actually encountered on a proper machine which I upgraded from precise to raring with barely a pause in quantal on the way through. Repeated in simpler form in vmware to check whether the loss happened from precise->quantal or quantal->raring. Seems to be the former, hence reporting it here.

(Simply restoring the gdu_ icons for raid to a raring system doesn't make it, or nautilus, use them. I confess I don't really know how this works. Setting the mount point directory's icon in nautilus doesn't affect the launcher icon, which is the one I actually want fixed.)

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-disk-utility 3.6.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-40.62-generic 3.5.7.20
Uname: Linux 3.5.0-40-generic x86_64
ApportVersion: 2.6.1-0ubuntu12
Architecture: amd64
Date: Mon Sep 9 12:40:13 2013
InstallationDate: Installed on 2013-09-09 (0 days ago)
InstallationMedia: Ubuntu 12.04.2 LTS "Precise Pangolin" - Release amd64 (20130213)
MarkForUpload: True
SourcePackage: gnome-disk-utility
UpgradeStatus: Upgraded to quantal on 2013-09-09 (0 days ago)

Second screenshot attached, showing same system post-quantal upgrade, missing all raid icons and apparent desktop functionality.

Quinn Balazs (qbalazs) on 2013-09-09
Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Quinn Balazs (qbalazs) on 2013-09-09
tags: added: regression-release
Quinn Balazs (qbalazs) wrote :

Reproducible in quantal. Fixed in saucy to the best of my knowledge.

Jeremy Bicha (jbicha) wrote :

Yes, I think this is fixed in Saucy with the new 'drive-multidisk' icon.

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Fix Released

OK, I'll upgrade this test vm all the way to saucy and see what happens.

Confirmed; launcher icon has returned; well, it's a new icon, but it's meaningful, so that's my main issue sorted. :-)

I note still no raid understanding in gnome-disk-utility - array just shows up as a "Block Device". Not terribly important to me but I guess that's just been a decision to take that stuff out of gdu.

Jeremy Bicha (jbicha) wrote :

According to the changelog, gnome-disk-utility 3.8 brings back RAID support. The bug requesting that update is bug 1092719.

So I'm marking the icon part of this bug fixed and reopening the gnome-disk-utility part.

Changed in gnome-disk-utility (Ubuntu):
status: Fix Released → Triaged
Changed in gnome-themes-standard (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.8.2-1ubuntu2

---------------
gnome-disk-utility (3.8.2-1ubuntu2) saucy; urgency=low

  * Depend on gnome-icon-theme-symbolic
 -- Jeremy Bicha <email address hidden> Wed, 18 Sep 2013 10:10:52 -0400

Changed in gnome-disk-utility (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers