Gnome disk (gnome-disks) utility does not show USB drive has SMART enabled. Option is grayed.

Bug #1092900 reported by Kangarooo Jānis
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Undecided
Unassigned

Bug Description

gnome-disk-utility (show as "Disks" on the desktop environment running Unity) systematically does not acknowledge that disks have SMART capabilities when connected through a USB port; SMART capabilities are grayed. However, 'sudo smartctl -a /dev/<disk>' works fine. gnome-disks acknowledge SMART capabilities if the same disk is connected through a SATA port.

Confirmed for Ubuntu 14.04 LTS Trusty Thar on 2016-01-26, gnome-disk-utility 3.10.0, udisks 2.1.3 (built against 2.1.3) by Hans Deragon.

Original report -->

In terminal it wasnt enabled but it was supported.
I enabled it in 12.04 ubuntu in terminal.
In 10.04 in terminal it shows its enabled but see screenshot in Disk utility it doesnt show SMART.
PS. I formated using Disk utility using : Dont partition and in fdisk -l it doesnt show any partitions. Thats then showing all correctly?

Toshiba v63600-C 1TB usb external HDD
Formated using DISK Utility with not usual options:
In DISK UTILITY Formated using: Dont partition and & FORMAT VOLUME to FAT (not possible to NTFS)

kangarooo@kangarooo-laptop:~$ sudo fdisk -l

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0001f6fb

   Device Boot Start End Blocks Id System
/dev/sda1 1 16071 129089283+ 83 Linux
/dev/sda2 16072 16797 5831595 5 Extended
/dev/sda3 * 16798 19457 21366450 7 HPFS/NTFS
/dev/sda5 16072 16797 5831563+ 82 Linux swap / Solaris

Disk /dev/sdb: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot Start End Blocks Id System
kangarooo@kangarooo-laptop:~$ sudo smartctl -i /dev/sdb
smartctl version 5.38 [i686-pc-linux-gnu] Copyright (C) 2002-8 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Device: TOSHIBA External USB 3.0 Version: 0001
Serial number: 91UCFSBMS
Device type: disk
Local Time is: Fri Dec 21 15:38:56 2012 EET
Device supports SMART and is Enabled
Temperature Warning Disabled or Not Supported
kangarooo@kangarooo-laptop:~$

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-disk-utility 2.30.1-1
ProcVersionSignature: Ubuntu 2.6.32-45.100-generic 2.6.32.60+drm33.26
Uname: Linux 2.6.32-45-generic i686
Architecture: i386
Date: Fri Dec 21 14:37:14 2012
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-disk-utility

Revision history for this message
Kangarooo Jānis (kangarooo) wrote :
Revision history for this message
Kangarooo Jānis (kangarooo) wrote :
Revision history for this message
Kangarooo Jānis (kangarooo) wrote :

If that makes change for solving this bug:
Heres pic how i formated: i choose Dont partition and then format partition and FAT (if choosing Dont partition its not create partition but format partition)

description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Revision history for this message
N1ck 7h0m4d4k15 (nicktux) wrote :

I can confirm that this bug affects me as well.

I will attach some txt's for debugging.

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) wrote :

$ lsb_release -rcd ; uname -r

Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
3.5.0-21-generic

$ apt-cache policy gnome-disk-utility

gnome-disk-utility:
  Installed: 3.0.2-2ubuntu7
  Candidate: 3.0.2-2ubuntu7
  Version table:
 *** 3.0.2-2ubuntu7 0
        500 http://gr.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

Revision history for this message
N1ck 7h0m4d4k15 (nicktux) wrote :
Hans Deragon (deragon)
description: updated
summary: - Gnome disk utility doesnt show usb HDD has SMART enabled
+ Gnome disk (gnome-disks) utility does not show USB drive has SMART
+ enabled. Option is grayed.
Revision history for this message
dino99 (9d9) wrote :

That version is no more supported

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Hans Deragon (deragon) wrote :

dino99, does the version in 14.04 LTS has been corrected recently? I have tried it on 14.04 on 2015-09-19, but not since then.

Can we reopen it against that version?

Revision history for this message
Hans Deragon (deragon) wrote :

Current version of gnome-disk-utility in 14.04 is 3.10.0-1ubuntu3. Searching through my history, i found that this package was never updated, surely not since 2015-09-19 so the bug is still valid (I am not home so I cannot try). Switching to 'confirm'.

Changed in gnome-disk-utility (Ubuntu):
status: Invalid → Confirmed
Revision history for this message
dino99 (9d9) wrote :

@Hans

as reported:
- option is 'grayed'
- only affect 'Lucid'

so that means 'transitional' mis-configuration when that report have been made
as this was not a 'security' problem, this has never been backported; and as Lucid is now dead, that report is useless.

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Hans Deragon (deragon) wrote :

@dino99. If it still affects 14.04, what should I do now? Recopy the ticket? Or simply change the description?

Hans Deragon (deragon)
Changed in gnome-disk-utility (Ubuntu):
status: Invalid → New
description: updated
description: updated
description: updated
Hans Deragon (deragon)
tags: added: trusty
Revision history for this message
dino99 (9d9) wrote :

@Hans

please dont comment on a report that is not yours, and concerning a different release.
 If you still have that issue, then open your own report with 'ubuntu-bug gnome-disk-utility' to give devs a chance to find the reason into your logs.

tags: removed: trusty
Changed in gnome-disk-utility (Ubuntu):
status: New → Invalid
Revision history for this message
Hans Deragon (deragon) wrote :

@dino99, ok, so essentially whenever a bug crosses to a more recent release because it was never fixed, a new bug report must be created. Not efficient, but if this is the rule, I will obey.

Revision history for this message
Hans Deragon (deragon) wrote :

I opened a new report for the same problem on Ubuntu 14.04 LTS. You can follow it at: https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/1540110

Revision history for this message
Kangarooo Jānis (kangarooo) wrote :
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers