Benchmark for disks always fails on 32 bit systems

Bug #1081019 reported by Thomas Bechtold on 2012-11-20
344
This bug affects 74 people
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
High
Unassigned

Bug Description

I can not benchmark any harddisk I have. I tried with unmounted, usb-connected harddisks.
Steps to reproduce:

1) Start gnome-disks
2) Select a Harddisk and unmount all partitions so the disk is not in use
3) Select "more actions..." button and then the point "Benchmark volume..."
4) Run "start benchmark..." and use the default settings and press the new button "start benchmarking"

Now I get:

Error seeking to offset 10002022400 (g-io-error-quark, 0)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-disk-utility 3.6.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.7.0-2.8-generic 3.7.0-rc5
Uname: Linux 3.7.0-2-generic i686
ApportVersion: 2.6.2-0ubuntu5
Architecture: i386
Date: Tue Nov 20 09:29:43 2012
InstallationDate: Installed on 2012-06-16 (156 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release i386 (20120423.2)
MarkForUpload: True
SourcePackage: gnome-disk-utility
UpgradeStatus: Upgraded to raring on 2012-11-12 (7 days ago)

Thomas Bechtold (toabctl) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Marcin Juszkiewicz (hrw) wrote :

I have the same on Chromebook running 13.04. My USB 3.0 harddrive works fine on desktop but when connected to Chromebook all I have is g-io-error-quark instead of benchmarking.

Vasilis Toumpakaris (toumbo) wrote :

I had the same issue while benchmarking a DVD on Optiarc DVD RW AD-5170A (1.11).

Ilan Tal (ilan-tal) wrote :

I can duplicate the bug on a SanDisk, usb disk on key. the g-io-error-quark is 13.
The disk on key is working fine. I thought this might mean a bad sector, but apparently it is just a bug.

mrDoctorWho (mrdoctorwho) wrote :

Benchmark of SSD OCZ Vertex 3 60gb fails: g-io-error-quark, 13

Thor Christian (infotcuc) wrote :

Benchmarking a 32GB Trancend micro SD Class10 (in an sd adapter on my HP 6530b)
same error/bug:

Error seeking to offset 2200612864 (g-io-error-quark, 13)

Chad Miller (cmiller) wrote :

strace

7549 <... read resumed> "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 4096
7549 lseek(12, 0, SEEK_SET <unfinished ...>
7549 <... lseek resumed> ) = 0
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 270675974}) = 0
7549 write(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 13631488) = 13631488
7549 fsync(12) = 0
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 331360325}) = 0
7549 lseek(12, 1176801280, SEEK_SET) = 1176801280
7549 read(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 4096
7549 lseek(12, 1176801280, SEEK_SET) = 1176801280
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 331551959}) = 0
7549 read(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 13631488) = 13631488
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 380325477}) = 0
7549 lseek(12, 1176801280, SEEK_SET) = 1176801280
7549 read(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 4096) = 4096
7549 lseek(12, 1176801280, SEEK_SET) = 1176801280
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 381023962}) = 0
7549 write(12, "\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0"..., 13631488) = 13631488
7549 fsync(12) = 0
7549 clock_gettime(CLOCK_MONOTONIC, {14402, 440467374}) = 0
7549 lseek(12, 2353606656, SEEK_SET) = -1 EINVAL (Invalid argument)
7549 close(12) = 0
7549 munmap(0xab4fe000, 13639680) = 0

Seek/read at zero, then some number, then at double that number, an invalid offset.

Marco Bottacin (westdam) wrote :

i've got same bug even on my 13.04 and 13.10 ubuntu. Cant benchmark with samsung ssd 840 120gb and WDC green 1tb

k browne (kbrowne1) wrote :

I'm trying to make an ISO image of a partition on an SD card with Disks. I get "Error seeking to offset 2147483648: Invalid argument (g-io-error-quark, 13)"

korziner (korziner) wrote :

14.04 alpha -same problem.

Luis Alvarado (luisalvarado) wrote :

Found same problem trying to benchmark Samsung SSD 840 256GB.

Image: http://imgur.com/EhLHr0F

George (3grciii) wrote :

I have the same problem on multiple drives, multiple systems. The only thing that changes is the offset. On a 3 Terabyte drive attached to an internal interface with GUID partition table (model WDC WD3001FAEX-00MJRA0 (01.01L01)) I get: Error seeking to offset 30005927936 (g-io-error-quark, 13).

On a USB 2.0 connected Hitachi 82.3 GB drive with no partition (model TOSHIBA THNSNH128GBST (HTRAN101)) The R/W benchmark actually started but then I got: Error seeking to offset 2470412288 (g-io-error-quark, 13). This is interesting as the drive label indicates the total sectors are 160836480. Disconnected and reconnected this drive and then got: Measuring transfer rate (0.0% complete)… and it hung. 3rd attempt on this drive duplicated first results.

We appear to be seeking beyond extents.

gmicsko (gmicsko) wrote :

"Luis Alvarado (luisalvarado) wrote on 2014-03-17:

Found same problem trying to benchmark Samsung SSD 840 256GB.

Image: http://imgur.com/EhLHr0F"

Same here. Samsung SSD 840 EVO 250GB. Ubuntu 14.04 LTS.

c_ellesley (archelegraph) wrote :

same on ubuntu gnome 14.04 crucial m500 240GB

setting testsize to 300MB results in failure after the first measurement, so the actual test works, but the seek-value is miscalculated

George (3grciii) wrote :
Download full text (177.2 KiB)

Same here: All relevant info follows:

Disks Utility – Attempting to benchmark unmounted partition sda1

Error: Error seeking to offset 2560712704 (g-io-error-quark, 13)

Relevant data:
$ sudo parted -l
Model: ATA TOSHIBA THNSNH12 (scsi)
Disk /dev/sda: 128GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 64.0GB 64.0GB primary ext4
 2 64.0GB 128GB 64.0GB primary ext4 boot

Model: ATA WDC WD3001FAEX-0 (scsi)
Disk /dev/sdb: 3001GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number Start End Size File system Name Flags
 1 1049kB 3001GB 3001GB ext4

Model: ATA WDC WD1001FALS-0 (scsi)
Disk /dev/sdc: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number Start End Size Type File system Flags
 1 1049kB 1000GB 1000GB primary ext4 boot

udisksctl dump

/org/freedesktop/UDisks2/Manager:
  org.freedesktop.UDisks2.Manager:
    Version: 2.1.3

/org/freedesktop/UDisks2/block_devices/loop0:
  org.freedesktop.UDisks2.Block:
    Configuration: []
    CryptoBackingDevice: '/'
    Device: /dev/loop0
    DeviceNumber: 1792
    Drive: '/'
    HintAuto: false
    HintIconName:
    HintIgnore: false
    HintName:
    HintPartitionable: true
    HintSymbolicIconName:
    HintSystem: true
    Id:
    IdLabel:
    IdType:
    IdUUID:
    IdUsage:
    IdVersion:
    MDRaid: '/'
    MDRaidMember: '/'
    PreferredDevice: /dev/loop0
    ReadOnly: true
    Size: 0
    Symlinks:
  org.freedesktop.UDisks2.Loop:
    Autoclear: false
    BackingFile:
    SetupByUID: 0

/org/freedesktop/UDisks2/block_devices/loop1:
  org.freedesktop.UDisks2.Block:
    Configuration: []
    CryptoBackingDevice: '/'
    Device: /dev/loop1
    DeviceNumber: 1793
    Drive: '/'
    HintAuto: false
    HintIconName:
    HintIgnore: false
    HintName:
    HintPartitionable: true
    HintSymbolicIconName:
    HintSystem: true
    Id:
    IdLabel:
    IdType:
    IdUUID:
    IdUsage:
    IdVersion:
    MDRaid: '/'
    MDRaidMember: '/'
    PreferredDevice: /dev/loop1
    ReadOnly: false
    Size: 0
    Symlinks:
  org.freedesktop.UDisks2.Loop:
    Autoclear: false
    BackingFile:
    SetupByUID: 0

/org/freedesktop/UDisks2/block_device...

Darek (ddarek-ch) wrote :

I had same problem on my amd64 computer trying to run gnome-disks's benchmark from following ubuntu live CDs:
- 13.04 i386,
- 14.04 i386.

However I was able to run gnome-disks's benchmark when I booted my amd64 computer from:
- 13.10 amd64,
- 14.04 amd64.

Maybe this will help somebody...

msth67 (msth67) wrote :

I can report the same issue in Lubuntu 14.04 32 bit:trying to benchmark my SSD fails after few seconds with the message:
#benchmark error (read only)#
Error seeking to offset 2329718784 (g-io-error-quark, 13)

Interestingly,I've tried with a live CD of Lucid 10.04 and it can perform the read-only benchmark,can't tell about the read & write benchmark because the SSD is already partitioned.

On a side note,I also can't run self-tests on this disk with Lubuntu,even if it SMART data are apparently available in Disk Utilit,I'm getting this error message:
 #disk self-test error#
sk_disk_smart_self_test: Operation not supported (udisks-error-quark, 0)

Oliver Joos (oliver-joos) wrote :

I also have this problem with 3.10.0-1ubuntu3 in Ubuntu 14.04 / Mint 17.

Like Darek in comment #17 I have an amd64 PC (AMD Athlon 64 X2) but use a i386 kernel and libs.

If I benchmark a small partition at the beginning of a disk or SSD then the read/write tests end succesfully, and the error occurs as soon as the access time benchmark starts. Looks like it fails with big sector numbers (>2³²) with 32bit libs on a 64bit CPU.

Marcel Partap (empee584) wrote :

Ha-aaallo, low-hanging fix-offset-type-size-on-32bit fruit?

summary: - Benchmark for Harddisk fail
+ Benchmark for disks always fails on 32 bit systems
VeganTommy (vegantommy) wrote :

Hi, can we have a simple update of when this long lasting bug will be corrected, we would like to know / understand its complexity. Thanks

I am not a programmer but i would like to help, how can i get involved ?

The problem is that the benchmark code uses 32bit lseek(2) function.
It should either be replaced with lseek64(2), or define _FILE_OFFSET_BITS 64
Here is a (one-line) patch:

--- a/src/disks/gdubenchmarkdialog.c
+++ b/src/disks/gdubenchmarkdialog.c
@@ -9,6 +9,7 @@

 #include "config.h"

+#define _FILE_OFFSET_BITS 64
 #include <glib/gi18n.h>
 #include <gio/gunixfdlist.h>
 #include <gio/gunixinputstream.h>

Pokulo (pokulo) wrote :

It seems to me more like a race condition. Old and slow USB-Sticks, and SD-Cards work fine. But HardDisks and new USB3.0 devices abort with g-io-error-quark, 13 after some samples. It could also depent on the device size. my old sticks have only about 1 GB.

Is @mmikucionis bugfix also valid for 32bit linux?

Oliver R. (oliverr) wrote :

Affects me too with a HITACHI 120GB HDD (HTS542512K9SA00). I'm running a 32-bit Linux Mint 17 Xfce on a ThinkPad T61.

Will the patch be included in the next updates?

max5555 (max-ph) wrote :

I tried to upgrade gnome-disk-utility package from 3.10.0-1ubuntu3 to 3.14.0-0ubuntu1, but I got the same error.

Ivan Baldo (ibaldo) on 2015-01-26
tags: added: patch

I'm seeing this behavior too, on a RAID5 setup, ubuntu 14.04 - 32bit

     The good news is that the fix has been applied upstream, so it will
trickle down to Debian and then to Ubuntu I guess, maybe in next version
15.10.
     Too bad that it took so long just for a one liner patch and a
simple test...

El 23/05/15 a las 13:16, William Tyler Sontag escibió:
> I'm seeing this behavior too, on a RAID5 setup, ubuntu 14.04 - 32bit
>

--
Ivan Baldo - <email address hidden> - http://ibaldo.codigolibre.net/
 From Montevideo, Uruguay, at the south of South America.
Freelance programmer and GNU/Linux system administrator, hire me!
Alternatives: <email address hidden> - http://go.to/ibaldo

Mark Pereira (markjna) wrote :

Bug still exists on Ubuntu 14.04.3 LTS, Linux Kernel 3.13.0-63-Low Latency (i686), see below:

Error seeking to offset 2458783744 (g-io-error-quark, 13)

Sebastien Bacher (seb128) wrote :
Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
Norbert (nrbrtx) wrote :

Bug exists in Ubuntu 14.04 LTS - see https://bugs.launchpad.net/ubuntu/+source/gnome-disk-utility/+bug/1556406 .

Please fix it!

tags: added: trusty
Oliver Joos (oliver-joos) wrote :

I confirm that this bug is fixed in newer releases.
I tested gnome-disk-utility 3.18.3.1 on a Linux Mint MATE 18.0 32bit! and the benchmark works now.

I checked the 32bit iso image on a 32-bit hardware and on a 64-bit hardware: this bug is fixed on both. (although the latter is not a recommended setup)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers