Ubuntu

gnome-disk-utility is missing palimpsest (renamed to gnome-disks)

Reported by Rocko on 2012-08-25
42
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Low
Unassigned

Bug Description

The description of the gnome-disk-utility package still says: "palimpsest (from the gnome-disk-utility project) is a tool to manage disk drives and media", but palimpsest has been renamed to gnome-disks (and made much less intuitive, and harder to read because it does things in places like use white text on light grey - is that gnome3 removing features yet again?).

As an aside, the unity dash also doesn't find 'disk utility', only 'disks'.

ubuntu 12.10
unity 6.2.0-0ubuntu3
gnome-disk-utility 3.5.3-0ubuntu2

Rocko (rockorequin) on 2012-08-25
description: updated
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

The new binary is gnome-disks.

Francesco Bonanno (mibo-fra) wrote :

A solution for me it's downgrade of gnome-disk-utility for the quantal to precise verison, the precise version contains the package with the "original" palimpsest and it works with no problem under quantal .

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-disk-utility - 3.6.1-1ubuntu1

---------------
gnome-disk-utility (3.6.1-1ubuntu1) raring; urgency=low

  * Resynchronize with Debian (LP: #1041665). Remaining change:
  * debian/control, debian/rules
    - Build-depend on and run dh-translations

gnome-disk-utility (3.6.1-1) experimental; urgency=low

  * New upstream release. (Closes: #671494)
    - Major rewrite.
    - Renamed to GNOME Disks or simply Disks.
    - The libgdu library has been removed in favour of libudisks2.
  * Use xz compression for source tarballs.
  * Drop all binary packages besides gnome-disk-utility. (Closes: #646204)
  * Drop all patches, they are obsolete.
  * Bump debhelper compat level to 9.
  * Bump Standards-Version to 3.9.3.
  * Update Build-Depends according to configure.ac.
  * Make gnome-disk-utility depend on udisks2.
  * Remove the obsolete /etc/xdg/autostart/gdu-notification-daemon.desktop
    conffile on upgrades using the dh_installdeb maintscript facility.
  * Remove obsolete configure switch.
  * Update package description: palimpsest → GNOME Disks.
  * Update debian/copyright.

gnome-disk-utility (3.0.2-3) unstable; urgency=low

  [ Ansgar Burchardt ]
  * debian/rules: Use xz compression for binary packages. (Closes: #683841)
 -- Jeremy Bicha <email address hidden> Wed, 14 Nov 2012 21:34:59 -0500

Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

Ok, that upload fixed the package description. I'm keeping this bug open because I think "palimpsest" should be added to Keywords so that people looking for the old name still find it.

Also, we should use http://blog.didrocks.fr/post/Announcing-session-migration-now-in-ubuntu so that people that have "favorited" palimpsest.desktop don't have their favorite magically disappear when they upgrade from Precise.

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Low
status: Fix Released → Triaged
Jim (jdblaich) wrote :

The newer version is poorly implemented. You hide the options for testing under buttons with pop up menus. Ever wonder why these aren't in have use (pop up menus from button clicks)? It's because they are confusing and non-intuitive. Additionally you should the progress bar for the tests on the window behind the one where the test is done and that window is dimmed. Bright ideas guys.

Can you fix your mess please?

Jim (jdblaich) wrote :

+Francesco Bonanno,

Would you mind explaining how you got it done with all the dependencies required?

Rocko (rockorequin) wrote :

@Jim: while I totally agree with your assessment, the changes to gnome-disks were implemented by gnome3 upstream, not ubuntu, and so it would be fairer to rant at the gnome-devs in a gnome3 bug report. But good luck with that: I have found they are abruptly dismissive when it comes to criticism, constructive or otherwise. And the new feature-reduced, less-intuitive palimpsest does fit in with the design goals for gnome3.

Logicwax (logicwax) wrote :

@Francesco Bonnano,

How did you install it on quantal with all the dependencies?

This new disk manager is just horrid.

Stephen D Metcalfe (mechatism) wrote :

The new gnome-disk app sucks for building custom systems. One of the most important features of gnome-disk-utility was that it showed to which port a drive was attached. Many motherboards have both SATA II and SATA III ports and attaching drives to the correct port is critical to building fast systems. Apparently the Gnome 3 project is determined to castrate user interfaces by removing critical features. If they wish to simplify them they should at least provide a mode option where all the original functionality is still available.

The new gnome-disk app gets nine smelly diapers from me.

gnome-disks-utility is missing everything that made it useful, please delete this useless junk from the repo so it removes confusion for people looking for the former fantastic utility

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers