Can't change brightness with keyboard or with "Brightness and Lock" settings panel

Bug #947919 reported by Matthew Paul Thomas on 2012-03-06
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Medium
gnome-desktop3 (Ubuntu)
Medium
Unassigned
mutter (Ubuntu)
Medium
Unassigned

Bug Description

gnome-settings-daemon 3.3.91-0ubuntu1, gnome-control-center 1:3.3.90-0ubuntu5, Ubuntu 12.04 beta

1. Press the Brightness keys on the keyboard.
2. In System Settings, click "Brightness and Lock".

What happens:
1. Nothing.
2. The "Brightness and Lock" panel does not contain any brightness settings.

What should happen:
1. The brightness changes.
2. The "Brightness and Lock" panel contains a brightness slider.

Matthew Paul Thomas (mpt) wrote :
Matthew Paul Thomas (mpt) wrote :

Thanks to Andrea Cimitan for enlightening me that this is not a problem with the design of the panel. The brightness keys on the keyboard are not working either, whereas they worked yesterday. However, xbacklight works to change the brightness, so I guess it's not a problem with the graphics driver. Moving to gnome-settings-daemon.

affects: gnome-control-center (Ubuntu) → gnome-settings-daemon (Ubuntu)
description: updated
summary: - "Brightness and Lock" doesn't contain any brightness settings
+ Can't change brightness with keyboard or with "Brightness and Lock"
+ settings panel
Amigo Tuyo (rafael-ensenyat) wrote :

I have this same problem and I couldn't find any solution so far. Also, xbacklight seems no to work for me. I'm new to ubuntu and I feel kinda lost here...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-settings-daemon (Ubuntu):
status: New → Confirmed
Dana Goyette (danagoyette) wrote :

In my case, I'm using an nvidia card on a Thinkpad, with EnableBrightnessControl set.

On at least the Intel driver, xrandr --verbose presents both 'BACKLIGHT' and 'Backlight'.
The nvidia driver (with EnableBrightnessControl set) offers only the latter.

libgnome-desktop (used by gnome-settings-daemon) seems to look for only the former.
xbacklight looks for both names; this must be why it works when Gnome does not.

That other bug report (#947748) has several different issues lumped into it.
I'd like to remove the "duplicate" flag, since this report mentions the xbacklight behavior.

Changed in gnome-settings-daemon (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: ubuntu-desktop-trusty
Robert Ancell (robert-ancell) wrote :

According to the XRANDR spec [1] the correct property is "Backlight".

[1] http://cgit.freedesktop.org/xorg/proto/randrproto/tree/randrproto.txt

affects: gnome-settings-daemon (Ubuntu) → gnome-desktop3 (Ubuntu)
Robert Ancell (robert-ancell) wrote :

The upstream code for this moved into Mutter.

Changed in mutter (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Robert Ancell (robert-ancell) wrote :

I suspect this bug is not frequently seen since gnome-settings-daemon falls back to using /sys/class/backlight if XRANDR doesn't provide a backlight setting.

Changed in mutter:
importance: Unknown → Medium
status: Unknown → New
Changed in mutter:
status: New → Fix Released
Tim Lunn (darkxst) on 2014-02-06
Changed in mutter (Ubuntu):
assignee: nobody → Tim (darkxst)
Tim Lunn (darkxst) on 2014-02-06
Changed in mutter (Ubuntu):
assignee: Tim (darkxst) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.10.3-0ubuntu3

---------------
mutter (3.10.3-0ubuntu3) trusty; urgency=medium

  * debian/patches:
    - remove unused git patches
    - git_fix_xrandr_backlight.patch, fix backlight not working on various
      GPU's (LP: #947919)
 -- Tim Lunn <email address hidden> Thu, 06 Feb 2014 20:01:34 +1100

Changed in mutter (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.8.4-0ubuntu3

---------------
gnome-desktop3 (3.8.4-0ubuntu3) trusty; urgency=medium

  * debian/patches/backlight-property-name.patch:
    - Use the corrent backlight property name as specified in the XRANDR spec
      (LP: #947919)
 -- Robert Ancell <email address hidden> Mon, 17 Mar 2014 17:28:55 +1300

Changed in gnome-desktop3 (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.