Update gnome-desktop3 to 3.28.2

Bug #1771242 reported by Jeremy Bicha on 2018-05-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-desktop3 (Ubuntu)
Low
Unassigned
Bionic
Low
Jeremy Bicha

Bug Description

Impact
======
This updates the GNOME version number reported in Settings > Details > About to 3.28.2

This is the final scheduled point release for GNOME 3.28.

Since we're updating most of the other GNOME packages to 3.28.2, it's appropriate to do this update too. (We might hold this update in -proposed a bit until we update say gnome-shell to 3.28.2)

Tne new version also fixes a memory leak and includes some translation fixes.

https://git.gnome.org/browse/gnome-desktop/tree/NEWS?h=gnome-3-28
https://git.gnome.org/browse/gnome-desktop/log?h=gnome-3-28

Test Case
=========
From Ubuntu 18.04 LTS, open the Settings app.
Navigate to Details > About
The GNOME version number should say 3.28.2

Regression Potential
====================
There is a micro-release exception for GNOME:
https://wiki.ubuntu.com/StableReleaseUpdates#GNOME

Jeremy Bicha (jbicha) on 2018-05-15
Changed in gnome-desktop3 (Ubuntu Bionic):
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.28.2-1ubuntu1

---------------
gnome-desktop3 (3.28.2-1ubuntu1) cosmic; urgency=medium

  * Resynchronize with Debian. Remaining changes:
    - Add 04_compute_average_color.patch: Compute the avergage color in
      gnome-desktop itself, not in unity to fix some races (LP #963140)
    - Add tweak_color_computation.patch, Patch from Gord, no patch header,
      no bug link.
    - Add git_revert_draw_background.patch
    - Add ubuntu_language.patch, Port relevant bits from gnome-control-center's
      52_region_language.patch, as required for gnome 3.8+ region panel
    - Add ubuntu_language_list_from_SUPPORTED.patch,
      Add API to get list of available languages from SUPPORTED file.
      To be used by gnome 3.8 region panel language installation.
    - Add gnomebg_hidpi_image.patch,
      gnome_bg_create_surface: always honor device scale, that fixes the
      wallpaper rendering in HiDPI config under ubiquity (LP: #1382291)
    - Add disable-bubblewrap.patch:
      + Don't use bubblewrap since it's not in main yet. See bug 1709164.
    - debian/control.in: Don't depend on bubblewrap
    - debian/libgnome-desktop-3-12.symbols:
      + Add symbols included in Ubuntu patches
    - Update Vcs fields and debian/gbp.conf for Ubuntu

gnome-desktop3 (3.28.2-1) unstable; urgency=medium

  * New upstream release (LP: #1771242)
  * debian/source/lintian-overrides: Drop, obsolete

 -- Jeremy Bicha <email address hidden> Mon, 14 May 2018 21:46:03 -0400

Changed in gnome-desktop3 (Ubuntu):
status: Fix Committed → Fix Released
Gil (gilvbp) wrote :

So Ubuntu 18.04 will not receive gnome 3.28.2?

Jeremy Bicha (jbicha) wrote :

> So Ubuntu 18.04 will not receive gnome 3.28.2?

Ubuntu 18.04 LTS will get GNOME 3.28.2. This bug report is part of that process. :)

Hello Jeremy, or anyone else affected,

Accepted gnome-desktop3 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-desktop3/3.28.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-desktop3 (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jeremy Bicha (jbicha) on 2018-05-23
Changed in gnome-desktop3 (Ubuntu Bionic):
assignee: nobody → Jeremy Bicha (jbicha)
Sebastien Bacher (seb128) wrote :

3.28.2-0ubuntu1 works as described, the GNOME version is displayed with the new revision and the desktop keeps working without any issue

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Robie Basak (racb) wrote :

> We might hold this update in -proposed a bit until we update say gnome-shell to 3.28.2

Holding as suggested.

Łukasz Zemczak (sil2100) wrote :

gnome-shell 3.28.2 has been released to bionic-updates - releasing this package as well.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.28.2-0ubuntu1

---------------
gnome-desktop3 (3.28.2-0ubuntu1) bionic; urgency=medium

  * New upstream release (LP: #1771242)

 -- Jeremy Bicha <email address hidden> Mon, 14 May 2018 21:37:26 -0400

Changed in gnome-desktop3 (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-desktop3 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers