[FFe] gnome-desktop 3.12 transition

Bug #1372346 reported by Tim Lunn on 2014-09-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-desktop3 (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
indicator-keyboard (Ubuntu)
Undecided
Unassigned

Bug Description

We have been trying to land this transition for about 9 months now (well previously was 3.10, but that was largely the same). The big blocker was the removal of xrandr and idlemonitor code out of gnome-desktop. Robert Ancell has solved that issue see Bug 1372240

There is a SONAME bump, however that only affects g-s-d/g-c-c. Mostly apps are using things like the thumbnailer etc, and these are not affected by api changes, so they just need to be rebuilt.

gnome-session could be updated to the latest 3.10 stable release, however this is not strictly required and will require reverting removal of fallback dialogs. A rebuild would be fine for now.

Full lost of r-depends:
Reverse-Depends
===============
* cheese [x]
* eog [x]
* epiphany-browser [x]
* evince (separately uploaded, no need to rebuild)
* gnome-clocks [x]
* gnome-contacts [x]
* gnome-control-center [x]
* gnome-documents [x]
* gnome-font-viewer [x]
* gnome-panel [x]
* gnome-photos [x]
* gnome-screensaver [x]
* gnome-session [x]
* gnome-settings-daemon [x]
* indicator-keyboard [x]
* evolution [x]
* mutter [x]
* nautilus [x]
* unity [x]
* unity-control-center [x]
* unity-settings-daemon [x]
packages marked [x] are uploaded

I have debian merges ready to go for gnome-desktop, g-s-d and g-c-c 3.12 (but using 3.10 power plugin/panel to untangle from upower 0.99).

gnome-control-center update will also require a UIFe, Ubuntu GNOME slideshow has not yet been updated for utopic, so this shouldnt be a problem from our side. No other flavours use the UI part of gnome-control-center anymore, the shared-data (faces) are unchanged.

Related branches

Tim Lunn (darkxst) on 2014-09-22
description: updated
Revision history for this message
Iain Lane (laney) wrote :

I want to do this for you guys, but we have beta freeze today. We can't get this done in time for that.

What about if you prepare the packages in a PPA and then I can help with copies / bzr merges on Thursday when the freeze is lifted? That should make the transition go quickly. I think the freeze should mean that we don't have much movement underneath us so it ought to be easy.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-desktop3 (Ubuntu):
status: New → Confirmed
Tim Lunn (darkxst) on 2014-09-22
description: updated
Tim Lunn (darkxst) on 2014-09-24
tags: added: ubuntugnome-blocker
Revision history for this message
Tim Lunn (darkxst) wrote :

Laney, this should be all good to go now, everything is staged on the ppa, and branches are linked above for packages needing merges.

Revision history for this message
Sebastien Bacher (seb128) wrote :

did you test the gnome-session update in fallback sessions? we blocked the update because of that commit iirc
https://git.gnome.org/browse/gnome-session/commit/?h=gnome-3-10&id=705699b2799a3434d1a8f35c9a92868a5057f73e

which removes the gtk session dialogs, that are still used in e.g gnome-panel type of sessions no?

Revision history for this message
Sebastien Bacher (seb128) wrote :

your gnome-session update also has
" - 13_display_session_properties.patch, Dropped session UI is gone"

but that's not true, the session properties capplet is still there in 3.10

Revision history for this message
Sebastien Bacher (seb128) wrote :

could you also give a pointer to "the ppa" which you are refering to in previous comment?

Revision history for this message
Tim Lunn (darkxst) wrote :

ppa:darkxst/gnome-desktop

As mentioned on irc, gnome-session update was blocked due to > 3.9.90 crashing when running under gnome-desktop 3.8.
gnome-panel provides its own dialogs, however seems they are only used when clicking through the system menu. I can revert the dialogs for now, but would seem consistent if fallback sessions always used gnome-panel dialogs.

re comment #5, the patch was there just the changelog entry was incorrect.

Revision history for this message
Tim Lunn (darkxst) wrote :

Lets just stick with rebuild gnome-session for now, reverting the dialog removal is a bit tangled up with other changes, will deal with that a bit later.

description: updated
Tim Lunn (darkxst) on 2014-09-26
description: updated
Revision history for this message
Iain Lane (laney) wrote :

I uploaded gnome-desktop3. It's in the unapproved queue for review.

Changed in gnome-desktop3 (Ubuntu):
status: Confirmed → Fix Committed
Tim Lunn (darkxst) on 2014-09-30
description: updated
Tim Lunn (darkxst) on 2014-09-30
description: updated
Iain Lane (laney) on 2014-09-30
description: updated
Iain Lane (laney) on 2014-09-30
description: updated
Revision history for this message
Iain Lane (laney) wrote :

To be clear, it was always intended that this transition would allow the corresponding update of gnome-control-center and gnome-settings-daemon to 3.12 so FFe ACK for those (they're ~Ubuntu GNOME only - actually also on Edubuntu but they aren't releasing for Utopic)

Martin Pitt (pitti) on 2014-09-30
Changed in gnome-control-center (Ubuntu):
status: New → Fix Committed
Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Committed
Iain Lane (laney) on 2014-09-30
description: updated
Revision history for this message
Iain Lane (laney) wrote :

Looks like g-c-c is depwait on geoclue-2.0, which isn't in main. Probs easiest to revert this, if possible?

Revision history for this message
Tim Lunn (darkxst) wrote :

Laney, I have pushed new branches that fix the depwait.

As far as edubuntu goes, they are using gnome-flashback which switched to using u-s-d/u-c-c. I don't think g-s-d/g-c-c should even be seeded on edubuntu. If I am reading the germinate output correctly its being pulled in by gnome-media, which happens to be missing the usual "unity-control-center | gnome-control-center" in the recommends.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop3 - 3.12.2-2ubuntu1

---------------
gnome-desktop3 (3.12.2-2ubuntu1) utopic; urgency=medium

  * New upstream release (LP: #1372346)
  * Merge with Debian, Remaining changes:
    - debian/patches:
      + 04_compute_average_color.patch: Compute the avergage color in
        gnome-desktop itself, not in unity to fix some races (LP #963140)
      + tweak_color_computation.patch, Patch from Gord, no patch header,
        no bug link.
      + git_revert_draw_background.patch
      + ubuntu_language.patch, Ported relevant bits from g-c-c
        52_region_language.patch, as required for gnome 3.8 region panel
      + ubuntu_language_list_from_SUPPORTED.patch,
        adds api to get list of available languages from SUPPORTED file.
        To be used by gnome 3.8 region panel language installation.
    - debian/rules:
      + drop obsolete --disable-scrollkeeper configure flag
    - debian/libgnome-desktop-3-10.symbols:
      + Add symbols included in Ubuntu patches
    - debian/control.in:
      + Mark gnome-desktop3-data Multi-Arch: foreign
  * Dropped changes:
    - 02_refuse_to_break_GL_compositors.patch:
      + xrandr code has moved into libunity-settings-daemon now

gnome-desktop3 (3.12.2-2) unstable; urgency=medium

  * Add debian/patches/realpath-PATH_MAX.patch (from upstream libgsystem)
    - avoids PATH_MAX to hopefully fix FTBFS on Hurd.

gnome-desktop3 (3.12.2-1) unstable; urgency=medium

  * New upstream release.
  * Bump Standards-Version to 3.9.5
  * Upload to unstable.

gnome-desktop3 (3.12.1-1) experimental; urgency=medium

  * Drop conflicts against libgnome-desktop-3-7 because it is not
    necessary: only leaf packages in G3.8 use gnome-desktop, including
    gnome-shell that does work with the new g-desktop library.
  * New upstream bugfix release.

gnome-desktop3 (3.12.0-1) experimental; urgency=medium

  * New upstream release.

gnome-desktop3 (3.11.90-1) experimental; urgency=medium

  * New upstream release.
  * Rename packages to match new soname.
  * Drop build-dependency on libxkbfile-dev, not needed anymore.
  * Update symbols file for new soname.
  * Drop empty debian/patches/
  * Break libgnome-desktop-3-8 for the same reason as libgnome-desktop-3-7.

gnome-desktop3 (3.10.1-2) experimental; urgency=low

  * Make libgnome-desktop-3-8 break libgnome-desktop-3-7. Mixing both on one
    system is a recipe for disaster when using gnome-desktop via
    gobject-introspection.

gnome-desktop3 (3.10.1-1) experimental; urgency=low

  * New upstream release
  * Sync with Ubuntu, bumped soname

gnome-desktop3 (3.8.4-2) unstable; urgency=low

  * Upload to unstable.

gnome-desktop3 (3.8.4-1) experimental; urgency=low

  [ Jeremy Bicha ]
  * Remove obsolete build dependency on gnome-doc-utils.

  [ Laurent Bigonville ]
  * New upstream release.
    - Prevent a crash with unknown language/country codes (Closes: #692453)
  * debian/control.in: Bump Standards-Version to 3.9.4 (no further changes)
 -- Tim Lunn <email address hidden> Fri, 12 Sep 2014 07:22:38 +1000

Changed in gnome-desktop3 (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.12.2-1ubuntu2

---------------
gnome-settings-daemon (3.12.2-1ubuntu2) utopic; urgency=medium

  * debian/patches/geoclue-build-fixes.patch: disable build of new
    datetime plugin since geoclue-2.0 is not currently in main.
 -- Tim Lunn <email address hidden> Wed, 01 Oct 2014 07:45:02 +1000

Changed in gnome-settings-daemon (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.12.1-5ubuntu2

---------------
gnome-control-center (1:3.12.1-5ubuntu2) utopic; urgency=medium

  * debian/patches/revert_automatic_timezone.patch: datetime plugin
    is disabled since it requires geoclue-2.0 which is in universe
 -- Tim Lunn <email address hidden> Wed, 01 Oct 2014 09:02:19 +1000

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in indicator-keyboard (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers