gnome-desktop needs support for X-GNOME-Gettext-Domain

Bug #587485 reported by Hendrik Knackstedt on 2010-05-30
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
Ubuntu Translations
Low
Unassigned
gnome-desktop (Ubuntu)
Low
Sebastien Bacher
Natty
Low
Sebastien Bacher

Bug Description

The gnome-desktop package recognises the X-Ubuntu-Gettext-Domain key to dynamically load .desktop file translations. However, some applications have started using the X-GNOME-Gettext-Domain key, which is not supported by gnome-desktop and thus translations are not loaded.

This is the relevant patch:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/gnome-desktop/maverick/annotate/head:/debian/patches/01_desktopfile_gettext.patch

An example can be seen when starting gnome-control-center and seeing that Gwibber's "Broadcast Preferences" is not translated there. From the original bug report:

"I'm not sure if this is caused by gwibber or gnome-control-center. When opening gnome-control-center "Broadcast preferences" is not translated to German like it is in Gnome's "System"-Menu. It should actually be "Nachrichteneinstellungen" instead."

gnome-desktop should be updated to support the same X-*-Gettext-Domain keys as glib:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/glib2.0/maverick/annotate/head:/debian/patches/01_gettext-desktopfiles.patch
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/glib2.0/maverick/annotate/head:/debian/patches/02_gettext-desktopfiles-ubuntu.patch

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gwibber 2.30.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic i686
Architecture: i386
CheckboxSubmission: 7ac749fb37b330dcf9c6acd92331d7ec
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Sun May 30 13:23:32 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=de_DE.utf8
 SHELL=/bin/bash
SourcePackage: gwibber

Hendrik Knackstedt (hennekn) wrote :
Eleanor Chen (chenyueg) on 2010-06-04
tags: added: gwibber-i18n
Gabor Kelemen (kelemeng) wrote :

Seems that this is because the .desktop file uses the X-GNOME-Gettext-Domain key to specify the translation domain. If I change this to X-Ubuntu-Gettext-Domain, it starts to show up localized. Thus, reassigning to g-c-c.

affects: gwibber (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in ubuntu-translations:
status: New → Triaged
Changed in gwibber:
status: New → Invalid
Gabor Kelemen (kelemeng) wrote :

Not a g-c-c bug either. Turns out, the tiles are rendered by libslab, which uses the gnome-desktop package's gnome-desktop-item voodoo to localize .desktop files. This in turn, is not prepared to handle X-GNOME-Gettext-Domain:

http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/gnome-desktop/maverick/annotate/head:/debian/patches/01_desktopfile_gettext.patch

This should be updated similarly to glib's solution:
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/glib2.0/maverick/annotate/head:/debian/patches/01_gettext-desktopfiles.patch
http://bazaar.launchpad.net/~ubuntu-branches/ubuntu/maverick/glib2.0/maverick/annotate/head:/debian/patches/02_gettext-desktopfiles-ubuntu.patch

affects: gnome-control-center (Ubuntu) → gnome-desktop (Ubuntu)
David Planella (dpm) on 2010-08-02
summary: - Broadcast preferences not translated
+ gnome-desktop needs support for X-GNOME-Gettext-Domain
David Planella (dpm) wrote :

Gabor, thanks for the throrugh investigation, I've now updated the description accordingly.

I don't see many packages making use of this, so I'm setting the priority to Low. Please feel free to reassign if you think it should be higher (or lower).

Thanks!

description: updated
Changed in ubuntu-translations:
importance: Undecided → Low
Gabor Kelemen (kelemeng) wrote :

Seems that the upstream opinion about this is to get rid of that old API:

http://mail.gnome.org/archives/desktop-devel-list/2010-July/msg00017.html

So, this problem will disappear after libslab is ported to GTK3/Glib3... if not before Gnome 2.32, then before Gnome 3.

Changed in gnome-desktop (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

ok, I've commited a fix for that in the packaging vcs

Changed in gnome-desktop (Ubuntu Natty):
status: Confirmed → Fix Committed
assignee: nobody → Sebastien Bacher (seb128)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.32.1-0ubuntu6

---------------
gnome-desktop (1:2.32.1-0ubuntu6) natty; urgency=low

  * debian/patches/01_desktopfile_gettext.patch:
    - the Gettext-Domain key can be a X-GNOME one (lp: #587485).
 -- Sebastien Bacher <email address hidden> Wed, 13 Apr 2011 11:23:46 +0200

Changed in gnome-desktop (Ubuntu Natty):
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) on 2011-08-03
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers