gnome-settings-daemon crashed with SIGSEGV in gnome_bg_draw()

Bug #522639 reported by Stefan Kriwanek (Divan) on 2010-02-16
142
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Fix Released
Medium
gnome-desktop (Fedora)
Fix Released
Medium
gnome-desktop (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-settings-daemon

For a few days now the Gnome desktop shows up in some default style after booting and I find the following in dmesg:

[ 47.974605] gnome-settings-[1789]: segfault at 7fcb18b12000 ip 00007fcb21b1f0c4 sp 00007fffd05aa050 error 7 in libgnome-desktop-2.so.17.0.1[7fcb21b09000+28000]

This happens again after every logon:
[ 503.640707] gnome-settings-[2356]: segfault at 7f3753630000 ip 00007f375c63d0c4 sp 00007fff53042d40 error 7 in libgnome-desktop-2.so.17.0.1[7f375c627000+28000]

However, running gnome-appearance-properties (which runs gnome-settings-deamon again) restores the humanity style and doesn't produce any errors in dmesg. Starting gnome-settings-deamon by hand shows:

(gnome-settings-daemon:2627): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

ProblemType: Crash
Architecture: amd64
Date: Tue Feb 16 15:02:41 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
Package: gnome-settings-daemon 2.29.90-0ubuntu1
ProcCmdline: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
ProcEnviron:
 PATH=(custom, user)
 LANG=de_DE.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18-generic
SegvAnalysis:
 Segfault happened at: 0x7f1fda6640c4: mov %sil,(%rdx)
 PC (0x7f1fda6640c4) ok
 source "%sil" ok
 destination "(%rdx)" (0x7f1fd1657000) in non-writable VMA region: 0x7f1fd1657000-0x7f1fd1662000 r-xp /usr/lib/gnome-settings-daemon-2.0/libhousekeeping.so
SegvReason: writing VMA /usr/lib/gnome-settings-daemon-2.0/libhousekeeping.so
Signal: 11
SourcePackage: gnome-settings-daemon
StacktraceTop:
 ?? () from /usr/lib/libgnome-desktop-2.so.17
 gnome_bg_draw ()
 gnome_bg_create_pixmap ()
 ?? ()
 g_closure_invoke ()
Title: gnome-settings-daemon crashed with SIGSEGV in gnome_bg_draw()
Uname: Linux 2.6.32-13-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (gnome-settings-daemon:2189): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2210): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

abrt 1.0.0 detected a crash.

Attached file: backtrace
cmdline: /usr/libexec/gnome-settings-daemon
component: gnome-settings-daemon
executable: /usr/libexec/gnome-settings-daemon
kernel: 2.6.31.9-174.fc12.x86_64
package: gnome-settings-daemon-2.28.1-10.fc12
rating: 4
reason: Process was terminated by signal 11

Created attachment 381629
File: backtrace

Crash in gnome-desktop

I think we probably need to ensure that rect is entirely contained in the pixbuf extents, in pixbuf_draw_gradient

*** Bug 552232 has been marked as a duplicate of this bug. ***

*** Bug 552083 has been marked as a duplicate of this bug. ***

I've noticed that since the crash gnome-settings-daemon does not
start (crashes each time) when I log in (e.g. fonts in gnome-panel
& nautils are weirdly huge). Relatively quick workaround is to
open the "Change desktop background" dialog (settings daemon is
launched) and restart nautilus.

Before the first crash it was all OK. Any idea which settings
cause these crashes? Can I do some quick cleanup which could help
me to get rid of this?

run it under gdb and see where it crashes ?

I've already submitted the backtrace to my original bug:

    https://bugzilla.redhat.com/attachment.cgi?id=381534&action=edit

It fails in the pixbuf_draw_gradient you mention in comment #3.
Sorry, I don't know any details about what this function does, so
I'm not able to figure our what setting could cause these crashes.

*** Bug 552686 has been marked as a duplicate of this bug. ***

*** Bug 553202 has been marked as a duplicate of this bug. ***

gnome-desktop-2.28.2-3.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update gnome-desktop'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F12/FEDORA-2010-0469

gnome-desktop-2.28.2-3.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

visibility: private → public
visibility: public → private

StacktraceTop:
 pixbuf_draw_gradient (pixbuf=<value optimized out>,
 gnome_bg_draw (bg=0x196e430, dest=0x19db720,
 gnome_bg_create_pixmap (bg=0x196e430,
 draw_background (manager=0x194fac0, use_crossfade=0)
 g_closure_invoke ()

Changed in gnome-settings-daemon (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

The issue is gone since yesterday (02/17) - gnome-settings-daemon now runs correctly on boot.

However, it still reports the failed assertion.

Sorry, I have to correct myself:

There's no assertion anymore.

Instead, gnome-settings-daemon does load correctly on boot if and only if there's no monitor connected to the VGA port on boot (notebook).

visibility: private → public
summary: - [lucid] gnome-settings-daemon crashed with SIGSEGV in gnome_bg_draw()
+ gnome-settings-daemon crashed with SIGSEGV in gnome_bg_draw()
Sebastien Bacher (seb128) wrote :
affects: gnome-settings-daemon (Ubuntu) → gnome-desktop (Ubuntu)
Changed in gnome-desktop (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Triaged
affects: gnome-settings-daemon (Fedora) → gnome-desktop (Fedora)
Sebastien Bacher (seb128) wrote :

I've uploaded a fix for this issue

Changed in gnome-desktop (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.29.92-0ubuntu2

---------------
gnome-desktop (1:2.29.92-0ubuntu2) lucid; urgency=low

  * debian/patches/90_upstream_gsd_crash.patch:
    - change from https://bugzilla.gnome.org/606456 to fix a gsd crash issue
      (lp: #522639)
 -- Sebastien Bacher <email address hidden> Tue, 16 Mar 2010 15:16:40 +0100

Changed in gnome-desktop (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Fix Released
Changed in gnome-desktop (Fedora):
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.