GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

Bug #384439 reported by Սահակ on 2009-06-07
84
This bug affects 15 people
Affects Status Importance Assigned to Milestone
GStreamer
Unknown
Medium
gnome-desktop (Ubuntu)
Medium
Chris Coulson

Bug Description

Binary package hint: gnome-settings-daemon

Every time gnome-settings-daemon starts it leaves a critical error message in .xsession-errors file:

(gnome-settings-daemon:5303): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

ProblemType: Bug
Architecture: amd64
Date: Sun Jun 7 05:14:20 2009
DistroRelease: Ubuntu 9.10
LiveMediaBuild: Ubuntu 9.10 "Karmic Koala" - Alpha amd64 (20090606)
Package: gnome-settings-daemon 2.27.1-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: gnome-settings-daemon
Uname: Linux 2.6.30-8-generic x86_64

Սահակ (petrosyan) wrote :
dino99 (9d9) wrote :

same thing with Jaunty 32

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-settings-daemon (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Medium
status: New → Incomplete
franciscovega (franciscovega) wrote :

Hello,

I'd got the same problem.
Have a look here https://bugs.launchpad.net/ubuntu/+source/gstreamer0.10-ffmpeg/+bug/366232.
It solved my problem simply by removing a *.so in gstreamer library which causes a gnome-settings-daemon error.

AMD 64 (x86_64)
Ubuntu Studio 9.04
2.6.29.4-rt16

Sebastien Bacher (seb128) wrote :

did you note the .so you moved and was that a local installated one?

franciscovega (franciscovega) wrote :

The file i removed was /usr/lib/gstreamer-0.10/libgstladspa.so

I use LADSPA effects on Ubuntu Studio and removing the libgstladspa.so didn't affect them.

Sebastien Bacher (seb128) wrote :

could you get a stacktrace a requested before or should we close the bug?

affects: gnome-settings-daemon (Ubuntu) → gstreamer0.10 (Ubuntu)
Changed in gstreamer0.10 (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Hernando Torque (htorque) wrote :

Removing that file doesn't change a thing here. Attaching a strace of g-s-d until the messages appear (no crash here, so no bt).

gnome-settings-daemon:
  Installed: 2.27.1-0ubuntu1
  Candidate: 2.27.1-0ubuntu1

Hernando Torque (htorque) wrote :

Output of gnome-settings-daemon --no-daemon --debug attached.

Hernando Torque (htorque) wrote :
Sebastien Bacher (seb128) wrote :

there is no stacktrace there, opening a bug on bugzilla.gnome.org where the code writters will read it could be useful

Hernando Torque (htorque) wrote :

Finally got a stacktrace (some debugging symbols seem to be missing, don't know which ones).

Hernando Torque (htorque) wrote :

Franciscovega's bug seems unrelated and happens earlier than the error message in this bug. Also there is no segmentation fault. Xrandr plugin just causes above mentioned errors.

Looking at the strace output right before the messages...

[pid 4818] 01:06:07.208872 access("/home/test/.config/monitors.xml.desired", F_OK) = -1 ENOENT (No such file or directory)
[pid 4818] 01:06:07.208943 access("/home/test/.config/monitors.xml", F_OK) = -1 ENOENT (No such file or directory)
[pid 4818] 01:06:07.209003 access("/home/test/.config/monitors.xml.desired", F_OK) = -1 ENOENT (No such file or directory)
[pid 4818] 01:06:07.209073 write(2, "\n(gnome-settings-daemon:4818): G"..., 99
(gnome-settings-daemon:4818): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
) = 99

...this bug might be connected: https://bugs.launchpad.net/ubuntu/+source/gnome-desktop/+bug/314406 (also deals with those ~/.config/monitors.xml files).

Changed in gstreamer:
status: Unknown → New
dino99 (9d9) on 2009-06-14
Changed in gstreamer0.10 (Ubuntu):
status: Incomplete → New
status: New → Incomplete
affects: gstreamer0.10 (Ubuntu) → gnome-desktop (Ubuntu)
Changed in gnome-desktop (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: Incomplete → Triaged
Hernando Torque (htorque) wrote :

The error is caused by the patch 100_load_desired_settings.patch by adding:

/* return NULL if the file doesn't exist */
if (!g_file_test (filename, G_FILE_TEST_EXISTS))
{
    result = NULL;

    return result;
}

to the function configurations_read_from_file() in libgnome-desktop/gnome-rr-config.c, because it leaves the error passed to the function uninitialized which later causes the error in gnome-settings-deamon's xrandr-plugin (gsd-xrandr-manager.c, function apply_configuration_from_filename()).

Removing that part makes the errors go away but for sure that's not a proper fix. No patch attached since I don't know how useful patching a patch is...

tekstr1der (tekstr1der) wrote :

Still seeing this error regularly in Karmic beta. Any progress toward a fix yet?

Is any more debugging information needed from users?

Kristie (mygp4u2nv) wrote :

(gnome-settings-daemon:4822): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
(gnome-settings-daemon:4822): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
aborting and using fallback: /usr/bin/metacity
Window manager warning: Failed to read saved session file /home/kristie/.config/metacity/sessions/10ef621a955cedd34125601806241223200000048080001.ms : Failed to open file '/home/kristie/.config/metacity/sessions/10ef621a955cedd34125601806241223200000048080001.ms ': No such file or directory
** (gnome-panel:4845): DEBUG: Adding applet 0.
** (gnome-panel:4845): DEBUG: Initialized Panel Applet Signaler.
** (nautilus:4846): WARNING **: No marshaller for signature of signal 'UploadFinished'
** (nautilus:4846): WARNING **: No marshaller for signature of signal 'DownloadFinished'
** (gnome-panel:4845): DEBUG: Adding applet 1.
** (gnome-panel:4845): DEBUG: Adding applet 2.
** (gnome-panel:4845): DEBUG: Adding applet 3.
** (gnome-panel:4845): DEBUG: Adding applet 4.
** (gnome-panel:4845): DEBUG: Adding applet 5.
** (gnome-panel:4845): DEBUG: Adding applet 6.
Initializing nautilus-gdu extension
** (gnome-panel:4845): DEBUG: Adding applet 7.
** (gnome-panel:4845): DEBUG: Adding applet 8.
** (gnome-panel:4845): DEBUG: Adding applet 9.
** (gnome-panel:4845): DEBUG: Adding applet 10.
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Chris Hermansen (c-hermansen) wrote :

I am "suddenly" having problems with launching applications in 9.10 (perhaps an unrelated issue) but I see a fresh copy of .xsession-errors containing something very similar to this (latest attached) on session startup. May have something to do with gstreamer but I have not started any audio / video apps at this point.

joankk (jvillaraco) wrote :

I'm getting the same error in the same point of bug, just add an information (that's why I write). I debug output from the daemon with: 'gnome-settings-daemon --no-daemon --debug' and got:
** (gnome-settings-daemon:2146): DEBUG: Activating xrandr plugin
** (gnome-settings-daemon:2146): DEBUG: Starting xrandr manager

(gnome-settings-daemon:2146): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
** (gnome-settings-daemon:2146): DEBUG: GnomeSettingsManager: emitting plugin-activated xrandr
** (gnome-settings-daemon:2146): DEBUG: Plugin xrandr: active
** (gnome-settings-daemon:2146): DEBUG: GnomeSettingsModule 0x81538c8 initialising
** (gnome-settings-daemon:2146): DEBUG: Loading /usr/lib/gnome-settings-daemon-2.0/libxsettings.so
** (gnome-settings-daemon:2146): DEBUG: Registering GnomeXSettingsPlugin
** (gnome-settings-daemon:2146): DEBUG: Creating object of type GnomeXSettingsPlugin
** (gnome-settings-daemon:2146): DEBUG: GnomeXSettingsPlugin initializing
** (gnome-settings-daemon:2146): DEBUG: Activating xsettings plugin
** (gnome-settings-daemon:2146): DEBUG: Starting xsettings manager
** (gnome-settings-daemon:2146): DEBUG: GnomeSettingsManager: emitting plugin-activated xsettings
** (gnome-settings-daemon:2146): DEBUG: Plugin xsettings: active
** (gnome-settings-daemon:2146): DEBUG: GnomeSettingsModule 0x8153918 initialising

I'm using propietary nvidia drivers in package nvidia-glx-185 and if I don't start gnome-settings-daemon everything goes right, when I start the binary the screen resolution becomes to 800x600.

Regards,

Joan.

Timo Aaltonen (tjaalton) wrote :

Still the same in lucid. Upstream closed the bugreport as 'notgnome', ie. because it's due to that ubuntu patch.

Chris Coulson (chrisccoulson) wrote :

This is fixed in bzr now

Changed in gnome-desktop (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.29.90-0ubuntu3

---------------
gnome-desktop (1:2.29.90-0ubuntu3) lucid; urgency=low

  [ Chris Coulson ]
  * debian/patches/100_load_desired_settings.patch:
    - Update to ensure that gnome_rr_config_apply_from_filename_with_time()
      always sets a GError when the call fails. Thanks to James Westby for
      contributing to this too (LP: #384439)

  [ Didier Roche ]
  * debian/patches/02_add_wallpaper_cache.patch:
    - keep maximum quality when saving the cached image in jpeg
    - support multimonitor: only clean wallpaper cache with same
      transformation and resolution
    - some refactoring, cleanage
 -- Didier Roche <email address hidden> Wed, 17 Feb 2010 19:19:03 +0100

Changed in gnome-desktop (Ubuntu):
status: Fix Committed → Fix Released
Chris Coulson (chrisccoulson) wrote :

Hmmm, we've identified and fixed 2 code paths that cause this message, but I'm still seeing it on my laptop.

Changed in gnome-desktop (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Chris Coulson (chrisccoulson)
status: Fix Released → In Progress
Hernando Torque (htorque) wrote :

Seems fixed for me (no messages while not having any monitor configuration files in ~/.config). Are you sure it's coming from the xrandr-plugin (g-s-d --debug might help)?

Chris Coulson (chrisccoulson) wrote :

I've fixed the remaining code path which causes this issue in bzr now

Changed in gnome-desktop (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.29.92-0ubuntu3

---------------
gnome-desktop (1:2.29.92-0ubuntu3) lucid; urgency=low

  * debian/patches/100_load_desired_settings.patch:
    - Fix another case where gnome_rr_config_apply_from_filename_with_time
      can fail without setting a GError, and really fix LP: #384439
 -- Chris Coulson <email address hidden> Sat, 27 Mar 2010 23:54:00 +0000

Changed in gnome-desktop (Ubuntu):
status: Fix Committed → Fix Released
Changed in gstreamer:
importance: Unknown → Medium
status: New → Unknown
JimmytheGeek (jamesaffeld) wrote :

SOLVED
I ran into this shortly after updating 9.10, got the black box in place of login screen, following log messages in /var/log/gdm/:0-greeter.log

(gnome-settings-daemon:3419): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed

(gnome-settings-daemon:3419): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
Window manager warning: Failed to read saved session file /var/lib/gdm/.config/metacity/sessions/10a9a99fd3e4ce7c9b128608721774271800000034130008.ms: Failed to open file '/var/lib/gdm/.config/metacity/sessions/10a9a99fd3e4ce7c9b128608721774271800000034130008.ms': No such file or directory

/etc/motd told me system load was over 5, saw 4-5 gdm processes each eating 15-27% cpu.

I figured it was a faulty update, possibly of my evil binary nvidia driver. Turns out /tmp was full! Clearing it solved the problem.

launchpadmember (lpuser1138) wrote :

As of 2012 Wed, July 11, This bug is still happening in Ubuntu 11.04 Natty 64Bit

My themes are broken, and nothing appears to work in order to get the gnome-settings-daemon working properly again.

If I attempt to fix the incorrect desktop theme by right clicking on the desktop and selecting "Change Desktop Background" I get the following error message:
Unable to start the settings manager 'gnome-settings-daemon'.
Without the GNOME settings manager running, some preferences may not take effect. This could indicate a problem with DBus, or a non-GNOME (e.g. KDE) settings manager may already be active and conflicting with the GNOME settings manager.

Here is the command issued from the CLI:
sudo gnome-settings-daemon

Here is its output:
** (gnome-settings-daemon:6805): WARNING **: Failed to acquire org.gnome.SettingsDaemon

** (gnome-settings-daemon:6805): WARNING **: Could not acquire name

I've tried many suggested workarounds but nothing is fixing this problem.
Do Mint or Archlinux suffer from this problem? I need a distro that works.

Sebastien Bacher (seb128) wrote :

@lpuser1138: stop commenting on every random bug you can find

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.