gnome-display-properties mistakenly requires logout to increase resolution

Bug #365210 reported by Scott Bronson on 2009-04-22
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-desktop
Fix Released
Medium
gnome-desktop (Ubuntu)
Low
Ubuntu Desktop Bugs
Jaunty
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-control-center

Open gnome-display-properties and reduce your resolution.

Now try to increase it back to the starting resolution. gnome-display-properties will curtly tell you, "Please log out and log back in again". No explanation of why.

Now quit gnome-display-properties, start it again, and choose your starting resolution. It works! The "log out and log back in again" is just a ruse.

This happens on both my GMA4500 laptop and my Radeon 3650 (open source driver) desktop. It's a regression in Jaunty -- Intrepid works properly.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
Package: gnome-control-center 1:2.26.0-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
Uname: Linux 2.6.28-11-generic x86_64

Scott Bronson (bronson) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, confirming it wants to enable virtual settings in those cases for no reason

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → Low
status: New → Confirmed
motty (mottyporat) wrote :

I agree.
If I mistakenly choose a resolution larger than my virtual maximum, it rightfully asks to log out (but without an explanation). Then I cancel the erroneous choice (I don't log out) and choose a setting that fits in the virtual maximum, but the same message keeps showing.
Closing & rerunning gnome-display-settings solves it. (Which makes this bug the least one, among many more bugs in gnome-display-settings since Jaunty upgrade).

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Alberto Milone (albertomilone) wrote :

I have provided upstream with a fix. See the patch in the upstream bug report.

affects: gnome-control-center (Ubuntu) → gnome-desktop (Ubuntu)
Changed in gnome-desktop:
status: Unknown → New
Alberto Milone (albertomilone) wrote :

Let's pick up upstream's solution (which does the same thing as my patch but in a different way) in commit 3f811a611185a3bdbb6b6d4c19590bd26ae1dc82

Changed in gnome-desktop:
status: New → Unknown
Changed in gnome-desktop:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in gnome-desktop (Ubuntu Jaunty):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Fix Committed
Changed in gnome-desktop (Ubuntu):
assignee: Alberto Milone (albertomilone) → Ubuntu Desktop Bugs (desktop-bugs)
Martin Pitt (pitti) on 2009-05-04
tags: added: regression-release
Martin Pitt (pitti) wrote :

Accepted gnome-desktop into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Pedro Villavicencio (pedro) wrote :

Proposed package indeed fix the bug there's no dialog saying that you need to logout in order to increase the resolution again, bug is fixed, thanks all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-desktop - 1:2.26.1-0ubuntu2

---------------
gnome-desktop (1:2.26.1-0ubuntu2) jaunty-proposed; urgency=low

  * debian/patches/90_git_change_reprobe_when_required.patch:
    - git change to refresh correctly the screen settings
      (lp: #365210)

 -- Sebastien Bacher <email address hidden> Mon, 04 May 2009 14:42:53 +0200

Changed in gnome-desktop (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

copied to karmic as well

Changed in gnome-desktop (Ubuntu):
status: Triaged → Fix Released
Changed in gnome-desktop:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.