nautilus draws black background when scrolled

Bug #237562 reported by Raja Mukherji on 2008-06-05
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gnome-desktop
Expired
Medium
gnome-desktop (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

After setting the background image for all windows to an image file (tried both png and jpg), I find that scrolling a nautilus window in icon mode will display a black background instead of the selected image. If the contents are long enough, then the background alternates between the correct image and black as I scroll. The amount of the background corresponding to the correct background image is the initial size of the nautilus icon view window and resizing the nautilus window draws a black background around the original image background.

Using Ubuntu 8.04, nautilus package 1:2.22.2-0ubuntu4

Raja Mukherji (rajamukherji) wrote :
Raja Mukherji (rajamukherji) wrote :

After just checking, (not sure why I didn't think of it earlier), the problem does not occur with the background patterns included with nautilus.

Pedro Villavicencio (pedro) wrote :

Confirming, it only happens with additional patterns (backgrounds) not with the ones shipped in nautilus by default.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

I was able to reproduce this with trunk also, will look upstream, thanks.

Changed in nautilus:
status: Confirmed → Triaged
Changed in gnome-desktop:
status: Unknown → New
Jeff Sereno (jsereno) wrote :

Actually, the problem DOES occur with the stock Nautilus patterns as well - make the window size SMALLER than the dimensions of the stock background tile image, close and re-open the Nautilus window and you will see the rendering issue. I noted this on my EeePC701 with its diminutive screen dimensions when I resized a window small enough to only fit in two icons, closed it, reopened it and then scrolled.

The black (or corrupted) areas of the background you will observe match the dimensions of the background image exactly, ie: a background 1024x768 in size inside a Nautilus window 640x480 in size will have black/corruption from pixel 641 through to 1024 horizontally and pixel 481 to 768 vertically. When the background wraps, it will render correctly, but again only to the original 640x480 dimensions of the window where it will black/corrupt again.

Make the window larger, then close it and re-open it and the black/corruption is gone (simply because the background image dimensions are smaller than that of the window, so it therefore tiles properly now).

I've observed this in Ubuntu 9.04 and 9.10. The black appears in Virtualbox and Intel gfx adapters and full-on corrupted/copied chunks of video memory appear in place of the black when using NVidia gfx adapters.

Changed in gnome-desktop:
status: New → Invalid
Changed in gnome-desktop:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.