[soundnua] moving running input stream fails

Bug #984637 reported by David Henningsson on 2012-04-18
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Conor Curran
Precise
High
Unassigned

Bug Description

Steps to reproduce:

1) Connect a USB headset so you have at least two sound card inputs
2) Start your favorite recording program - I've tested with both audacity and mumble
3) Make sure this recording program is set to record from pulseaudio and start recording
4) Open gnome-control-center and change the default sound input from one card to the other.
At this point, these two things can be observed:
  Problem A) The input stream is not moved from one input to the other.
  Problem B) The input gain of the source we move from, is changed.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.0-0ubuntu7
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic i686
ApportVersion: 2.0.1-0ubuntu3
Architecture: i386
Date: Wed Apr 18 09:34:16 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=sv_SE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3
 deja-dup 22.0-0ubuntu2
 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu1

David Henningsson (diwic) wrote :
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Conor Curran (cjcurran)
importance: Undecided → Low
tags: added: soundnua
David Henningsson (diwic) wrote :

Raising importance - this is a generic problem and a regression compared to the old sound settings UI

Changed in gnome-control-center (Ubuntu):
importance: Low → High
David Henningsson (diwic) wrote :

...and I have also verified the problem with two different 12.04 installations.

Conor Curran (cjcurran) on 2012-04-18
Changed in gnome-control-center (Ubuntu):
status: New → In Progress
Conor Curran (cjcurran) on 2012-04-19
Changed in gnome-control-center (Ubuntu):
importance: High → Critical
Conor Curran (cjcurran) wrote :

a) I can't reproduce this
b) I can reproduce this, working on a fix now.

Changed in gnome-control-center (Ubuntu):
status: In Progress → Confirmed
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :

Conor, that's not a blocker for the release viewed from Ubuntu, I'm lowering back the importance to High

Changed in gnome-control-center (Ubuntu):
importance: Critical → High
Conor Curran (cjcurran) wrote :
Conor Curran (cjcurran) wrote :

On second testing I can reproduce a). The recording program needs to be recording, changing the default input from control center mid recording reproduces the bug. I will look into this first thing in the morning. Agreed Seb, it's definitely not critical.

David Henningsson (diwic) wrote :

Okay, I've now been able to fix the bug that causes the running streams not to be moved when the default source is changed.
From looking at the code, it seems to be an upstream bug as well, and might not be a regression for us - if so, it's strange nobody has cared about it until now.
The code can be merged from here:
http://bazaar.launchpad.net/~diwic/+junk/soundnua-lp984637/revision/31

Changed in gnome-control-center (Ubuntu Precise):
status: New → In Progress
importance: Undecided → High
Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed

Hello David, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
David Henningsson (diwic) wrote :

I can confirm that the bug is fixed in the proposed version of gnome-control-center 1:3.4.1-0ubuntu2.

tags: added: verification-done
removed: verification-needed
Conor Curran (cjcurran) on 2012-05-04
Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.1-0ubuntu2

---------------
gnome-control-center (1:3.4.1-0ubuntu2) precise-proposed; urgency=low

  * debian/patches/deal_with_null_ssid.patch: don't try to dereference ssid when
    it's NULL (i.e. for non-broadcasting APs). (LP: #908670, #912948)

  [ Conor Curran & David Henningsson ]
  * debian/patches/96_sound_nua_panel.patch:
    - updated version including fixes for
    - "moving running input stream fails" (lp: #984637)
    - "peak detection on input tab doubles up on level"(lp: #987626)
    - "SIGSEGV in gvc_mixer_ui_device_get_description()" (lp: #982495)
 -- Mathieu Trudel-Lapierre <email address hidden> Fri, 27 Apr 2012 12:04:53 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.