missing "apply system-wide" in network>proxy

Bug #967978 reported by Marwin Terence Lao on 2012-03-29
52
This bug affects 8 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

1) 12.04 LTS
2) gnome-control-center version 3.3.90
3) Set the system-wide proxy settings to access the Internet
4) Cannot find the "Apply system-wide" (or similar) option.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.3.90-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
NonfreeKernelModules: wl
ApportVersion: 1.93-0ubuntu2
Architecture: i386
Date: Thu Mar 29 12:15:11 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta i386 (20120301)
ProcEnviron:
 LANGUAGE=en_PH:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_PH.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to precise on 2012-03-29 (0 days ago)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.2-0ubuntu2
 deja-dup 21.90-0ubuntu1
 gnome-bluetooth 3.2.2-0ubuntu2
 indicator-datetime 0.3.90-0ubuntu1

Marwin Terence Lao (marwin-lao) wrote :
Jeremy Bicha (jbicha) wrote :

I believe this has been fixed in Ubuntu 12.04. The "Apply system wide" button shows up fine here.

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Andrei (andrei-doom) wrote :

You believe wrong. Up to date on packages, still now freaking button. Double-check next time.

Jeremy Bicha (jbicha) wrote :

Andrei, you don't have to get upset. Here's what's on my computer.

Tom (thombend) wrote :

The button shows up in neither Unity nor Unity-2d desktops using the most current available packages.

Tom (thombend) wrote :

Status is bogus - no fix was released, nor was any rigorous testing even involved. This was a "works for me" which is utterly irresponsible for an LTS candidate.

Jeremy Bicha (jbicha) wrote :

Tom, Andrei,

I've verified that "Apply system wide" shows up on multiple Ubuntu 12.04 computers. Maybe you did an incorrect dist-upgrade and removed something important.

I went ahead and reopened this bug even though I believe the default installation is working as it's supposed to.

Changed in gnome-control-center (Ubuntu):
status: Fix Released → Confirmed
Matt Fischer (mfisch) wrote :

The button is only shown if you are in the admin group. On one of my laptops, my user is, on another fresh install, it is not. I do not know why that is, but the logic needs to be re-examined:

static gboolean
is_admin ()
{
        gid_t groups [1024];
        int i, ngroups;
        struct group *admin;

        admin = getgrnam ("admin");
        if (admin == NULL)
                return FALSE;

        ngroups = getgroups (1024, groups);
        if (ngroups < 0) {
                perror ("getgroups");
                return FALSE;
        }

        for (i = 0; i < ngroups; ++i) {
                if (groups[i] == admin->gr_gid)
                        return TRUE;
        }

        return FALSE;
}

        /* System wide proxy settings */
        if (is_admin ()) {
                g_signal_connect (G_OBJECT (gtk_builder_get_object (panel->priv->builder, "system_proxy_button")), "clicked",
                                  G_CALLBACK (on_proxy_apply_system_wide), panel);
        } else
                gtk_widget_hide (GTK_WIDGET (gtk_builder_get_object (panel->priv->builder, "system_proxy_button")));

Perhaps the cause is this change?
"Move "admin" group to "sudo""
https://bugs.launchpad.net/ubuntu/+source/policykit-1/+bug/893842

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
Tom (thombend) wrote :

Indeed:
https://wiki.ubuntu.com/PrecisePangolin/TechnicalOverview/Beta2#Other

This would certainly explain that behavior. Could be quite problematic in LDAP/AD environments.

Jeremy Bicha (jbicha) on 2012-04-06
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Committed
Michael Goth (fnd-x) wrote :

I updated Ubuntu 11.04 to 12.04 Beta 2 an also couldn't find the "appy system wide" button. It turned out, the "admin" group was called "adm". Renaming it to "admin" made the button visible. This may be useful as a short-term workaround.

Andrei (andrei-doom) wrote :

Still, this is utterly unacceptable, as Tom previously said. I'm not trying to be an ass here, but ever since I've started testing the 12.04 release, I've encountered only idiotic problems and solutions that have very poor implementation. I was quite shocked that solutions like these are present within a distro that has this amount of praise. It's quite disappointing...

Tom (thombend) wrote :

Thank you, Matt for tracking down the source of the issue, thanks much, Jeremy, for the quick fix:

http://bazaar.launchpad.net/~ubuntu-desktop/gnome-control-center/ubuntu/revision/429

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.0-0ubuntu5

---------------
gnome-control-center (1:3.4.0-0ubuntu5) precise; urgency=low

  [ Jeremy Bicha ]
  * debian/patches/50_ubuntu_systemwide_prefs.patch:
    - Network proxy: Show "apply system wide" for sudo group too
      (LP: #967978, LP: #893842)

  [ Michael Terry ]
  * debian/patches/accounts_handle_system_user.patch:
    - Disable user controls when no user is selected, to prevent crashes
      in code that doesn't expect that situation. LP: #908140
 -- Michael Terry <email address hidden> Mon, 09 Apr 2012 22:13:55 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
David R. Hedges (p14nd4) wrote :

This is still broken for me on a fresh install today, with gnome-control-center 1:3.4.0-0ubuntu5.

I believe the problem may lie here:
        struct group *admin;
        struct group *sudo;

        admin = getgrnam ("admin");
        if (admin == NULL)
                return FALSE;

        sudo = getgrnam ("sudo");
        if (sudo == NULL)
                return FALSE;

---------
Since the 'admin' group doesn't exist on my system, the function returns false immediately, short-circuiting the possibility of checking for the sudo group.

The attached patch to cc-network-panel.c seems to have done the trick on my system, but presumably you'll have to merge that into the debian patch directory.

George Swann (g-swann) wrote :

This is still broken for me as well after updating to gnome-control-center 1:3.4.0-0ubuntu5

David Rando (david-rando) wrote :

I had this problem suddenly after an update (update released yesterday) because i didn't have it before. Checking it, i saw that my user was in the admin group, but no in the sudo group, so after adding the user to the group, i have the button again.

Marcelo (marcelo-dacruz) wrote :

My user is a member of "admin", "adm", "sudo", ... However, I still experience this issue with gnome-control-center 1:3.4.0-0ubuntu6. In my case, I started experiencing this problem with an update about a week ago.

Marcelo (marcelo-dacruz) wrote :

Ok, this is weird... I just tried the following:
1) run "sudo gnome-control-center"
2) you'll see the network configuration is empty (nothing weird here)
3) Exit the application
4) Now, run gnome-control-center again, this time with your default user (i.e. no sudo)

After following these steps, the issue is gone in my environment.

David R. Hedges (p14nd4) wrote :

This appears to be fixed by bzr revision 443: http://bazaar.launchpad.net/~ubuntu-desktop/gnome-control-center/ubuntu/revision/443 , which is packaged in 1:3.4.0-0ubuntu7 and later (including 1:3.4.1-0ubuntu1).

Thanks!

Hi,
  Hopefully it's ok to ask this after the bug has been marked as fixed...

  I have renamed the adm group to be admin to get the button to appear and consequently get the proxy setting working. As this bug has now been fixed can someone tell me what groups my user should be part of?

  My setup is a completely fresh install of 64bit beta 2 from the beta 2 ISO. The only change I made to the groups was to move adm to admin. So...
  - Should I now move the admin group back to adm?
  - Should I expect there to be a sudo group?
  - When it says Fixed Released does that mean I should have received an update through Update Manager to resolve this issue or will it only appear in the final release?

Thank you for your help,
Alex

David R. Hedges (p14nd4) wrote :

It's my understanding that in 12.04, you should no longer need to be a member of the admin or adm group, just sudo: https://wiki.ubuntu.com/PrecisePangolin/TechnicalOverview/Beta2#Other . You should definitely expect a 'sudo' group.

In general, when a bug status is 'fix released' I believe that means it's supposed to be fixed in a package currently available in some release. (I think it'd be more useful if they indicated specifically which package version it was supposed to be fixed in, but in any event, for this bug, as I noted, I believe it's actually fixed in 1:3.4.0-0ubuntu7 .) This was pushed out at least a few days ago. You can check what version of gnome-control-center is installed on your system by running dpkg -l gnome-control-center.

David,
  Thank you for your help, it's much appreciated! I've renamed the admin group back to adm and I have the fixed version of gnome-control-center, everything is working fine.

Cheers,
Alex

Eam Nay (eamnay) wrote :

hi,

Can someone please help me with this? I have enter the proxy, but can't find where to enter a username for the proxy. The user I use to login to ubuntu 12.04 is different to the proxy user.

I'm a noob to linux.

Thanks,

Eam

Oliver Dungey (oliver-dungey) wrote :

Hi all,

Just been trying this functionality out on 12.04 64 bit. I can report that there is a an 'Apply system wide button' but it does not work i.e. click the button, open a new terminal and run set | grep proxy and you see the old value. Should I report this as a new issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers